Print Page | Close Window

Crash of DUAL MODE at AsRock 970 PRO3

Printed From:
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
Printed Date: 20 May 2024 at 4:17am
Software Version: Web Wiz Forums 12.04 -

Topic: Crash of DUAL MODE at AsRock 970 PRO3
Posted By: crocuzz
Subject: Crash of DUAL MODE at AsRock 970 PRO3
Date Posted: 09 May 2016 at 3:04pm

Motherboard; AsRock 970 pro3
CPU: AMD FX-4300 Quad-Core Processor
HDD: 2 x  Western Digital SATA III 1Tb , ACHI mode
Video: GIGABYTE R7 260X OC 1GB [AMD R7 260x series] 
DIMM3: Crucial Balistix Sport BLS4G3D1609DS1S00 1600Mhz [800Mhz] 9-9-9-24  [ 4Gb x 2, total 8Gb ]. These Crucial DIMM3 two modules comply with international 1600Mhz specification 9-9-9-24 [28 in standard].

Lyrics. I am not a gamer. But I overclocked DIMM3 only from 1600 Mhz till 1966 Mhz for 2 years. Motherboard worked perfectly. I mistakenly tried to flash a motherboard or video card BIOS by uncomparable driver.  And I interrupted the operation.  The electricity became down in that moment. After the electrical mishap the motherboard BIOS refused to start. I set the original v1.9 BIOS driver via the programmer, not from HDD , not from the flash stick. Than I upgraded BIOS till v2.0 from DOS. --

Problem: the memory DUAL MODE does not work with DIMM3 1600Mhz 4GB x 2 even it was fine till the electrical mishap. It occurred that motherboard speaker is beeping when I put the single DDR3 in the B2 slot. I changed DIMM3 into the similar Crucial kit. 

ASROCK 970 PRO3 TEST. BIOS voltages are set for the default values from AUTO. No overclocking. All useless motherboard settings [spread spectrum/ /c1/c6/audio/video to RAM] are OFF.  

Memory config 1:  A1+B1. Reaction: BIOS shows single memory. Win 10 or 8.1  [x64] shows 3.97Gb used from 8GB . 

CPU-Z untility shows DIMM3 modules work at 777 Mhz each instaed of 800 Mhz standard.  CPU works less 5% from standard 3800 Mhz. Debug codes B2 mostly.

Memory config 2: A2+B2. Reaction: BIOS shows single memory. Win 10 or 8.1 [x64] shows 3.97Gb used from 8GB.

CPU-Z untility shows DIMM3 modules work at 777 Mhz each instaed of 800 Mhz standard.  CPU works less 5% from standard 3800 Mhz. Debug codes B2 mostly.

Memory config 3: A1+A2 [SINGLE STANDARD mode]. Reaction: BIOS shows SINGLE memory mode. Win 10 or 8.1 shows  [x64]   8Gb full memory capacity.

CPU-Z untility shows DIMM3 modules work at 800 standard.  CPU works at standard 3800 Mhz. Debug codes B2 mostly.

I suspect:-

A2 and B2 memory controllers [slots] are out of service 
and / or [less probably]
the BIOS micro controller does not send command for DUAL memory.

Please do not advise standard "clear CMOM" and "remove the battery" "short battery contacts" for 15-20 minutes due to  these standard BIOS clearance operations had been tried by myself.

1. Any engineering solution: how to restore the DUAL MODE in AsRock 970 PRO3?
2. My motherboard age is 2 years 3 months. Does AsRock provide the "global" RMA warranty in the European Union? 

Posted By: crocuzz
Date Posted: 21 May 2016 at 11:48pm
True story: how the AsRock marketing team works in practice.

1. There is no information of any engineering contact at AsRock site, exept for US and India
2. The Central office of As Rock does not know which engineers are exactly
3. I submitted the simple question regarding the controller  for the motherboard. The secretary of the central office of asROck reply was in the style " get way, we do not know about our details".

This is the last time, when I dealt with AsRock in my life.

Posted By: Xaltar
Date Posted: 22 May 2016 at 12:15am
Firstly the memory controller is on the CPU not the motherboard. I am sorry your experience with tech support was not to your satisfaction but I can't believe for an instant that you were deliberately treated with any kind of disrespect or rudeness. I have never in all my dealings with ASRock nor from user accounts here on the forums seen any indication of this kind of behavior. 

ASRock and every other manufacturer out there will not share certain details about the inner workings of their products. There is a significant amount of proprietary information that they either cannot share due to component vendor stipulations (intel/AMD chipsets for example) or proprietary information of their own that gives them a competitive edge over the competition. Refusing to give out this information is policy and not disregard for the end user.

As for your issue there are 2 possible causes. Either:

1. Your CPU's memory controller is damaged or there are bent pins on your CPU
2. Your A2 and B2 slots on your motherboard are damaged.

Check your CPU for bent pins, if none are found then you can begin the RMA process for your board with ASRock or with the reseller you purchased it from. ASRock are very good with honoring their RMA requests and you shouldn't have any issues. 

I can understand your frustration, there is nothing more annoying than a persistent problem you cannot solve. If you wish you can submit a new support ticket containing a link to this thread for Tech support to look at but I strongly suspect they will give the same advice I just did. 

I hope this helps resolve your issues. Please let us know if you have further questions.


Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -