Print Page | Close Window

Asrock B450 Steel Legend - NVME support

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=26267
Printed Date: 04 Mar 2024 at 2:28am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Asrock B450 Steel Legend - NVME support
Posted By: PatrickL84
Subject: Asrock B450 Steel Legend - NVME support
Date Posted: 07 Aug 2023 at 5:14pm
Hello,
i am using a B450 Steel Legend Board, AM4 Ryzen5 3600, 16GB RAM, RTX 2080 8GB

PCIE1 (PCIe 3.0 x16 slot): RTX 2080 GPU
PCIE4 (PCIe 3.0 x16 slot): LAN 10GBE Mellanox Connect X3 (x4 Mode)
PCIE5 (PCIe 2.0 x1 slot): SATA Controller Card, 6 Port
M2_2 NVME Sandisk Extreme Pro.M2 500GB
M2_1 occupied, because using 10GBE Card in PCIE4 will be disabled

4 of 6 SATA3 Ports connected to SATA-HDD, SATA3_4 SATA3_3 disabled because using M2_2 Slot --> in this configuration all devices were working without problems.

now i bought an WD Black SN770 2TB SSD to upgrade the 500GB Sandisk --> WD Black isnt show up in UEFI,
i noticed that there are "pin missmatch issues with some Boards:
see: https://pg.asrock.com/support/qa/Limited%20Support%20SSD%20List.pdf" rel="nofollow - https://pg.asrock.com/support/qa/Limited%20Support%20SSD%20List.pdf

In the first line the B450 Steel Legend is written, with "limited support" for some M2 SSD (SN770 is in the list)
that means that those M2 SSD are not working completely or working, but with speed limitations?
I considered to change to B550 chipset, but perheps this will not solving my problem.

Finally i need a motherboard wich is working with RTX2080, 10GBE ethernet card (x4 Mode), SATA controller (x1 Mode), 4 useable SATA Ports onboard, and one or two NVMEs



Replies:
Posted By: ASRock_TSD
Date Posted: 11 Aug 2023 at 5:22pm
Dear PatrickL84,
Thank you for the posting.

For this case, due to hardware limitations, WD SN770 can only be supported on M2_2 slot of B450 Steel Legend.
Please update the BIOS to version 4.60 and refer to the following steps to try.
1. Please update the BIOS to 4.60 through Instant Flash.
BIOS 4.60: https://download.asrock.com/BIOS/AM4/B450%20Steel%20Legend" rel="nofollow - https://download.asrock.com/BIOS/AM4/B450%20Steel%20Legend (4.60)ROM.zip
Instant Flash: https://www.asrock.com/support/BIOSIG.asp?cat=BIOS10" rel="nofollow - https://www.asrock.com/support/BIOSIG.asp?cat=BIOS10
2. Boot into BIOS setup and go to Advanced\Storage Configuration, then set ?Force M2_2 to support PCIe type device??to ?Yes??
3. Press ?F10??key to save configuration changes.

Thank you

Yours truly,
ASRock TSD


Posted By: Rattattastisch
Date Posted: 29 Sep 2023 at 6:09am
Hi guys,
I had the same problem with the ssd and did all of the steps but nothing worked can u help me pls


Posted By: kerberos_20
Date Posted: 29 Sep 2023 at 2:42pm
Originally posted by Rattattastisch Rattattastisch wrote:

Hi guys,
I had the same problem with the ssd and did all of the steps but nothing worked can u help me pls

if nothing works, then use PCIe M2 adapter, or different drive or different mainboard

-------------
http://valid.x86.fr/diq4l4" rel="nofollow">
http://www.userbenchmark.com/UserRun/47132492" rel="nofollow - userbenchmark


Posted By: ekinskofer
Date Posted: 01 Oct 2023 at 1:31pm
I have the same issue. I'm was going to update to a new bios but it says that "ASRock do NOT recommend updating this BIOS if you are going to use Pinnacle, Raven or Summit Ridge CPU on your system." I have the 2700X. What are the consequences of updating my bios while running this CPU? Should I update or just return this NVME and get a different one? What do you all recommend for 2TB to run in these mobos? Many thanks.


Posted By: Movethis1
Date Posted: 14 Nov 2023 at 8:42am
I have a Asrock B450 Steel Legend with a AMD Ryzen 5 3600. I am trying to put a WD SN850X NVMe in my machine. Does the board support this hard drive and do do I need to update the BIOS? Any help is appreciated!

Thanks



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net