Print Page | Close Window

NVMe windows 10 boot partition not detected

Printed From: ASRock.com
Category: Media&User's Review
Forum Name: AMD Motherboards
Forum Description: ASRock AMD Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=26292
Printed Date: 20 May 2024 at 5:01am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: NVMe windows 10 boot partition not detected
Posted By: MickStacko
Subject: NVMe windows 10 boot partition not detected
Date Posted: 12 Aug 2023 at 4:23pm
I am upgrading from my currently working 6y old system to a new one.

My plan is to use new components for the new system, but use the NVMe drive from my old system to not reinstall windows.
I used this approach successfully in the past without issues however it was from asrock + Intel Cpu -> other MBBrand + Intel CPU

Right now, the new machine detects the nvme drive in bios but is not booting from it. I cant select is as boot option. The nvme drive however works perfectly fine in the old system without issues.

specs:
old system ->   new system
Asrock Fatality Z170K4 -> Asrock B650 Riptide (bios v1.28)
Intel i7-6700K   -> AMD Ryzen 7950X3D
16GB DDR4      -> 32GB DDR5

The 4 post status LEDs are off, so cpu+ ram seem to be fine.
GPU is not installed yet (since the nvme slot is under it)

I do have 2 nvme drives, both have the same issue: both work fine and boot up on the old system (asrock+intel) but dont boot on the new system (Asrock+AMD).

Can my plan work out or do I really need to reinstall windows?




Replies:
Posted By: MickStacko
Date Posted: 12 Aug 2023 at 11:19pm
Solved.
Turns out the nvme drive partition had still MBR instead of GPT. For some reason I was sure it had GPT.

Anyone else dealing with this issue, the fix is less than 5 minutes, see here
https://learn.microsoft.com/en-us/windows/deployment/mbr-to-gpt" rel="nofollow - https://learn.microsoft.com/en-us/windows/deployment/mbr-to-gpt

This way i did not need to reinstall windows or deal with licensing.
Pro tip: If first step fails, shrink your main partition by 200 MB for new partition.


Posted By: M440
Date Posted: 13 Aug 2023 at 4:12am
you need an EFI partition with startup files, don't you?

-------------
asrock b650m/hdv.m2, ryzen 7700x@85watt



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net