Print Page | Close Window

Onboard Lan on B650E PG Riptide Wifi not working

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=26297
Printed Date: 25 May 2024 at 6:45pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Onboard Lan on B650E PG Riptide Wifi not working
Posted By: Cuu
Subject: Onboard Lan on B650E PG Riptide Wifi not working
Date Posted: 13 Aug 2023 at 1:51pm
Hi.
I just built a new system with the
ASRock B650E Phantom Gaming Riptide WiFi Motherboard
Other components in the system are:
XFX Radeon RX 7900 XT Speedster MERC 310
MD Ryzen 7 7700X
1TB Samsung 990 PRO M.2
1TB Samsung SSD 980
32GB (2x 16GB) Patriot VIPER VENOM DDR5-6600 DIMM CL34-40-40-84 Dual Kit

I am running windows 11.

Before installing the OS i updated the BIOS to the latest version 1.28. System works fine despite the onboard lan does nothing.
The onboard lan is enabled in the BIOS but the leds at the ethernet connector are constantly off.
I tried several cables of course. The ethernet adapter is not detected by the OS.
I tried the following already:
1) Disconnect all devices (including graphics card)
2) Disabled all other onboard devices in the bios
3) Reset to bios defaults
None of this worked: Anyone has a recommendation what else I can do?
Is it likely that this is a motherboard defect?

Best regards, Christian.



Replies:
Posted By: M440
Date Posted: 13 Aug 2023 at 6:05pm
hi,

there is a separate Realtek chip for LAN. It can be faulty.

You can try the LAN on a Linux Ubuntu/PopOS live usb to rule out the OS/VPN/malware.

-------------
asrock b650m/hdv.m2, ryzen 7700x@85watt


Posted By: mineschwepper
Date Posted: 04 Sep 2023 at 11:12am
Mine felt like it was doing the exact same thing (same model etc); Double check on your ethernet settings whether it's intermittently detecting or not? The port was still lighting up amber when I was in standby or in BIOS. I also did a CMOS BIOS Reset.

What did it for me was hooking up the other end of the cable into another device (my laptop in this case) and it detected fine, plugged it back in and it all started working again. Can't make sense of why but I hope you get some similar luck.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net