Print Page | Close Window

Trouble with Recognizing USB-C Devices on ASRock T

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=26437
Printed Date: 24 Feb 2024 at 7:04am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Trouble with Recognizing USB-C Devices on ASRock T
Posted By: pangeng
Subject: Trouble with Recognizing USB-C Devices on ASRock T
Date Posted: 31 Aug 2023 at 8:50am
Hello ASRock Community,

I recently purchased an ASRock TB 4 AIC R2.0 card and installed it on August 4th. I don't have any Thunderbolt 4 devices to test its functionality, so I used the USB-C devices I have on hand. However, I'm facing an issue where none of the devices are recognized by my PC when connected to the AIC card. The same devices work perfectly when plugged into the USB-C port on my PC's chassis.

- Devices Tested:
    LaCie Rugged Thunderbolt USB-C 4TB (via USB-C cable)
    SanDisk Extreme Portable SSD (via USB-C cable)
    Apple Magic Trackpad 2 (via Lightning to USB-C cable)

- Software and Controller Status:
    Downloaded and installed "Thunderbolt (TM) Controller software ver: Rev86_3" from the ASRock TB 4 AIC R2.0 website.
    Thunderbolt (TM) Controller software displays the following information:
    Thunderbolt Software:
        Application version: 1.0.34.0
        Controller driver version: 1.41.1325.0
        PCIe Tunneling: Enabled
    Thunderbolt Controller 1:
        Thunderbolt generation: thunderbolt 4 (1137)
        number of ports: 2
        security level: no security (SL0)
        NVM Firmware version: 35.0

- Device Manager:
    No errors reported.

- PC Configuration:
    OS: Windows 10 Pro 22H2
    CPU: AMD 7800X3D
    Memory: 64GB Corsair Vengeance
    Graphics: ASRock 7900XT PG
    Storage: WD Black 4TB SN850X, WD Blue 510 4TB SATA SSD
    Motherboard: ASRock x670e PG Lighting
    AIC Card Slot: Plugged into PCIe #3 as per manual instructions
    Jumper: Connected as indicated in the AIC manual
    Internal Cables: Thunderbolt and USB cables connected according to the AIC manual

Has anyone encountered this issue or can offer some troubleshooting advice?




Replies:
Posted By: pangeng
Date Posted: 31 Aug 2023 at 8:56am
Title did not disply fully. It is:
Trouble with Recognizing USB-C Devices on ASRock Thunderbolt 4 AIC R2.0


Posted By: pangeng
Date Posted: 31 Aug 2023 at 11:31am
update: problem fixed.


Posted By: Xaltar
Date Posted: 31 Aug 2023 at 4:38pm
Thanks for the update pangeng. Enjoy the build

-------------


Posted By: pangeng
Date Posted: 31 Aug 2023 at 11:25pm
Thank you


Posted By: GoBucks2023
Date Posted: 25 Sep 2023 at 10:29pm
I'm having the same issue with my ASRock TB4 AIC coupled with a B660 Pro RS MB. I first found Pangeng's thread about this on the Tom's Hardware forum. They helpfully responded to my request for details on how they fixed the issue and said that the USB 2 header was not connected properly. I've double checked my setup and it appears that both my TB header and USB 2 header are indeed connected properly. Any ideas what the issue may be? Device manager shows the AIC is working properly, but USB C devices are not recognized. I've tried a couple of different external SSDs, as well as my phone, and while the devices receive power, there is no data connection, and no devices show as connected in the TB manager software.


Posted By: GoBucks2023
Date Posted: 01 Oct 2023 at 2:15am
Fixed it - classic ID 10 T error on my part.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net