Print Page | Close Window

Z370 Taichi, can't see freshly installed NVME SSD

Printed From:
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
Printed Date: 28 May 2024 at 7:01am
Software Version: Web Wiz Forums 12.04 -

Topic: Z370 Taichi, can't see freshly installed NVME SSD
Posted By: lordpsytronix
Subject: Z370 Taichi, can't see freshly installed NVME SSD
Date Posted: 25 Sep 2023 at 6:05pm
G'day, I'm about ready to have a cry because I can't handle stress well.

I've got a Z370 Taichi I bought ~5 years ago and I'm trying to install a Lexar NM790 into it.

I've tried slotting the SSD into M2_1 and M2_2 with similar results; when I launch Windows and go into disk management, there's no new disk to format. When I jump into the BIOS, it doesn't detect anything connected in the slot it's currently in.

I've updated the BIOS to the latest version (" rel="nofollow - ), 4.20I Beta, and still can't see anything new connected to the slot of choice.

My Windows drive sits on an A-slot, I'm NOT trying to install a fresh copy of Windows on this new SSD.


Posted By: lordpsytronix
Date Posted: 26 Sep 2023 at 4:55am
Fixed! Feeling like a god amongst men.

I installed the SSD into the slot closest to the CPU and GPU. Appeared in BIOS and Windows on next boot.

I hate computers.

Posted By: jonathan7007
Date Posted: 08 Dec 2023 at 6:39am
On 1 December I installed a Samsung 2TB "Pro990" into my Taichi370's "second" M2 slot. Remaining in Slot 1 M2 was the Samsung 512 SSD which has been the Operating System boot and files for six years.

My Taichi Z370 mobo *never* was able to use this new SSD. BIOS and Disk Management could not recognize the drive at all.

Here are steps I took: I tried disconnecting ALL other SATA hard drives and one DVD drive. No Luck
I swapped the slots - the new drive went into the #1 M2 slot and the boot drive, the Samusung 512GB, was installed in Slot2, which is the M2 at the back of the mobo and case. Slot1 successfully boots Windows (always has...) so I know that M2 slot "works". Still no recognition of the Pro990. The BIOS found the boot routines on the 512GB in its new location, and Windows started.

So Slot 2 is fully functional, but unable to see the Pro990.

My exchanged new Pro990 will arrive in four or five days and I want to confirm that there is not a structural reason that a Taichi Z370 cannot accept TWO NVMe SSDs when one of the SSDs is expecting Gen4 SSD and it's sitting in a Gen 3 I/O channel. Searching this idea I found no such cautions because these devices are supposed to be backwards compatible.

Any thoughts, everybody?

Taichi z370, i7-8700K, Samsung Pro960 512GB, Asus GTX1060 3GB GPU, EVGA 850 PSU, Win10

Posted By: mark118
Date Posted: 09 Dec 2023 at 2:40am
Jonathan are you on bios 4.20I? And have you tried the 990pro in M2_3 ( the slot next to the cpu and ram)

Posted By: jonathan7007
Date Posted: 13 Dec 2023 at 5:37am
Mark, others:
Thank you for your suggestions. Since my last post I have also posted on TomsHardware and there, too, the question about latest BIOS came up.
No, I am on the original firmware 1.10 I believe (my notes elsewhere...)

Asrock didn't show an update on their overall Support/Downloads website section but on the Z370 product page - scrolled way down - there is a table of downloads with a [Beta]2021 v4.20I (letter "I") and the cryptic "Added NVMe TCG OPAL SSD support" which is offered by Asrock as, what, the reason we'd use it?

This is a production workstation which already has a NVMe. Therefore "Beta" is a dicey description...Asrock has had two years+ to test this or roll up user comments to graduate the rating to full release status.

Do you think that the new NVMe would work in Slot 3 without a BIOS update?

My Z370 works fine with the existing NVMe from Samsung. When I tried to install the new NVMe in Slot 2 it was not recognized. Slot 3 is underneath the cooler fans and heat exchanges. If I have to use that slot I'll have to pull that rig, clean CPU, re-apply paste, etc.

Maybe if I pull the GPU I can get at that M3 socket.

- tough time to fit all this in with other responsibilities during holidays.

Taichi z370, i7-8700K, Samsung Pro960 512GB, Asus GTX1060 3GB GPU, EVGA 850 PSU, Win10

Posted By: gman737
Date Posted: 23 Dec 2023 at 6:23am
I had a similar problem. I tried to install a WD Black SN850X into a Z370 Taichi and the mobo would not recognize it. Tried different slots and updated the BIOS. It seems like the mobo has trouble reading Gen 4 SSDs even though they are supposed to be backwards compatible. I then bought a Samsung 970 which is Gen 3 and it read it no problem.

As a side note, updating the BIOS messed up my Windows installation somehow. The system freezes when waking up from sleep or hibernation. I also have issues with different drivers now. So I don't recommend updating the BIOS unless you absolutely have to. You can't downgrade after.

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -