Print Page | Close Window

DRAM led keeps burning - Z790 Steel Legend WiFi

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=26944
Printed Date: 21 Apr 2024 at 9:54am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: DRAM led keeps burning - Z790 Steel Legend WiFi
Posted By: JBt
Subject: DRAM led keeps burning - Z790 Steel Legend WiFi
Date Posted: 31 Oct 2023 at 5:25pm
I have a new Z790 Steel Legend WiFi and using an intel i7-14900K and Kingston Fury Beast KF556C40BBK4-128.

This is the same RAM as the supported 'KF556C40BBK2-64', except that there are 4 sticks of 32GB instead of 2. Which means, inserting '1' stick should work anyhow, right?

Well... no

No matter which of the 4 sticks I insert and no matter which slot (documentation states install 1 dimm in B2) in all cases the same result:

CPU and DRAM let turn on. Boot led flashed really short after turning on. CPU led goes off. DRAM led remains on.

The Mobo wont POST, no display output and yeah... that's it.
The CPU led goes off, even though its a 14th gen Intel. I cannot see what BIOS is installed. The motherboard shows REV 1.01 below the name, next to the DRAM slots.

So, what is going wrong? Any suggestions?

I don't have other DDR5 RAM, nor do I have a different 1700 socket compatible CPU.



Replies:
Posted By: Darkje
Date Posted: 31 Oct 2023 at 8:23pm
maybe the bios version on the board doesn't support 14th gen and you need to flash a newer version?

On an another brand board i got from a client, it was about the same, the cpu seemed to work but no output, top pcie slot not working, m2 slots from the cpu not working. Only when i inserted a graphics card in the second pcie slot i did get an image and was able to flash. Turned out the cpu was working just enough to proceed with the flash from an usb stick, but non of the devices connected from the cpu where working. The devices running from the chipset did work.

After updating the bios it all worked as intended.

I'm not sure it will be the same on this board, but maybe if you insert a gpu in the second slot, you can get into the bios and flash.



Posted By: JBt
Date Posted: 31 Oct 2023 at 9:19pm
Thank you for the suggestion!
I placed a GTX 1080 in the PCI slot, but for all 3 slots the display does not output anything and the DRAM led remains lit.

I did find a sticker on the BIOS chip, with "5.02" on it, meaning that the 14th gen CPU is not supported :|

But still.. how does one update bios w/o buying a 13th gen cpu?


Posted By: JBt
Date Posted: 31 Oct 2023 at 10:15pm
The problem: The bios chip has a sticker on it, saying "5.02", meaning that version of the bios is installed. The 14th gen is thus not supported.

So here is what to do:

Place ONE DRAMM in slot B2 (though I guess other slots might work as well, this is the one specified in the manual)

Install the 14th gen CPU + CPU cooler
DO NOT install M.2 or other stuff in the motherboard (I actually had the M.2 PCI 5 slot in use... as well as one M.2 PCI 4 slot)
Connect the power supply to the motherboard and the CPU connectors.

Now connect the displayport or HDMI port and turn on the system after starting wait for at least 2 minutes. The display should now work!

It is thus possible to update the BIOS without additional hardware!


Posted By: Avocadoo
Date Posted: 18 Nov 2023 at 7:50pm
Hello,

I have the same problem with Z790 PG LIGHTNING, but this solution looks like doesn't work with KF CPUs (I have already tried with two PCIE VGAs without any outpot signal). :(



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net