Print Page | Close Window

Asrock B650 PG usb issues

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=27225
Printed Date: 20 May 2024 at 10:24am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Asrock B650 PG usb issues
Posted By: edhunter
Subject: Asrock B650 PG usb issues
Date Posted: 02 Jan 2024 at 6:04pm
I have strange issues with intermittent loosing connectivity to all my wireless peripherals (keyboard, mouse, headset all wireless with dongles). It can happens in different situations during gaming or just browsing. It happens once or twice a day.

Here is my setup:
MB: Asrock B650 PG Lightning, bios 2.02
CPU: Ryzen 7800x3d
RAM: 2x16 DDR5 6000, Kingston Fury
GPU: Palit rtx 4090
OS: Windows 11 (23H2)
Mouse: Razer Basilisk v3 wireless (rear port usb32_3)
Headset: Sony inzone h9 wireless (front port usb32_9)
Keyboard: Corsair K63 wireless (front port usb_5)
Second keyboard/mouse: logitech k400 (front usb_6)

Strange thing is that when the issue happen logitch k400 kbd/mouse is not affected - it works. All other wireless peripherals become radio disconnected - for example the headset starts to blink indicating reconnection and sometimes it reconnects but then immediately loses connectivity again.
The only solution is to do a reboot.

There are related no entries in event viewer System category, but there are in Appication category informational events for LiveKernelEvent with dump for USBXHCI. So I think that the issue is probably related to usb but cannot figure it out.

Recently I have added ax210 wifi/bt adapter in m2_wifi port, and may be around that time my issue started. I have disabled it in the bios (both bluetooth and wifi), but still I have these intermittent usb issues.
I also have tried the wifi peripherals donlges in different ports, it does not help.
I have reinstalled the chipset driver (5.11) from Asrock support site, but it did not fix my problem.

Please I need advices how to proceed.
This issue is very annoying especially when it happens while I play online.



Replies:
Posted By: edhunter
Date Posted: 14 Jan 2024 at 10:18pm
anyone ?


Posted By: idovitz
Date Posted: 18 Jan 2024 at 6:51am
I'm experiencing the same kind of problems here. My system is b650 PG Lightning mobo + 7800x3d + rx7800xt + 32Gb expo 6000 corsair. USB 2.0 4x usually does not work. Over time, Ethernet fails and the USB connections stutter, a few minutes later the system freezes. OS is archlinux.
I plan to downgrade BIOS 2.02 to 1.30 or so. According to some, more stable.


Posted By: edhunter
Date Posted: 18 Jan 2024 at 3:18pm
I tracked down that the issue in my case affects only usb ports connected to the b650 chipset. And it affects all HID devices connected to these ports, no matter wired or wireless.
USB ports connected to the cpu are not affected by this.
I think on my case it's hardware problem and not sure if older bios would resolve it.
I am going to RMA the board. I am wondering if I get again b650 or try my luck with x670.


Posted By: bakurix
Date Posted: 22 Jan 2024 at 1:26am
BIOS 2.02 looks defective, I've had this issue, also, since updated my RTX 4080 only displays after reboot, the iGPU take over the first boot...
After trying to switch every other component (RTX3000 series worked fine), the solution was to come back to BIOS 1.28.


Posted By: bakurix
Date Posted: 22 Jan 2024 at 1:28am
Try downgrading it to 1.28 (before beta ones), solved all my problems. As advised in download page, first XMP boot takes a while.


Posted By: idovitz
Date Posted: 22 Jan 2024 at 10:01pm
Thanx for replying. What problems did you experience Bakurix? I'am running 1.30.AS05 but problems did indeed not solve. Will try 1.28 soon.


Posted By: Elope3
Date Posted: 01 Apr 2024 at 6:32am
Hey idovitz, I'm having very similar problems.

Sometimes when I boot my PC, the internet (connected via ethernet) doesn't work and my mouse and keyboard inputs stutter. The stuttering gets worse until the system completely freezes. A reboot always fixes the issue, allowing me to use my computer like normal. That's how I've tolerated it for this long lmao. But I don't know why it only affects some boots, and not all of them.

I've suspected it's the motherboard and tried to keep it up-to-date, hoping it'd be fixed.

Yesterday I updated the BIOS to 2.10, but it's too early to tell if that fixed the problem. Will try to report back if it did.

Anyway,it's been two months since your latest update, idovitz. Has anything changed? Has 1.28 fixed it for you?

I hope I don't have to RMA the board, because I don't wanna go through the effort of dismantling my pc ??


Posted By: Cronista
Date Posted: 12 Apr 2024 at 11:12am
I'm having the same problem. I did everything under the sun trying to figure out what even was going on (fresh windows install, PSU, RAM, defective USB device etc).

It happens as described in the posts above: Gradual decay in USB signal (mine was increasingly garbled static in the headset) then almost all USB ports get disabled, except for the 3.2 Gen 2 type A (must be the one connected to the CPU, as said by @edhunter?).

Before I reinstalled windows the USB would come back by it self after about 10 seconds, but then 10 min later it would happen again. Currently, the ports just stop working until reboot.

Will try downgrading to 1.28 and come back to give feedback.

Setup:

MOBO: B650M PG RIPTIDE
CPU: RYZEN 7 7700
RAM: 2x 16gb Kingston Fury Beast RGB 6000MHz
PSU: Corsair RM850x Shift
GPU: RX 7900 XTX


Posted By: Cronista
Date Posted: 12 Apr 2024 at 3:39pm
It didn't work. I was going to test other BIOS versions but according to this other forum post about the same problem ( https://forum.asrock.com/forum_posts.asp?TID=27010&PN=2&title=odd-cold-boot-issues-mobo-or-cpupound" rel="nofollow - https://forum.asrock.com/forum_posts.asp?TID=27010&PN=2&title=odd-cold-boot-issues-mobo-or-cpupound ), looks like it's hardware .

Still on the other post, he said he had problems with two PG boards in a row. Plus, I've had a issue with a past Asrock AM4 build (solder would fail and not turn on the PC unless you heated up the board).

So I'm going to contact the store warranty and/or Asrock support for a replacement, but this was the last Asrock board I bought or recommended.


Posted By: Elope3
Date Posted: 18 Apr 2024 at 12:48am
I was hopeful. But today it happened again, so unfortunately BIOS 2.10 did not fix it.

I read that many people have had issues with previous ASRock boards, but that their AM5 boards are supposed to be really good.

Well, unlucky I guess

I think I'm gonna try contacting ASRock to see if they can somehow help, as I really don't wanna have to take my whole pc apart to replace the motherboard ??

Let me know how it goes for you, Cronista

My current specs:

MOBO: ASRock B650 PG Lightning
CPU: AMD Ryzen 7800X3D
RAM: 2x 16GB Kingston FURY Beast 6000Mhz
PSU: Corsair RM850x Shift
GPU: XFX RX 6950 XT Speedster MERC 319




Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net