Print Page | Close Window

Z77 Extreme4 - How to enable USB3.0 ?

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=277
Printed Date: 19 Apr 2024 at 10:03am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Z77 Extreme4 - How to enable USB3.0 ?
Posted By: 50cent
Subject: Z77 Extreme4 - How to enable USB3.0 ?
Date Posted: 19 Jun 2015 at 12:42am
Hi,
I have a Z77N-WIFI motherboard and the rear USB ports appear to be registered only as USB 2.0.

I downloaded and installed the USB 3.0 drivers from the AsRock site, but still they seem to be set to USB 2.0.

I can not see an setting in BIOS to enable USB 3.0.

How do I get USB 3.0 to work? (the USB 3.0 header does work, but the ports at the back of the mobo are only USB 2.0).

I'm using Win 7 64bit and the BIOS version is: F2 (08/23/2012).

Also, I just tried updating the BIOS, version 2.9 from this link: http://www.asrock.com/mb/Intel/Z77%20Extreme4/?cat=Download&os=BIOS

...but it said the BIOS software was incorrect!

Can anyone help?
Thanks



Replies:
Posted By: parsec
Date Posted: 19 Jun 2015 at 1:00pm
Originally posted by 50cent 50cent wrote:

Hi,
I have a Z77N-WIFI motherboard and the rear USB ports appear to be registered only as USB 2.0.

I downloaded and installed the USB 3.0 drivers from the AsRock site, but still they seem to be set to USB 2.0.

I can not see an setting in BIOS to enable USB 3.0.

How do I get USB 3.0 to work? (the USB 3.0 header does work, but the ports at the back of the mobo are only USB 2.0).

I'm using Win 7 64bit and the BIOS version is: F2 (08/23/2012).

Also, I just tried updating the BIOS, version 2.9 from this link: http://www.asrock.com/mb/Intel/Z77%20Extreme4/?cat=Download&os=BIOS

...but it said the BIOS software was incorrect!

Can anyone help?
Thanks


The title of your thread (Z77 Extreme4 - How to enable USB3.0 ?) is about the ASRock Z77 Extreme4 mother board. But the first sentence of your post is about a Z77N-WIFI board that is made by Gigabyte.

I can also tell you are using a Gigabyte board by the BIOS version number, F2, which is a format that ASRock does not use, but Gigabyte does.

I would certainly expect the BIOS of the ASRock Z77 Extreme4 to be rejected by that board.

Can you explain this confusion, or extreme typos? Confused


Posted By: Xaltar
Date Posted: 19 Jun 2015 at 1:16pm
I think you are right Parsec, he is using a gigabyte Z77N-WIFI. 

A quick search and it seems there is only one BIOS update for his board:

http://www.gigabyte.com/products/product-page.aspx?pid=4337#bios" rel="nofollow - Gigabyte Z77N-WIFI BIOS F3


Posted By: 50cent
Date Posted: 19 Jun 2015 at 9:48pm
Oh man, that's a little embarrassing! I originally ordered the Asrock board, but I forgot I couldn't use it in the end and finished up with a Gigabyte.

Sorry for wasting your time!


Posted By: Xaltar
Date Posted: 19 Jun 2015 at 10:03pm
Not a problem Wink

Good luck with your PC.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net