Print Page | Close Window

ASRock Rapid OC doesn't run on Windows 10

Printed From: ASRock.com
Category: OverClocking(OC) Zone
Forum Name: OC Technical Discussion
Forum Description: OC enthusiast's tech talk
URL: http://forum.asrock.com/forum_posts.asp?TID=2773
Printed Date: 02 Feb 2023 at 3:24pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: ASRock Rapid OC doesn't run on Windows 10
Posted By: akaKlen
Subject: ASRock Rapid OC doesn't run on Windows 10
Date Posted: 03 Jun 2016 at 2:59am
ASRock Rapid OC used to work on Windows 10 but now I start it and it never shows up. ver. 2.0.21. Is it just me?



Replies:
Posted By: Brumbybob
Date Posted: 02 Oct 2016 at 12:57pm
Since 3 updates ago I have found a lot of things not working properly on Win 10 including UEFI Bios. I think it's Win 10 issue & it will probably be a long time before they are able to fix it.



-------------
Brumbybob


Posted By: parsec
Date Posted: 02 Oct 2016 at 9:53pm
" rel="nofollow -
Originally posted by Brumbybob Brumbybob wrote:

Since 3 updates ago I have found a lot of things not working properly on Win 10 including UEFI Bios. I think it's Win 10 issue & it will probably be a long time before they are able to fix it.



Some more information would be helpful, please.

Mainly, what ASRock mother board you are using? Rapid OC would be the feature in the BIOS?

Also, have you done an upgrade to Windows 10, or a fresh, clean installation?

I use Windows 10 on four different ASRock boards, from a Z77 Extreme4, to a Z170 Extreme7+. I use the UEFI on those boards all the time, and I'm not having any problems.

Many other ASRock board users also use Win 10 without any problems. What exactly is wrong that you think is related to Windows 10?


-------------
http://valid.x86.fr/48rujh" rel="nofollow">



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net