Print Page | Close Window

BSOD when installing Eltron USB3 drivers

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=290
Printed Date: 19 Jun 2021 at 12:01pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: BSOD when installing Eltron USB3 drivers
Posted By: amancalleddave
Subject: BSOD when installing Eltron USB3 drivers
Date Posted: 19 Jun 2015 at 7:09pm
I recently bought a ASRock 990FX Extreme 9 motherboard and have hit on a bit of a problem. Neither of the front USB3 port sockets work, despite having already installed the All In 1 driver package from the CD that came with the motherboard. So I head over to ASRock's support page and download the Win 7 64bit Eltron USB3 drivers, but when I run the setup is BSOD's on me and restarts my system.

The error I get is this...
DRIVER_IRQL_NOT_LESS_OR_EQUAL
STOP: 0x000000D1
EltronXHCI.sys

There is more info but I can't read it as it's right off the end of my screen. I've tried running the setup as administrator and normally, neither of those worked. I've pulled each of my sticks of RAM and tried running the setup as administrator and normally, and I still get BSOD's with the same error codes.

I quick google search tells me I have crap drivers and I should go to the support page and download new ones, which is what caused the issue in the first place. I've even tried going to the Eltron site and downloading the 0.0118 drivers (slightly more up to date versions than are available on your support page) but I get the same BSOD codes back. So round and round in circles I go with no USB3 drivers and I've ran out of ideas.

Can anyone here provide an alternative suggestion please?



Replies:
Posted By: amancalleddave
Date Posted: 19 Jun 2015 at 7:21pm
OK, I don't know if I'm being trolled or helped by some divine force but right after I wrote that last post I tried installing the 0.0118 drivers again as admin with both sticks of RAM installed and it worked.

I made no changes to my system, it's exactly the same as what it was 3 hours ago when I started tearing my hair out over this issue. So I've no idea why it works now and why it didn't before. But at least my front USB3's are now working.

The only thing I could suggest to anyone else who has this issue in the future is to keep trying, around the 12th time you try it'll probably decide to work.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net