Print Page | Close Window

Prolem with usb 3.0 H81M-G

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=292
Printed Date: 16 Apr 2024 at 4:04am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Prolem with usb 3.0 H81M-G
Posted By: trantuan1607
Subject: Prolem with usb 3.0 H81M-G
Date Posted: 22 Jun 2015 at 5:15pm
Hello everyone,

I recently bought mainboard h81m-g and I discovered that usb 3.0 does not work properly with its speed . Specifically, the copy speed is 32 ~ 38Mb only / s . It is too slow compared to the standard usb 3.0. Where can I download usb driver for main h81m-g? On the homepage ASROCK have not found? How can i fix this? Please, help me. Thanks you.

Sorry for my bad english :D



Replies:
Posted By: Xaltar
Date Posted: 22 Jun 2015 at 5:52pm
Welcome to the forums Smile

If you could please provide more information. 

What device are you testing copy speed with, (Brand and Model)?
What operating system are you using?

Without this information I can't tell you where to find drivers as I don't know what operating system you need them for. I do know that the product download page for your motherboard has intel USB3 drivers listed.

Additionally: Only the blue USB ports on your motherboard are USB 3 as well as the onboard USB 3.0 header that is designed to be connected to the front USB 3 port/ports on your case if it has the facility.


Posted By: trantuan1607
Date Posted: 22 Jun 2015 at 6:12pm
I use Win7 pro 64 bit, device HDD box WD elements 500gb support usb 3.0. i connect device (hdd box) with blue usb ports on motherboard :) thanks for support


Posted By: Xaltar
Date Posted: 22 Jun 2015 at 6:42pm
Thanks.

ftp://europe.asrock.com/Drivers/Intel/USB/Intel_USB3%28v2.5.3.34%29.zip" rel="nofollow - Here is the USB 3 driver for your motherboard. I direct linked to the download to avoid confusion but it does in fact come from your product download page for windows 7 64bit Wink


Posted By: parsec
Date Posted: 23 Jun 2015 at 12:30am
Originally posted by trantuan1607 trantuan1607 wrote:

Hello everyone,

I recently bought mainboard h81m-g and I discovered that usb 3.0 does not work properly with its speed . Specifically, the copy speed is 32 ~ 38Mb only / s . It is too slow compared to the standard usb 3.0. Where can I download usb driver for main h81m-g? On the homepage ASROCK have not found? How can i fix this? Please, help me. Thanks you.

Sorry for my bad english :D


As Xaltar said, the Intel USB 3.0 driver is available on your board's download page:

http://www.asrock.com/mb/Intel/H81M-G/?cat=Download&os=Win764" rel="nofollow - http://www.asrock.com/mb/Intel/H81M-G/?cat=Download&os=Win764

You must have had a USB 3.0 driver installed for the USB 3.0 ports to work at all. Probably from an automatic Windows driver update. So the USB 3.0 driver from your board's download page may not make any difference in copy speed.

The copy speed that you will get over any interface, like USB 3.0 or SATA, is not one constant speed, it is variable depending upon many different factors. The maximum speed quoted for any storage interface is only achieved under certain circumstances.

The main factor causing different copy speeds is the size of the files being copied. Many small files up to about 50KB will be copied at much slower speeds than large files of 500KB and greater. That is caused by the extra processing by the Windows file system and the HDD to find, open, and start the file copy.

The USB interface does not use the SATA AHCI NCQ feature that reduces the amount of file system processing needed to do multiple file copies. USB will always be slower than any SATA drive.

Large files (many mega-bytes) appear to copy at faster speeds because there is enough time for Windows to actually measure the copy speed. Small 4K files will never be copied at say 50MB/s because the file copy is completed so quickly because it is so small.

What are you using to measure the file copy time, the display that Windows 7 shows during the file copy?



Posted By: trantuan1607
Date Posted: 23 Jun 2015 at 6:03pm
Thanks Parsec and Xaltar.

@Parsec:  you right, the display that Windows 7 shows during the file copy. I copied about 60GB file ( .iso file) and the speed displayed on the copy process is 30 ~ 35MB / s . I 'm downloading the driver you and xaltar gave me. Hopefully after drivers installed it will run properly with its speed  Smile


Posted By: parsec
Date Posted: 24 Jun 2015 at 10:13am
Originally posted by trantuan1607 trantuan1607 wrote:

Thanks Parsec and Xaltar.

@Parsec:  you right, the display that Windows 7 shows during the file copy. I copied about 60GB file ( .iso file) and the speed displayed on the copy process is 30 ~ 35MB / s . I 'm downloading the driver you and xaltar gave me. Hopefully after drivers installed it will run properly with its speed  Smile


What are the source and destination drives being used? I know one is the WD elements 500GB USB 3.0 external drive, but what is the other drive?

You may just have a USB 2.0 driver installed on the USB 3.0 ports which accounts for the USB 2.0 range speeds.





Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net