Print Page | Close Window

B650E PG Riptide WiFi Issues (Bios and Chipset)

Printed From:
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
Printed Date: 18 Jun 2024 at 6:00pm
Software Version: Web Wiz Forums 12.04 -

Topic: B650E PG Riptide WiFi Issues (Bios and Chipset)
Posted By: Werezombie16
Subject: B650E PG Riptide WiFi Issues (Bios and Chipset)
Date Posted: 07 Feb 2024 at 12:53am
CPU is a Ryzen 9 7900X
Windows 11

Hey guys a short story of what is going on, I am a small time youtuber very small time and I built my first PC back in may of 2023. while checking the pc I used my capture card in all 3 ports to make sure they worked since I didn't have a graphics card yet and I noticed that the third slot controlled by the chipset wasn't working there is power to the capture card as I can see my Xbox on the tv but the pc cannot see the device in device manager or any software. Fast forward to November and I finally have a 6700 xt graphics card. I start to use it in the primary slot but the third slot where I need to use the capture card since it requires a x4 slot is showing the same issue. ASRock tech support recommended updating the Bios which I was unable to do so they replaced the entire motherboard.

Now: I have the new motherboard but I am seeing all the exact same issues. Third PCIE slot doesn't work. Cant update board bios, cant run updates for my Chipset or my graphics card either. Any time I try to run an update it gets stuck in a load screen. Any help would be much appreciated, first new PC and first PC Build.

Posted By: eccential
Date Posted: 08 Feb 2024 at 7:59pm
According to the spec page:" rel="nofollow -

Chipset slot (PCIe_2) is only x1 wide. Is it possible that your capture card requires more than one PCIe lane? Some capture cards do require that. There are capture cards that are specifically designed to use just one PCIe lane, for cases like this.

For example:" rel="nofollow -
So GC571 would work on an x1 slot, but GC575 would not.

Posted By: Werezombie16
Date Posted: 09 Feb 2024 at 12:49am
okay I thought that the bottom slot was the chipset slot but it is the x4 slot so the chipset is the x1 slot that I'm not using. Thank you for pointing this out to me because it caused me to go back and look at the manual again. I see that the 2 slots that I'm using will work in a crossfire mode(I know the capture card wouldn't show as a graphics card for crossfire). But would enabling crossfire make the capture card show up do you think and if so how to I enable crossfire in the bios? Thank you for your response.

Posted By: eccential
Date Posted: 09 Feb 2024 at 1:52am
I think I misunderstood the issue, also.

So you're saying the capture card does not work in PCIE_3 slot (bottom most slot). That is strange. It should just work. Do other things work in that slot? If other things (6700XT) don't work there, it could be the CPU, since it's the 2nd motherboard you tried, and the PCIe lanes are directly connected to the CPU.

It has nothing to do with crossfire. It's just PCIe lanes being distributed across slots, and the CPU should have enough PCIe lanes to support both PCIE_1 and PCIE_3 slots.

The only other thing I can think of is to force PCIe Gen3 (or Gen2) for the bottom slot, if that is even possible in the BIOS.

Posted By: Werezombie16
Date Posted: 09 Feb 2024 at 2:05am
okay ill give it a shot later today and responded with the results. When i contacted ASRock about the issue they said i had a corrupted chipset which is why i got the slot confused on which was controlled by chipset and GPU

Posted By: Werezombie16
Date Posted: 14 Feb 2024 at 12:44am
I don't understand this but I was able to resolve the problem.

Long description of what I did to fix it below, sorry.

During troubleshooting as I said I was able to get the capture card to work in both the top and middle slots but not the bottom slot. I found an old article when searching on the elgato side and found that someone had a similar issue and they had to go back to an old elgato driver for their card. I went to the elgato site and downloaded the most recent software update for the capture software first. When i tried to update it informed me that i had the most recent update installed but asked if I wanted to uninstall and update anyway. I click yes and after all of the installation and updating was completed it started to work. I'm not sure why it didn't work with the same revision before but now my capture card and graphics cards are both working in my system. Thanks for the help and response.

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -