Print Page | Close Window

Asrock B450 Pro4 blind bios update

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=29498
Printed Date: 18 Jun 2024 at 5:54pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Asrock B450 Pro4 blind bios update
Posted By: RXg8
Subject: Asrock B450 Pro4 blind bios update
Date Posted: 15 Feb 2024 at 2:55pm
I get a black screen with my Asrock B450 Pro4 mainboard until the OS (Linux in my case) initializes the graphics card (RX Vega 11 integrated with AMD Ryzen 5 2400GE). I suspect a bios update would fix it, but I can't do that without seeing what I'm doing. So what I need are the keyboard inputs required to perform a bios update blind. Can anybody help me?



Replies:
Posted By: Xaltar
Date Posted: 15 Feb 2024 at 4:23pm
The issue isn't the GPU not being detected but rather the display isn't being
seen before the OS loads.

You can try other cables, some HDMI cables can be problematic when it comes to
display detection. If you have the option you can also try the other display outputs.
D-Sub (the old VGA style output) almost always works but you can also try the
Display Port/HDMI depending on what you already have connected.

-------------


Posted By: RXg8
Date Posted: 15 Feb 2024 at 5:10pm
I have tried HDMI, DisplayPort and D-Sub cables, it doesn't seem to make a difference.

It's not that there's no signal (my monitor detects a signal) it's just that it's a black screen. Interestingly, my SATA Controller Card's (SilverStone ECS06) BIOS *does* get displayed for some reason; but BIOS and bootloader (GRUB) show a black screen.


Posted By: Xaltar
Date Posted: 15 Feb 2024 at 5:22pm
That is odd, if the OPROM is showing that should mean it's working. Have you tried
doing a CMOS clear? If not I would do that, I find this method works best to clear
out gremlins and bad config info a typical clear doesn't seem to quite remove:

https://forum.asrock.com/forum_posts.asp?TID=630&title=how-to-clear-cmos-via-battery-removal

If that doesn't resolve the issue then I would open a ticket with ASRock:
https://tw.asrock.com/events/tsd.asp

You can include a link to this thread so they can check it out.

Good luck

-------------


Posted By: RXg8
Date Posted: 15 Feb 2024 at 8:08pm
Clearing the CMOS worked, thanks!



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net