Print Page | Close Window

PC randomly boots to iGPU instead of discrete GPU

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=29658
Printed Date: 16 Jun 2024 at 11:32am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: PC randomly boots to iGPU instead of discrete GPU
Posted By: bookthief1221
Subject: PC randomly boots to iGPU instead of discrete GPU
Date Posted: 20 Feb 2024 at 4:32pm
I have a B650E PG Riptide WiFi with a 7800X3D and 4080 super FE. The monitor is connected to the discrete GPU port directly. I have issues with the system booting to the iGPU instead of the discrete card (or randomly, the opposite). Sometimes, the system goes through a boot cycle a few times before settling. The red debug LED's on the motherboard turn off and on in a cycle and eventually go out. When booting, I see the Asrock splash screen briefly before it switches to the iGPU output.

I eventually went into the BIOS settings while connected to the motherboard video output, and I tried to changing the GXF configuration settings to specify "iGPU disabled" and "auto detect discrete display enabled." However, this doesn't seem to have worked (at least consistently enough). Note that I unplug the HDMI cable from the motherboard when testing, but I need it to actually get into the BIOS to change things.

Other things I've tried: downloaded latest drivers (at least everything recommended by the Asrock auto installer) and flashed the BIOS to both older and newest beta versions. Didn't work?”same problem. Still waiting on Asrock support for any kind of response (it's been a week, and I don't know what to do).

I've tried searching online for similar issues, but I couldn't find anything that worked.

Kind of disappointed by this board. This issue makes it impossible to actually use the system consistently. And Asrock support is basically MIA. Would appreciate any help here?”thanks!



Replies:
Posted By: Hanzo
Date Posted: 25 Apr 2024 at 9:36am
Hello, I have the same problem with a B650E Taichi.
I have the same CPU, and a 4070ti

The problem happens every time Windows is updated, or there is a power outage and the MB does not start from the GPU.

It is probably some error with the 7800X3D controller that has not been solved from the BIOS, because even by disabling the iGPU, it is disabled and starts there.

Let's hope that ASROCK takes into account this error, which is exasperating.


Posted By: eccential
Date Posted: 25 Apr 2024 at 11:21pm
Just some other possibilities I can think of.
1) PCIe connection to the dGPU is marginal. Try cleaning the dGPU's PCIe connectors with electronics contact cleaner (or just some rubbing alcohol) and re-seating it. It's also possible for the connection between the motherboard and the CPU to be marginal. Hope nobody touched the contact pads on the CPU during install. Cleaning them and re-seating the CPU would be more hassle than re-seating the dGPU, but same concept.
2) Power supply is marginal and dGPU is not getting enough power for the initialization, but only sometimes.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net