Print Page | Close Window

[solved] B650M/HDV.M2 BIOS memory stability issues

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=30954
Printed Date: 23 Jul 2024 at 4:10pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: [solved] B650M/HDV.M2 BIOS memory stability issues
Posted By: M440
Subject: [solved] B650M/HDV.M2 BIOS memory stability issues
Date Posted: 28 Feb 2024 at 5:59pm
B650M/HDV.M2 (rev 1.07 sticker at BIOS chip)

1.30.AS05 [Beta]

Is the last bios i can run my memory on stock speeds. (G.SKILL F5-5600J3636C16GX2-TZ5RS). I could run the memory out of the box with XMP profile, hassle free and stable.

Every bios past 1.30.AS05 [Beta] i can not make this memory stable @stock (5600mhz 36-36-36 1.2v) settings and i need to manually downclock (5000mhz 38-38-38 and higher voltage).

What is the reason for that? Will this be fixed?

-------------
asrock b650m/hdv.m2, ryzen 7700x@85watt



Replies:
Posted By: M440
Date Posted: 07 Mar 2024 at 2:25pm
BIOS 2.08 final is out.

is 2.08 any different to 2.08.AS01 or is it just a relabel?

-------------
asrock b650m/hdv.m2, ryzen 7700x@85watt


Posted By: Xaltar
Date Posted: 07 Mar 2024 at 4:46pm
Short of a reply from ASRock_TSD or someone testing it out there is no way to know
at this point. Generally, if the beta passed testing it will simply be relabeled
and uploaded as a release version. If there were any bugfixes made then these will
be added to the final release too. Which is true here I can't say.

You could open a support ticket and ask directly. Sorry I couldn't be of more help.

-------------


Posted By: M440
Date Posted: 09 Mar 2024 at 7:17pm
Originally posted by Xaltar Xaltar wrote:

Short of a reply from ASRock_TSD or someone testing it out there is no way to know
at this point. Generally, if the beta passed testing it will simply be relabeled
and uploaded as a release version. If there were any bugfixes made then these will
be added to the final release too. Which is true here I can't say.

You could open a support ticket and ask directly. Sorry I couldn't be of more help.


Yes thats how I understand it, just wanted to make sure. Thank you

Anyway I decided to take a look again on this and found a fix.

I needed to set all the training options from default to auto. I've set the first option (DFE read training) to enable in the main timing menu.


https://ibb.co/pw6yMjG" rel="nofollow">

https://ibb.co/BqDk3Nd" rel="nofollow">

-------------
asrock b650m/hdv.m2, ryzen 7700x@85watt


Posted By: M440
Date Posted: 13 Mar 2024 at 3:51am
memory training options set in other menus:

https://ibb.co/qn9cx0R" rel="nofollow">

https://ibb.co/YTJnNnX" rel="nofollow">

-------------
asrock b650m/hdv.m2, ryzen 7700x@85watt


Posted By: mrbill
Date Posted: 17 Apr 2024 at 9:55am
Training isn?t working for me. - screen stays black for 30+ minutes. Nothing works for me beyond. FW 1.30 AS05.

-------------
ASRock X670E Steel Legend (ABA159EAF581)
AMD Ryzen 9 7900X
32GB (2x16GB) G.Skill F5-5200J4040A16GX2-RS5K
WD SN570 2TB
MSI NVIDIA GeForce RTX 3080 Ti
Win 11 Pro


Posted By: M440
Date Posted: 18 Apr 2024 at 1:13pm
Originally posted by mrbill mrbill wrote:

Training isn?�t working for me. - screen stays black for 30+ minutes. Nothing works for me beyond. FW 1.30 AS05.


update the ancient bios to the most recent 2.10 (as of today). Repeat what you did for the newly updated bios

-------------
asrock b650m/hdv.m2, ryzen 7700x@85watt


Posted By: mrbill
Date Posted: 18 Apr 2024 at 6:30pm
Originally posted by M440 M440 wrote:

Originally posted by mrbill mrbill wrote:

Training isn?�t working for me. - screen stays black for 30+ minutes. Nothing works for me beyond. FW 1.30 AS05.


update the ancient bios to the most recent 2.10 (as of today). Repeat what you did for the newly updated bios


As I said, nothing works beyond FW 1.30 AS05. FW 2.00, 2.02, 2.08 and 2.10 all fail and will not train with memory on the QVL which obviously has not been supported since 1.30 AS05. Try to train and the screen stays black for 30+ minutes. Let it boot right into Windows and an immediate Win error occurs.

-------------
ASRock X670E Steel Legend (ABA159EAF581)
AMD Ryzen 9 7900X
32GB (2x16GB) G.Skill F5-5200J4040A16GX2-RS5K
WD SN570 2TB
MSI NVIDIA GeForce RTX 3080 Ti
Win 11 Pro


Posted By: M440
Date Posted: 19 Apr 2024 at 11:07am
Originally posted by mrbill mrbill wrote:

Originally posted by M440 M440 wrote:

Originally posted by mrbill mrbill wrote:

Training isn?�t working for me. - screen stays black for 30+ minutes. Nothing works for me beyond. FW 1.30 AS05.


update the ancient bios to the most recent 2.10 (as of today). Repeat what you did for the newly updated bios


As I said, nothing works beyond FW 1.30 AS05. FW 2.00, 2.02, 2.08 and 2.10 all fail and will not train with memory on the QVL which obviously has not been supported since 1.30 AS05. Try to train and the screen stays black for 30+ minutes. Let it boot right into Windows and an immediate Win error occurs.


Thats what i understand - firmware ~1.30 introduced memory training options, so if it worked for pre ~1.30 it can work at new bioses too - you just have to set memory training options. Unfortunatelly the 'default' or 'auto' dont work for your memory RAM product.

-------------
asrock b650m/hdv.m2, ryzen 7700x@85watt


Posted By: mrbill
Date Posted: 20 Apr 2024 at 11:00am
When the MB trains memory, what does it do? I just get a black screen for 30 minutes or so. There's no indication training is taking place. Then I hard boot, it goes to boot Windows and immediately encounters an error. Then they system restarts to the Asrock boot screen and stays there for another 30 minutes before I finally must revert back to 1.30 AS05 FW. Might it be the 670E will not accept training options like the B650?

-------------
ASRock X670E Steel Legend (ABA159EAF581)
AMD Ryzen 9 7900X
32GB (2x16GB) G.Skill F5-5200J4040A16GX2-RS5K
WD SN570 2TB
MSI NVIDIA GeForce RTX 3080 Ti
Win 11 Pro


Posted By: mrbill
Date Posted: 20 Apr 2024 at 11:07pm
I was finally able to get it to train (screen was black for a few minutes during training). After training, RAM was set to 4800 by MB despite my initial efforts to train to 5200. Windows was unstable at 4800 and would crash after a minute or two (see pic). So I had to rollback again to FW 1.30 AS05

I was an early adopter with the MB, which is why all components in this system are QVL supported. Using QVL supported Gskill memory, there should be no need to train memory anyway. To say this is frustrating is an unederstatement - I've been down this path before with a much older FW. Then I had opened up a support case and ASRock never responded. Not sure if I'll waste my time again because ASRock doesn't appear to test their FW against what they recommend on the QVL anyway. This will be the last ASRock MB I purchase and at work I will deny the purchase of any workstations configured with an ASRock MB due to their poor support.



-------------
ASRock X670E Steel Legend (ABA159EAF581)
AMD Ryzen 9 7900X
32GB (2x16GB) G.Skill F5-5200J4040A16GX2-RS5K
WD SN570 2TB
MSI NVIDIA GeForce RTX 3080 Ti
Win 11 Pro


Posted By: Xaltar
Date Posted: 21 Apr 2024 at 10:48pm
RAM support is a tricky beast, particularly since the IMC is located on the CPU
on modern CPUs. This means any change to the IMC or a CPU quality issue adversely effects
RAM compatibility. Another major issue is that RAM manufacturers will often change
the components of a particular model of RAM without warning or notification. It's
not uncommon to see 2 RAM modules of the same model number have completely different
physical RAM chips on them. So long as the RAM chips meet the technical specs
of the model they will change them (usually due to availability issues). I am
sure you can guess that this also hurts compatibility.

Fairly often, unless you are seeing a lot of other people with your board model
reporting the same issue, the problem is coming from the CPU not the actual board.
I have a brand new out the box 3600 that never worked with anything over JEDEC
speeds on any board I have tried it in. It's memory controller was borderline bad
right out the box. Unfortunately it had been sitting on a shelf for over a year
before I tested it so I missed my return window and AMD refused an RMA citing
that it worked as intended at it's rated RAM speeds.

As I said in response to your reply in essential's thread, make sure your support
ticket went through and that you received the automated confirmation email.

-------------


Posted By: mrbill
Date Posted: 28 Apr 2024 at 6:06am
@Xaltar

Thanks for your response. FW 3.01.AS01 was released so I tried that with the same result - Windows crashes before loading so I'm back on 1.30.AS05 which is six FW updates earlier.

I ran into a similar problem a while back, but they corrected it on their own with a future FW update. I suspect the reason why there aren't many others reporting similar problems is because they are using different RAM or are just like I've been which is not reporting a problem for five FW updates. Regardless, I did submit a support request and did receive an email acknowledgement from them. So we will see if/when they do respond.

Have a good weekend.

-------------
ASRock X670E Steel Legend (ABA159EAF581)
AMD Ryzen 9 7900X
32GB (2x16GB) G.Skill F5-5200J4040A16GX2-RS5K
WD SN570 2TB
MSI NVIDIA GeForce RTX 3080 Ti
Win 11 Pro


Posted By: mrbill
Date Posted: 17 May 2024 at 8:59am
Just a follow-up on this. Received a response to my support ticket from Eric (USA). Asked if I tried different USB drives to update the FW, which I did and works just fine when rolling back to 1.30 AS05. He also sent a pic stating they recommend not updating FW if it's working ok. Problem is the LogoFAIL vulnerability exists in this FW, which I pointed out to him on August 29, 2024. I've received no response back. Not thrilled I'm running a MB with old FW that can't be updated to address security vulnerabilities.



-------------
ASRock X670E Steel Legend (ABA159EAF581)
AMD Ryzen 9 7900X
32GB (2x16GB) G.Skill F5-5200J4040A16GX2-RS5K
WD SN570 2TB
MSI NVIDIA GeForce RTX 3080 Ti
Win 11 Pro



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net