Print Page | Close Window

Low usb 3.0 speed before system restart?

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=313
Printed Date: 05 Mar 2024 at 2:58am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Low usb 3.0 speed before system restart?
Posted By: miroslav216
Subject: Low usb 3.0 speed before system restart?
Date Posted: 27 Jun 2015 at 2:42am
Hello everybody, am Miroslav from Bulgaria.
For the last half year I have Asrock Z97 Extreme Motherboard (bios version 2.10),  until now everything was fine.
Before two day I purchased my first usb 3.0 device - its 32 gb flash drive, model is  http://www.kingston.com/en/hyperx/usb#HXF30" rel="nofollow - HyperX Fury 32gb usb 3.0
Problem is that when I plug it in some of the Intel controlled usb 3.0 port in the back of the motherboard drive operate in usb 2.0 mode, to get usb 3.0 speed working I must keep flash drive plugged in the same port and restart the computer - after restart problem get fixed until I unplug flash drive and shutdown or restart.
I have tried three operating system and result are the same:
1. Windows 7 64 bit with Intel extensible host controller usb 3.0 driver installed
2. Windows 8.1 64 bit operating with native usb 3.0 driver (intel extensible host controller usb 3.0 is not needed for windows 8.1)
3. Ubuntu 14.10

Here is the speed when plug the flash drive for a first time in some of the four Intel usb 3.0 ports ~20write/40mb read:
http://i.imgur.com/sEVcJvp.jpg" rel="nofollow">
Here is the speed  after restarting computer and keeping flash drive plugged in the same Intel usb 3.0 port ~ 70mb write/140mb read:
http://i.imgur.com/M0d2OlF.jpg" rel="nofollow">

And here the speed when usb drive is connected to some of the two ASMedia ASM1042AE controlled usb 3.0 port (here I don't have any problem even before restart speed is the same and good for usb 3.0):
http://i.imgur.com/aRbMIrb.jpg" rel="nofollow">

To get usb 3.0 speed from Intel usb 3.0 port I must keep flash drive inserted in motherboard and restart the computer, after restart the computer device operate in usb 3.0 speed. When I plug flash drive in Asmedia controlled usb 3.0 ports there is no such problem even if I not restarting computer flash drive operate in usb 3.0 speed.

I decided to test usb with free program "usbdeview"  to see what is happening.

Here is a result from program when I plug flash drive in Intel usb 3.0 port, as you can see drive operate in usb 2.1 300mA mode:
http://i.imgur.com/fqwh8d1.png" rel="nofollow">
Here the result afrer restarting the computer and keep flash drive plugged in the same usb 3.0 port like before ,as you can see drive drive operate in usb 3.0 504mA mode:
http://i.imgur.com/tPs09ox.png" rel="nofollow">

One more test, this time with free program "USB View".
Here is when I plug flash drive for a first time:
http://i.imgur.com/Mno5kYW.png" rel="nofollow">
Here is after restart when keeping flash drive plugged in in the same port.
http://i.imgur.com/HdG6Lx1.png" rel="nofollow">

First I decided that problem is in USB Setting from bios and started to change some of the settings.
Here are some pictures of all usb options I have in bios:
http://i.imgur.com/H6Vj5VN.jpg" rel="nofollow"> http://i.imgur.com/bWiQoy3.jpg" rel="nofollow"> http://i.imgur.com/7n4ycEn.jpg" rel="nofollow"> http://i.imgur.com/Gnqhnwt.jpg" rel="nofollow"> http://i.imgur.com/2iNym28.jpg" rel="nofollow"> http://i.imgur.com/q6BCOfO.jpg" rel="nofollow">

I tried to change Intel usb 3.0 mode to Auto, Smart Auto and Eabled without effect.
Turning off USB Compatibility patch without any effect again. I even stopped Đ¢hird party Usb controller but again there is no any difference. 
Disabling Legacy usb and Legacy usb 3.0 resulted in that my keyboard and mouse stopped working in bios, but again there is no difference in USB speed.

Am not sure is that compatibility problem, or there is some settings that must be tweaked in bios or maybe something else.

Thanks everyone for help or suggestions and sorry for my bad English.





Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net