Print Page | Close Window

ASRock Z87 EXTREME4 won't restart - debug code 4F

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=3515
Printed Date: 26 Sep 2021 at 3:11pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: ASRock Z87 EXTREME4 won't restart - debug code 4F
Posted By: ilovejuice
Subject: ASRock Z87 EXTREME4 won't restart - debug code 4F
Date Posted: 30 Sep 2016 at 4:53pm
Hello,
I have ASRock Z87 EXTREME4 motherboard. Every time I restart my pc it gets stuck on debug code 4F (which is not listed on ASRock website). The screen is black as if the PC is off, all fans working. Nothing else happens.
When I hit "Reset" button - it gets stuck again, exactly the same situation.

The only way I can get past this is when I hold down "Power" button so the PC turns itself off. Then I hit "Power" button again to turn it on and it starts displaying something on the debug leds (changes quickly), it goes to debug code "4F" for a few seconds and restarts again. It repeats a few times (I feel like it takes longer every time I have to reboot it again) and then it finally starts working. I haven't noticed any other issues except for that.

Could you please tell me what I should do?

Also the temperature on my non overclocked i5-4670k with be quiet! Dark Rock Pro 3 cooler jumps between 34*C (min) and 48*C(max) when I'm writing this post. This is with only HWMonitor, some background apps and about 10 tabs opened in my browser. Isn't it too high?

I would really appreciate your feedback as right now I have no clue what to do and don't want to end up with my PC completely broken.



Replies:
Posted By: Xaltar
Date Posted: 30 Sep 2016 at 5:03pm
First stop, clear CMOS using http://forum.asrock.com/forum_posts.asp?TID=630&title=how-to-clear-cmos-via-battery-removal" rel="nofollow - this method.

Whenever you are having erratic post issues clearing CMOS by removing the battery is a good go to. Post back if that does not resolve the issue.

Also you only mentioned restarting, does the system shut down and power back on without issue?


-------------


Posted By: ilovejuice
Date Posted: 30 Sep 2016 at 5:26pm
It doesn't. I've turned it off and on after reading your post:
It started to display some very quickly changing numbers on the debug leds with black screen (as if PC off), but all fans working. I <think> I managed to catch some of these:
03, 15, 19, 3B, 10
Then it gets stuck on "4F" for a few seconds and it repeats the cycle. I waited about 20 cycles, no success. Then I hit "Reset" and it started displaying some quickly changing numbers on debug leds again, then went to "B2" and it actually turned on and started working again.

So it look like the CMOS battery is just above the Reset and Power buttons on this motherboard? Then it's blocked by my GPU. Is using "Sleep" instead of turning it off a safe way to keep it working until I have time to disassemble my PC and do a proper CMOS reset?

PS. I forgot to mention that in last 1-2 months electricity in my area went down while I was using my PC. May it be the reason for CMOS errors?


Posted By: Xaltar
Date Posted: 30 Sep 2016 at 8:19pm
With UEFI based motherboards there are any number of causes for corruption. Windows updates, power outages, changing major hardware on the board like RAM, CPU or GPU. A lot of this never used to happen with the old BIOS setup but, then again the old system was very limited and less intuitive. 

I am not saying that your problem is definitely UEFI related, it is very likely given the symptoms but it could be a different issue entirely. Ruling out UEFI corruption is the simplest first step and most often resolves the issue. 


-------------


Posted By: ilovejuice
Date Posted: 30 Sep 2016 at 9:44pm
Thanks a lot for your quick answer. I will get back here after I reset CMOS.


Posted By: hryelle
Date Posted: 17 Oct 2016 at 7:33am
Hey, I had something very very similar to this problem like 2 weeks ago after I upgraded gpu and monitor - I have the same mobo too. Nothing worked, until a mate of mine suggested restoring the main bios with the backup bios. That seemed to fix it, and have been stable since. I reseated components, cleared cmos etc, but this was the only fix.


Posted By: Shigaev
Date Posted: 15 May 2017 at 3:25am
" rel="nofollow - I got the same problem with my Z77 Extreme 4. "4F" and nothing more. Coolers work, but the screen does not react. Although a few days ago, the computer turned on (after multiple cycles of "F4"). Resetting the BIOS did not help.

Has anyone already solved this problem?

P. S. Here they talked about the restoration of the bios. My UEFI looks workable, but I would like to have a spare move. What is the recovery procedure?


Posted By: Zearon
Date Posted: 19 Nov 2017 at 3:58am
Same problem here. After power on while all coolers are working got repeatable post codes 15 and 4f.

CMOS cleared, all cables checked, 2 modules of RAM were changed in all possible positions.

PC not working, nothing happens.

Just wanna know how to be sure is it a motherboard error or maybe RAM, so i csn buy a new one.

Please help!


Posted By: tempy
Date Posted: 19 Nov 2017 at 8:48am
According to this forum post, 4F is a faulty BIOS Chip. Temporary solution would be to switch BIOS A with BIOS B, and acquire a new one online to replace BIOS B. Tried it on mine and it worked, and it happened right when I attempted System Restore on Windows 7, thought I corrupted the OS on my SSD but no, I figured a mobo code has nothing to do with SSD filed being corrupted.

https://forums.tweaktown.com/asrock/62764-asrock-error-code-4f.html" rel="nofollow - https://forums.tweaktown.com/asrock/62764-asrock-error-code-4f.html


Posted By: parsec
Date Posted: 19 Nov 2017 at 9:43am
The Dr Debug display shows various POST codes as the POST process runs when the PC starts. That does NOT mean each code you see is flagging an error.

The only code shown that has any significance is the last POST code shown, and then ONLY if the PC does not allow you to enter the UEFI/BIOS, or does not boot your OS. If you can get into the UEFI UI or boot the OS, POST completed fine, and any code shown is just leftover, the code of the last POST process that ran.

While an electrical problem could have caused a damaged UEFI chip, just the UEFI code may have been corrupted. I would first try to install whatever UEFI version you are currently using again, and see if that solves the problem. Please use the Instant Flash method to flash to the same or newer version, it is the most reliable.

If that does not work, as suggested above, switch to the backup UEFI chip, and see if the board still behaves as it has been with your issue. If that seems to fix the problem, you can get a new UEFI chip from ASRock and insert it yourself, no soldering necessary.




-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: HaveNoName
Date Posted: 14 Jan 2018 at 5:16pm
I had 4F error when waking up from sleep cause i had disabled gear down mode.


Posted By: rafadr
Date Posted: 23 Feb 2018 at 9:25pm
Originally posted by tempy tempy wrote:

According to this forum post, 4F is a faulty BIOS Chip. Temporary solution would be to switch BIOS A with BIOS B, and acquire a new one online to replace BIOS B. Tried it on mine and it worked, and it happened right when I attempted System Restore on Windows 7, thought I corrupted the OS on my SSD but no, I figured a mobo code has nothing to do with SSD filed being corrupted.

https://forums.tweaktown.com/asrock/62764-asrock-error-code-4f.html" rel="nofollow - https://forums.tweaktown.com/asrock/62764-asrock-error-code-4f.html

Replacing BIOS A chip with BIOS B chip solved my issue too. Thanks, I had this problem for a while.

I'll buy a new BIOS chip to replace the problematic one.

Here is an image with the location of BIOS chips:






Posted By: rafadr
Date Posted: 06 Mar 2018 at 6:53pm
According to the Asrock support, we can switch BIOS A to BIOS B by changing the BIOS jumper.



After changing, you can enter in BIOS setup and backup the working BIOS to the corrupted one.

No need to buy a new chip.

Cheers!


Posted By: enorbet2
Date Posted: 11 Jul 2019 at 9:18pm
Greetz
I know this is nearly necro but I'm still using my Asrock Z77 Extreme 4 for my Main and it has served me quite well for years but I have much older PCs that work just fine. I'm a bit peeved at this issue for such a ridiculously small thing to make my whole system unreliable. Here's my exact deal.

It began slowly and escalated. First 3 quick beeps followed by a pause and another set of 3. Since that is supposed to be memory issue and I spent a lot extra for Corsair Vengeance hi performance ram, naturally I ran Memtest+ for many hours - No errors. It was common that after a Reset pulse or 3 it would boot and run for months (up 25/7) just fine. Since I have a 1KW UPS it has never suffered spikes or a bad shutdown.. but it kept getting longer (more cvcling, more beeps) any time I did have to reboot. It would, like everyon's here, pause at 4F and recycle... for very long times.

Finally one day the Reset button stopped working altogether! so I cleared CMOS (removed battery too) and then just let it run for around an hour till it finally came up and I successfully Instant Flashed a newer BIOS version. RESET is fixed but that is ALL!

I don't see anything in my Manual about Backup BIOS nor any chips marked so on the board. I don't know how to swap for Backup despite having experience at Hot Swapping BIOS chips back in the day.

TLDR - Where do I find and/or how do I swap for Backup BIOS?

Is it necessary to buy a new CMOS chip?

Any help greatly appreciated. Thanks.


Posted By: enorbet2
Date Posted: 12 Jul 2019 at 11:28pm
Nevermind... I guess this just shows how rattled and pissed off I am. I totally missed this thread is specific to Z87 not Z77... guess Asrock wised up after Z77...kinda. No backup chip for me :(


Posted By: badbri
Date Posted: 15 Jul 2019 at 8:52am
Your BIOS is socketed not soldered so you may be able to get a new BIOS chip from Asrock support. Go here: http://forum.asrock.com/forum_posts.asp?TID=5265&title=howto-contact-tech-support
However being near 7 years old it may be more than the BIOS that has gone bad.

-------------
https://www.passmark.com/baselines/V9/display.php?id=99573335296


Posted By: enorbet2
Date Posted: 16 Jul 2019 at 2:16am
Thank you for your reply and useful link, badbri. FWIW I'd be more disappointed than I already am if anything else is bad, considering how I build my systems with superb cooling and the best PSUs protected by 900 watt UPS. Monitoring voltages and temps seems essential to me and my Asrock rarely exceeds 47C though the GPU will hit 56C during heavy loads.

I have many PCs more than twice as old that still run just fine, including a few Socket 7s and even an Asus Slot 1. I'm typing this from the Asrock Z77 right now. It runs just fine. It's just that if it shuts down it can take upwards of an hour to get past the 4F cycling and it isn't the code that is corrupted since it successfully flashed but to no avail. Something must've physically failed in the chip.

Anyway thank you since I'll likely try replacing that chip.


Posted By: tamas3232
Date Posted: 07 Jun 2021 at 4:43pm
Hi, i am leaving this here if anyone else now or in the future has the same problem.

I had the exact same issue with my PC what was mentioned, Error Code 15,40,4F. I had a lot of issues with electricity, daily 5-10 power-outfall. I also connected my PC to an Back UPS (APC brand) but i guess it was too late and this sudden powerloss corrupted the BIOS Chip.
I resetted every memory stick, my GPU, only had just the drive connected which has the OS. In my case i has an PCI-E to M.2 SSD adapter(Axagon), with the M.2 NVMe Samsung EVO 1TB SSD.

So, i tried out everything like above mentioned, resetted the CMOS memory, changed the battery too, but it did not solved in my case.

The solution was actually really easy at the end. I placed the BIOS jumper from A to B. After that my PC could boot normally. In the Boot Menu under Tool there is that line "Secure Backup UEFI (B->A)". I clicked on it and wrote that after a restart (which occurs automatically) will start the copying process. After the buckup, I resetted the BIOS jumper from B back to A and it started normally as it should. I also made a BIOS Update because of teh mentioned OS drive is an NVMe drive, just the newer 3.40 version has NVMe support, so after I updated that too, everything is fine. I ordered a new BIOS Chip just in case but eventually it turned out that my BIOS Chip did not die.

Have a nice day guys.

Tamas


1. https://ibb.co/wrKtQ6v" rel="nofollow - Boot Menu --> Tool


2. https://ibb.co/T1tFL48" rel="nofollow - Backup Process



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net