Print Page | Close Window

Z77 Extreme 6 Error Code 10 and 15

Printed From:
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
Printed Date: 24 Jun 2024 at 2:27pm
Software Version: Web Wiz Forums 12.04 -

Topic: Z77 Extreme 6 Error Code 10 and 15
Posted By: Aaabii
Subject: Z77 Extreme 6 Error Code 10 and 15
Date Posted: 24 Apr 2015 at 3:22pm
ı get a error code 10 and 15 on startup, fans spin for 2-3 seconds and system reboots to a infinite cycle. I get the code 15 right before the code 10 (maybe miliseconds but long enough to read.)
My system is:

i5 3570k
Z77 Extreme 6
GSkill Sniper 2x4
1 TB Caviar Black HDD

Tried to remove rams trying 1 stick at a time on all slots wih no success.
Removed GPU and HDD,
Reinstalled CPU and heatsink,nothing works.

Tried to remove all the rams, error code doesnt change.
I have no idea whats going on. Will replace the faulty part if i can identify it.
Wiating for your response.
Thank you.

Posted By: ASRock_TSD
Date Posted: 27 Apr 2015 at 2:01pm
Dear customer,
This is ASRock Technical Support Department.
Thank you for the query.

We provide some suggestions to try:
1. Please refer the user manual page.38 to clear CMOS settings for try:
2. Please reinstall the CPU and check whether there's any bent or broken pin in CPU socket.
3. If possible, please use another CPU, memory to verify. 

Kindest Regards,

Posted By: Drbones420
Date Posted: 04 Jun 2015 at 6:04am
Replying here instead of making a new thread, 

My setup is very similar to the OP's:
i5 3570K
Z77 Extreme 4
2X G.Skill Sniper 4gb: F3-14900CL9D-8GBSR
EVGA GTX 660 2gb
Soundblaster Fatal1ty platinum soundcard with front I/O bay. 
Samsung 840 Evo 120 GB OS drive

This system is currently operating normally when using shutdown and normal power on procedures, however fails to boot when using any restart function both in OS, and via UEFI. 
The Error codes I receive when failing to restart indicate 10 for a millisecond, then hang's on 15 (both seem to be related to Northbridge and Southbridge Initiation) after sitting on code 15 for about 10-30 seconds, system will restart and continue showing the same codes. 

I've reseated every component on the motherboard and verified no bent pins on processor, or elsewhere, all system components fully seated and not having any problems when successfully booted. 

I'm not sure what exactly causes the system to power on and boot OS normally when it does succeed, normally I'll lay down my case remove side panel, double check connections, and after a few tries the mobo POST's normally and continues to boot OS as normal, usually accompanied by a UEFI message regarding "The system has failed to boot 3 times, you can hit F2 or del to enter UEFI to verify settings" etc etc. obviously I wait and let the system boot normally after that otherwise closing the UEFI will force another restart and the same loop again. When the system boots into OS, everything goes back to functioning normally, and when updating software prompt's for restart I use the shutdown and power on function to "Reboot" to complete the software installations. 

I've also noticed recently when trying to setup and operate the system using the Lucid Virtu feature that my computer never recognizes the on board intel video card, and when attempting to install the intel drivers, or the Lucid Virtu software, both indicate there is no compatible hardware within the system, i've attempted to boot with monitor HDMI connected only to the onboard, both on board and discreet gpu, or just gpu with no luck, the only thing i've yet to try is to uninstall my Discreet gpu to boot normally with on-board. I've been hesitant to do this as i'm worried that the restart loop problem may be tied to the Onboard intel graphics card failing or not functioning normally when it hangs on the error code 10+15 for north/southbridge initialization. 

It is not possible for my to test with another cpu or memory, but considering when it correctly boots my OS it operates as smoothly as Day 1 build boot, i doubt its a processor or memory issue. 

Any assistance would be greatly appreciated. 

Posted By: Xaltar
Date Posted: 04 Jun 2015 at 2:10pm
Another avenue to check is power, if the power supply is inadequate or faulty it can cause failed post. It is unlikely seeing as PSU caused faults tend to be more random rather than the same repeated error but worth ruling out. From the error codes it would seem something is failing between pre-memory Northbridge initialization and post so sadly it could be any component initialization causing the problem. In the case of Drbones420 it may be the northbridge bugging out as it actually hangs on code 15. These 2 scenarios are not the same problem. The 2 systems are showing different symptoms after the same status codes.

Drbones420: I suspect in your case that the problem may be solvable by clearing CMOS with the jumper on the motherboard. It sounds like you have some corrupt data in your bios settings.

Aaabii: Your problem seems more serious as it is preventing post completion and freezing up before boot can occur. As Asrock tech support suggested you can try clear CMOS too but in your case there may be another problem. Additionally, is this a new build or did the system develop this issue? It has worked at some point?

Posted By: Drbones420
Date Posted: 07 Jun 2015 at 6:23am
Hello again, and thanks for the input, gonna start with an update.

So once again randomly, it went back into its code 15 hang and was not able to force UEFI/OS to load/boot, so I went about disconnecting and reconnecting all major components, I removed my add in pci-e/pci cards, removed both sticks of ram, I then disconnected my corsair processor water block/radiator/fan, cleaned thermal paste off block and processor with isopropyl alcohol. unseated the processor and inspected chip and socket for any issues. Everything was pristine on the processor side, and socket: no bent pins no hair or dust, no corrosion or charring etc. Double checked all my power connections, and re-connected ram, water block and radiator/fan (after cleaning the tons of dust from radiator fins), ram install, Soundcard (pci) install, and prior to GPU install disconnected CMOS battery then reconnected GPU. reconnected case fans and reconnected power for boot test (no other cables connected). 

code 15...

so i wondered if ram might be bad, so tested seperate dual channel port first, cmos reset button to boot system: code 15, tested single ram chip-cmos reset buttom, system booted so went into UEFI to ensure settings for peripherals were correct, save and exit>forced restart> code15. Tested the chip that booted system in multiple ports including the one it booted with last time> code 15. Tested other ram chip in all ports with cmos reset button on each install> all code 15. Reinstalled both chips into original ports where they worked prior to code 15 issues and took a break for a few hours. When i came back the system booted into windows normally, and it has not been shut off since, fearing dreaded code 15 will rear its ugly little head again. 

So I did all the above before coming back on here to see if anyone commented or suggested anything. And as I saw your advice about CMOS jumpers I presume from my research that the Clear CMOS button on my I/O panel on mobo does the same function as switching jumpers, or reseating CMOS battery. And have ruled that out as a possibility (Maybe flash UEFI? usually dont mess with that unless all else has been tested). The other comment was regarding my power supply, i'm currently running the EVGA nex 650 Gold modular power supply which does have a 10 year warranty, so whenever i eventually shut the system off and get code 15 again, i'll look into testing with a separate power supply to see if that may be the culprit and if all else fails may try the UEFI flash to newest version. After that I've got to presume there is something on the MOBO that is causing the error (northbridge not behaving?).

Let me know if this further input adjust's any advice previously given, or if there is any new advice of things to try. 

Ohh PS. after the system booted correctly mysteriously, my OS saw the onboard intel graphics, I installed the drivers for that, then installed Lucid Virtu MVP from mobo disc, and it seems to be working (although getting less frame rates than when not using it 30 fps vs 60 fps without, granted D-GPU is running cooler with less usage) .

Thanks again. 

Posted By: Drbones420
Date Posted: 07 Jun 2015 at 6:25am
Ohh and I built the machine Nov 2013, and up until about 5-7 months ago everything was working flawlessly. So it seems as though the problem developed over time. 

Posted By: parsec
Date Posted: 07 Jun 2015 at 11:13am
The Clr CMOS button on the IO panel functions the same as the CMOS jumper on the board. Removing the board's battery also functions the same as the other two, but also causes a few other things to be reset, like the boards RTC (clock), and some memory in the CMOS/BIOS chip.

BTW, I have two Z77 Extreme4 boards, and have never had this problem. That does not mean that you cannot have this issue, my point is this is not a known bug that this board has.

What UEFI/BIOS version do you have now? The Main screen will show the version number, and it usually is shown on the ASRock splash screen displayed when the PC boots. Given the date you built the PC, unless you got an older stock board, it probably has a newer version. If you have a 1.xx UEFI/BIOS version, it is worth trying updating to the latest version, 2.80. I recommend using either the Instant Flash method, a feature found in the Tools section of the UEFI, or the Internet Flash method (again in Tools), but only if your ISP is good and you are using a wired Internet connection.

Let's go into some random things to check, which might randomly help you out.

You have a Samsung 840 EVO, what SATA interface are you using? Your board has two, the main Intel SATA support and the add on ASMedia 1061 SATA chip. The two gray SATA ports at the top of the stack of ports as viewed with the board mounted in a case, are the ASMedia SATA III ports. The two gray SATA ports below them are the Intel SATA III ports. Below that are the black Intel SATA II ports.

The Intel SATA III ports will provide the most stable and fastest SATA connections on your board. The ASMedia chipset does not perform at the same level that the Intel chipset does. If you are using an ASMedia SATA port for your SSD, you should change to an Intel SATA III port. Just move the data cable.

In the Storage Configuration screen in the UEFI, if the SSD is connected to an Intel SATA port, and you click on the SSD's listing, a few options will appear. One of them is SATA Device Type, which should be set to SSD. The default is Hard Drive.

Still in Storage Configuration, hopefully you are using AHCI as the SATA mode. If SATA Aggressive Link Power Management is enabled, set it to disabled. This option can cause issues with some drives.

Have you looked at Device Manager recently, to see if there is a problem with a device?

What version of Windows are you using?

The random appearance of the Intel iGP is curious, and hints at some other issue lurking somewhere that may be related to your 15 POST error. The iGP should not randomly appear if its driver was not installed and it did not have a cable connected to one of its outputs. That may be why it seemed to appear, a cable was connected to it.

Posted By: Drbones420
Date Posted: 08 Jun 2015 at 8:54am
Hey Parsec, Thanks for the interest, i'll do my best to get all the info you need, here goes:

Bios version for mobo UEFI: currently running version p2.80 and don't currently have a physical internet connection, even though this is the most current version referenced from you above, a reflash may solve any errors or corruption, I will have to bring it into work to get a lan connection to use the UEFI's internal flash utility.

Samsung EVO 840 connected to the first bottom grey port labeled: SATA 3_0 which if I understood correctly during installation is the correct port for intel SATA support. (if looking from the side starting at the bottom of the board progressing toward the northbridge - there are 4 ports- all black labeled: SATA2_4(bottom)_5(top), SATA2_2(bottom)_3(top). Then progressing further from bottom of board towards northbridge-grey ports labeled: SATA3_0(bottom- Evo plugged in here)_1 (top), and lastly SATA3_A0(bottom)_A1(top).)

The UEFI settings for the sata, are SSD, and AHCI mode is set. 

Device manager: everything reports normally aside a programmable Root Enumerator which was from my MadCatz R.A.T.7 gaming mouse. it is currently disabled. 

Currently running Windows 7 X64 with all current critical updates, I rarely do any of the Optional updates usually following the mantra "If it aint broke dont fix it" and none of the optional ones reference anything regarding these problems, certainly I would try them but for w/e reason it feels highly unlikely a windows update would cause these pre UEFI reboot loops. 

the iGP I shut off in the EUFI when i initially built the system so as to only use the discreet GPU, which worked fine thus far. I then read about Lucid Virtu feature of the MOBO's iGPU. Considering sometimes my system boots normally, i played around with some of the iGPU settings in the northbridge UEFI to enable it so I could install its drivers (intel HD graphics) after the next few successful os boots, device manager wouldn't show the iGPU to allow me to install the drivers. Later during my troubleshooting of the code 15, it booted to OS and all of a sudden recognized it and failed to update drivers through win7, i had previously downloaded the intel drivers along with the virtu MVP software, installed intel drivers, shut down, booted back up, installed virtu, shutdown booted back up, and tested, unfortunately after using it in the only game I play: FFXIV-ARR, my framerate halved, as opposed to the advertised increased performance and FPS. LOL so i've uninstalled it and continuing with Discreet gpu. 

Posted By: Drbones420
Date Posted: 19 Jun 2015 at 8:21am
Hey touching base again haven't seen any activity with posts since my last so gonna try and update again. 

Still getting periodic code 15's, the last one i got disconnected all power and I/O cables, add in card cables, opened up case and started inspecting, noticed after a few minutes that my ram had popped out (I know I reconnected it during last teardown/rebuild as I double checked both sticks and side clips twice) It was only on the top side of the board one of the lock clips was not clipped and the top side of the chip was slightly raised out of the socket, re-seated, and proceeded with some cable management. Double checked all connections and closed case back up, connected all I/O: Powered on and... BOOOT!!! That was a few days ago, and today I got it again. So i popped open case to visually inspect ram, all seated fine, tried a few more times with all code 15's, then i just let it sit. Went and ran some errands and came back, booted normally. WTFLOL... so idk, i've yet to try another power supply, but that may be the ticket unless the ram randomly wants to pop out randomly >.< we'll see, onto further testing. 

Posted By: Xaltar
Date Posted: 19 Jun 2015 at 12:26pm
In situations like this it pays to reseat everything and even clean contacts where possible. I have seen the most erroneous problems caused by something as simple as dust or corrosion preventing contact somewhere. I remember troubleshooting a data server only to discover that a small clump of animal hair had somehow found its way into one of the RAM slots and was preventing proper contact, I was the third tech to look at the thing and the only one who actually bothered to check the contact points rather than just pop the ram out and back in again lol.

If connections are not the problem then power is your next gremlin to look at.

Posted By: parsec
Date Posted: 19 Jun 2015 at 12:48pm
The POST codes listed in the Z77 Extreme4's manual for codes 1 - 55 give specific reasons for each code, although most are directly related to memory problems.

In the manuals of newer boards, codes 1 - 55 are simply called memory related problems. In your case I would suspect the memory if it happens again. Or reseat the 24 pin power connector to get a fresh connection.

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -