Print Page | Close Window

x99E ITX/AC Broadcom 802.11ac Issue

Printed From:
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
Printed Date: 09 Dec 2023 at 7:37pm
Software Version: Web Wiz Forums 12.04 -

Topic: x99E ITX/AC Broadcom 802.11ac Issue
Posted By: JoeMamma!!
Subject: x99E ITX/AC Broadcom 802.11ac Issue
Date Posted: 11 Jul 2015 at 10:45am
I recently built a new rig with the ASRock x99E ITX/AC. I did a clean install of Windows 7 and installed the ASRock drivers. The Broadcom 802.11ac connected to my router with no issues. I started to run the Windows updates and thought everything was fine. I shut down the PC and in the morning when I rebooted I noticed I could not connect via WiFi. I opened up Device Manager and noticed the yellow error icon on the Broadcom 802.11ac Network Adapter. I tried uninstalling and let Windows reinstall the driver but that did not fix the issue. I then uninstalled and deleted the drivers...then reinstalled the drivers. That didn't work either. I had a spare Intel 7260 dual band network adapter that I tried, but I got the same exact results, so I don't believe it to be an adapter issue. I tried different drivers with no success. Anyone run into this issue?

The error code I get is the generic "This device cannot start. (Code 10)"
Under the Resources tab it says "This device isn't using any resources because it has a problem"

Uh right! 

Posted By: odiebugs
Date Posted: 11 Jul 2015 at 11:38am
Download and try driver sweeper if you haven't gone through windows, System 32 and made absolutely sure there are none left. 

Try using driver -

Make sure you uninstall old software from programs,  run setup and check, if same with driver, then point the hardware to the driver and force install it in devise MGR.


Posted By: Xaltar
Date Posted: 11 Jul 2015 at 2:16pm
It sounds like windows update is up to its old tricks of breaking more than it fixes lol. Drivercleaner is a good suggestion.

Boot into safe mode and delete all network adapters being sure to select "display hidden" so you know you got them all. Then run driver cleaner to kill any left over files/registry entries.

If that does not work then you may need to restore/reinstall your OS and skip the updates or select only the essential ones.

Posted By: JoeMamma!!
Date Posted: 13 Jul 2015 at 4:29am
First of all thank you for people like you who are here for support. 

Instead of trying to troubleshoot the issue any further, I decided to just re-install Windows 7, however in one last ditch effort I tried running the Windows Repair/Restore feature and try to restore it to an early version. It failed to complete successfully, but when I proceeded into Windows 7 the Broadcom 802.11ac Network Controller error icon disappeared, and I was able to connect to my wireless AC router. Part of the restore did appear to work because there were 16 new updates (7 security and 9 Windows x64) that I had previously installed already. I installed the 7 security updates first and after a reboot the Broadcom network controller still worked. I then proceeded with the other 9 Windows x64 updates and after reboot the Broadcom network controller still worked. I didn't make any changes in the BIOS either. 

I was unable to determine the root cause of this issue to help other users, but things seem to be working now. 

Posted By: Xaltar
Date Posted: 13 Jul 2015 at 12:26pm
Good to hear, enjoy your new PC Thumbs Up

Posted By: Jon
Date Posted: 13 Jul 2015 at 12:27pm
JoeMamma, I have the same motherboard and had the same issue as you a few weeks ago.  I RMAed the wifi module.  The new one worked for around a day and then stopped working.  Some have suggested it may work fine in a different motherboard or with a different OS but I have not tried those things.

I bought an Intel wifi/BT card to replace the Broadcom one.  I haven't installed it yet but one other forum user commented that the Intel card was working well for him.

Hopefully Broadcom or ASRock can come up with a solution or perhaps Windows 10 will handle the wifi card better than Windows 7 does.  (I also have Win7 64-bit.)

More discussion here:" rel="nofollow -

ASRock X99E-ITX/ac | Intel i7-5820K | ASUS GTX 970 mini | Samsung 850 EVO 250GB | Crucial Ballistix (2x8GB) | Corsair CX600M | CoolerMaster Seidon 120V | CoolerMaster Elite 110 | Windows 10 64-bit

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -