Print Page | Close Window

ASRock Fatal1ty AB350 Gaming K4

Printed From:
Category: Media&User's Review
Forum Name: AMD Motherboards
Forum Description: ASRock AMD Motherboards
Printed Date: 28 May 2024 at 10:54pm
Software Version: Web Wiz Forums 12.04 -

Topic: ASRock Fatal1ty AB350 Gaming K4
Posted By: drewster411
Subject: ASRock Fatal1ty AB350 Gaming K4
Date Posted: 20 Apr 2017 at 9:36am
" rel="nofollow - ASRock Fatal1ty AB350 Gaming K4

Hi Does anybody know what's correct RAM Dimm config for this MoBo. I have it in as A2+B2 Dimms. I have 2 sticks of Cosair Vengeance LPX 3000 (2x8) total 16G. It's QVL listed for this motherboard (CL15. 15-17-17-35)@ 1.35v. But it only works in 2133Mhz at default. Even if I put it to A-XMP Profile. Nothing works. I have latest Bios (v2.20) as well as Ryzen_Balanced_Power_Plan installed. The only thing I can think of is to put the DDR's into different dimm config. Maybe A2+B1 dimm config. The manual was kinda confusing in regards to DDR RAM configuration. They should have some picture illustration of...if 2 ddr's...with arrow pointing...go here, etc. But instead the confusing chart.

Also should I disable cool-&-quiet when I overclock cpu on UEFI, just curious I already did but wondering does it make any differnece when it comes to overclocking cpu. It's stable 3.9Ghz @ 1.35v. I tried 3.9Ghz @ 1.3375v it booted into windows but wasn't stable. So my sweet spot is 3.9Ghz @ 1.35v. I have AIO liquid cooler in push&pull (Corsair H100) So temps are min:33c max 51c. 

Also does anyone with AMD graphics card having issues with installing 'crimson relive drivers' I have msi rx480 armor oc version. Can't install it!!! it keeps giving me "Radeon software has been partially installed...error 1603,etc."
I tried un-installing it with DDU 'display driver uninstaller' and it didn't resolve anything...still the same error 1603. But after like 3hrs of this nightmare, it installed 'crison relive driver v17.4.1' and I'm affraid to update to the latest crimson driver. Also msi after burner doesn't work. I was able to overclock msi rx480 to (1345 boost / 2132 memory) default 1291/2000. But now it's just on default. Is there another GPU overclocker that I can try besides Wattman? maybe Sapphire Trixx?

Does anyone have any answers to any one of these issues that I'm currently having, pls let me know?? thx 

ASRock Fatal1ty AB350 Gaming K4
Win10 X64 Build v1607 
Rosewill 1300w modular power supply
Cooler Master: Cosmos full atx case
Cosair veneance lpx 3000 ddr4
Corsair H100 AIO Liq cooler
msi rx 480 8Gb armor oc gpu
intel 180g ssd
2x veloci-raptor 300G in RAID 0
Samsung 120hz 3d monitor


Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -