Print Page | Close Window

BIOS update mistake on X370 Taichi

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=4928
Printed Date: 25 Feb 2024 at 12:53pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: BIOS update mistake on X370 Taichi
Posted By: bukankhadam
Subject: BIOS update mistake on X370 Taichi
Date Posted: 23 Apr 2017 at 3:22pm
" rel="nofollow - Hi. I just bought x370 taichi this week and tried to update my bios. I used the update through windows and stupid of me to not read the how-to properly on asrock website. (I'm new to this kind of thing. So pls pardon my stupidity ) instead of clicking the 'UpdateBIOS' patch file in the downloaded BIOS update file, I stupidly run one of the exe file (afuwin64.exe) in AfuWin64 file that is also in the BIOS update file. After that, I proceed with the exe file and save the things that it do and then restarted my PC. When restart, the system run with all fans and LED like normal but the DrDebug on the the mobo went bat sh*t crazy displaying a lot of error number in quite high speed. The monitor did not pick up any signal and the keyboard is also not detected.

After this happen, i try all sort of things to recover the previous BIOS such as clear CMOS, reset with the jumper, taking out the CMOS battery and so on but nothing works. I'm really feeling hopeless now and need some help.

Do I have any other choice than to return the mobo to the shop I bought it and ask or replacement or RMA? Does this stupid mistake of mine even covered by RMA? Please somebody/anybody, help me fix this.   I know it's my fault for doing this stupid thing but please help me..



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net