Print Page | Close Window

X370 taichi boot problems

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=4946
Printed Date: 03 Mar 2024 at 8:08pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: X370 taichi boot problems
Posted By: zjwenker
Subject: X370 taichi boot problems
Date Posted: 25 Apr 2017 at 3:33pm
" rel="nofollow - So today I tried to start up my computer and got the error code 0xc000000e.

So while browsing the internet i came across a post telling that the problem mostly is that the motherboards settings aren't correct to see the drive where the windows is installed on,

 ( http://www.tomshardware.co.uk/answers/id-2744141/error-code-0xc000000e.html )

 so I took a look in the bios and at the boot settings I cannot see my samsung nvme drive. 

So my question is,  where can I find the option to turn on Ahci mode?

Thanks in advance.



Replies:
Posted By: TooQik
Date Posted: 25 Apr 2017 at 5:30pm
In the BIOS you should have an option in the Advanced tab named Storage Configuration where you'll find your SATA configuration settings.

Make sure SATA Controller(s) is set to Enabled and SATA Mode is AHCI.

Some others have had issues with disappearing SDDs, so read through some other post in this forum to get some other ideas on what / where to check if the above doesn't help.

Good luck.


Posted By: datonyb
Date Posted: 25 Apr 2017 at 7:45pm
" rel="nofollow - also are you set to windows uefi boot as first option ?


-------------
[url=https://valid.x86.fr/jpg250][/url]

3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold


Posted By: parsec
Date Posted: 25 Apr 2017 at 11:35pm
Originally posted by zjwenker zjwenker wrote:

" rel="nofollow - So today I tried to start up my computer and got the error code 0xc000000e.

So while browsing the internet i came across a post telling that the problem mostly is that the motherboards settings aren't correct to see the drive where the windows is installed on,

 ( http://www.tomshardware.co.uk/answers/id-2744141/error-code-0xc000000e.html )

 so I took a look in the bios and at the boot settings I cannot see my samsung nvme drive. 

So my question is,  where can I find the option to turn on Ahci mode?

Thanks in advance.


What version of Windows are you using?

How did you install Windows on your mystery Samsung NVMe SSD?

AHCI mode is the default SATA mode in the UEFI/BIOS, Storage Configuration screen, for any Ryzen board.

But if you are using a Samsung NVMe SSD, that drive uses the NVMe protocol, not the SATA protocol. It is not a SATA drive, and does not use the SATA controller or SATA driver on any Ryzen board. Different SATA modes make no difference with an NVMe SSD.

There is no specific NVMe setting that needs to be set in the UEFI/BIOS, like the SATA mode, since the NVMe controller is part of the SSD itself.

As datonyb said Thumbs Up, did you configure anything in the UEFI/BIOS for UEFI booting your NVMe SSD?

You should see your NVMe SSD listed in Storage Configuration, M2_1 slot entry. Did you try clearing the UEFI/BIOS with the jumper on the board, or the CLR CMOS button on the IO panel, and then check Storage Configuration and the Boot Order again.


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: zjwenker
Date Posted: 26 Apr 2017 at 4:02am
" rel="nofollow - So I tried the jumpers and now I can see the nvme again, is there any way to make sure the ssd doesn't disappear again? Or should I just not install the windows on the nvme slot. im using the latest version of windows so I don't think this is the problem, I did all updates. I installed the windows via a usb stick.


Posted By: datonyb
Date Posted: 26 Apr 2017 at 4:38am
" rel="nofollow - give me a few mins im uploading some bios pics of my taichi and samsung 960 for you to compare

you did install windows in uefi mode ?
ive tried twice to screenshot the opened options here but its not opening the file after uploading
on this windows boot manager then has samsung written after it (first boot option)
http://smg.photobucket.com/user/datonyb/media/170425213313_zpsorf2odm9.png.html" rel="nofollow">

and here is my storage options tab (i have not installed my evo850 yet) so its not showing any at present but does show my settings
http://smg.photobucket.com/user/datonyb/media/170425213212_zpscadasdw8.png.html" rel="nofollow">

one other thing to note
after installing the 960 nvme and windows and then samsung magician and nvme drivers
it was still set in windows to defragment the drive automatically i had to manually turn this off to prevent early hard drive wear (something the samsung magician software usually turns off on installation)
make sure you check this is off on yours


-------------
[url=https://valid.x86.fr/jpg250][/url]

3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold


Posted By: zjwenker
Date Posted: 26 Apr 2017 at 4:44am
" rel="nofollow - what do you mean in uefi mode? , I installed windows trough my ssd from my old computer, so I put the ssd from my old pc in my new build, booted the windows and in windows started the usb stick. then in the windows installer I formatted the ssd and choose the nvme ssd as the boot drive.


Posted By: datonyb
Date Posted: 26 Apr 2017 at 4:47am
" rel="nofollow - on a clean install from usb you look for option to install in uefi mode

here check the video
1min 55 seconds in > until 4 mins

https://www.youtube.com/watch?v=xURz-SSQUVY


-------------
[url=https://valid.x86.fr/jpg250][/url]

3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold


Posted By: zjwenker
Date Posted: 26 Apr 2017 at 2:50pm
So i booted the installer via uefi mode and at the windows installer my nvme ssd is no where to be found, also in the motherboard it isn't showing upp. While last time I installed I could see it, and when I try long enough to boot the pc I can usually get in the nvme ssd.


Posted By: zjwenker
Date Posted: 27 Apr 2017 at 6:22am
" rel="nofollow - Today i installed the windows trough UEFI mode to make sure it works correctly. after shutting my computer down the nvme slot disappeared again. after 20 reboots still nowhere to be found. so I tried the jumpers on the motherboard again and it booted as if nothing happend. anyone got any idea what the problem is?

also my specs are:

X370 taichi
ryzen 1700
2x 8gb gskill ddr4 F-3200C16D-16gtzr
sapphire rx 580 nitro
samsung 960 evo nvme 250 gb
samsung 850 128gb
corsair 750 psu
 




Posted By: datonyb
Date Posted: 27 Apr 2017 at 6:54am
" rel="nofollow -
have you tried removing and then replacing the nvme drive to make sure its seated correctly ?
other than this im thinking you may have either a defective drive or board
for testing purpose can you try the 960 in the second m2 slot


-------------
[url=https://valid.x86.fr/jpg250][/url]

3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold


Posted By: JohnV
Date Posted: 27 Apr 2017 at 11:53am
Originally posted by zjwenker zjwenker wrote:

" rel="nofollow - So today I tried to start up my computer and got the error code 0xc000000e.

So while browsing the internet i came across a post telling that the problem mostly is that the motherboards settings aren't correct to see the drive where the windows is installed on,

 ( http://www.tomshardware.co.uk/answers/id-2744141/error-code-0xc000000e.html )

 so I took a look in the bios and at the boot settings I cannot see my samsung nvme drive. 

So my question is,  where can I find the option to turn on Ahci mode?

Thanks in advance.


After reading the thread I'd like to know what Bios version you are on and if you had updated it >1.6 or 2.0.  Nvme drives 'disappearing' after reboot is an issue with some of the old bios versions. Note: I had the same issue on the x370PG with the 1.5 bios.


Posted By: parsec
Date Posted: 27 Apr 2017 at 12:47pm
" rel="nofollow -
Originally posted by zjwenker zjwenker wrote:

what do you mean in uefi mode? , I installed windows trough my ssd from my old computer, so I put the ssd from my old pc in my new build, booted the windows and in windows started the usb stick. then in the windows installer I formatted the ssd and choose the nvme ssd as the boot drive.


Why do you have two SSDs in the PC when you are trying to install Windows? That is the wrong way to do it, and causes problems.

Also, the way you described your installation process, if it that is true, does not make sense and is wrong. In Windows you started the USB stick? Where did you learn that? That cannot work.

As datonyb said, you must install Windows 10 in UEFI booting mode when using an NVMe SSD as the OS drive. You must select the entry in the UEFI/BIOS boot order for the USB Window installation media that looks like this: "UEFI: <flash drive name>".

Remove the 850 SSD from your old computer, which should never have been put in your new build at all. Two completely different systems since Ryzen is new, even if your old PC was an AMD build. I have no idea why you did that, all it did was cause problems for you.

Always install Windows with ONLY the new OS drive in the PC. You should be able to boot the Windows installer from the USB flash drive itself, I do that all the time. If you cannot boot/run the Windows installer from the USB flash drive, by selecting it in the boot order in the UEFI/BIOS, then it was not created correctly.


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: zjwenker
Date Posted: 27 Apr 2017 at 2:48pm
Check the reply after that, I did the install again trough UEFI mode fully clean. It still causes the same problem.


Posted By: zjwenker
Date Posted: 27 Apr 2017 at 2:51pm
Originally posted by JohnV JohnV wrote:

Originally posted by zjwenker zjwenker wrote:

" rel="nofollow - So today I tried to start up my computer and got the error code 0xc000000e.

So while browsing the internet i came across a post telling that the problem mostly is that the motherboards settings aren't correct to see the drive where the windows is installed on,

 ( http://www.tomshardware.co.uk/answers/id-2744141/error-code-0xc000000e.html )

 so I took a look in the bios and at the boot settings I cannot see my samsung nvme drive. 

So my question is,  where can I find the option to turn on Ahci mode?

Thanks in advance.


After reading the thread I'd like to know what Bios version you are on and if you had updated it >1.6 or 2.0.  Nvme drives 'disappearing' after reboot is an issue with some of the old bios versions. Note: I had the same issue on the x370PG with the 1.5 bios.

im using the latest bios 2.0



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net