Print Page | Close Window

Z87 Extreme 6 BIOS update not working

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=5214
Printed Date: 28 Mar 2023 at 10:20am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Z87 Extreme 6 BIOS update not working
Posted By: Fitfit
Subject: Z87 Extreme 6 BIOS update not working
Date Posted: 24 May 2017 at 7:01pm
" rel="nofollow - Hello,

I am an IT engineer, and I am used to work with computers.

I purchased this Z87 board 3.5 years ago (09/2013) and it ran fine with the original P1.40 BIOS (dual chips).
Recently I acquired a new I7 4790K, so I needed to update the BIOS to at least 2.20 for the CPU support.

I tried every method but nothing works. I tried with the 2.40 and 1.90 BIOSes and it did not work.

When I use the Windows Flash to flash the BIOS A, the computer restarts and stays at the ASRock black screen and does not post. I then have to switch to the other still working BIOS B, to copy it over A.

When I use the Internet Flash, I am not able to get a connection it seems. It stops at 50% and then displays an error message.

When I use the Instant Flash utility from the BIOS, it finds the BIOS on the key, but I cannot select it. I can click anywhere I want and it does not respond anymore. I can clearly see however on the bottom right that the clock is still running. I then have to power off/restart.

When I use the Instant Flash at post with F6, the same things happen. The rectangle window opens with the BIOS file in it but I cannot select it. I then have to power off/restart.

I tried the USB2 ports, USB3 ports, the onboard USB port, and my key is in FAT32 format.
I also tried to disable the sound with F4 in the BIOS but it does not change anything.

So here I am, sitting with a new processor that cannot be used. The motherboard works fine but I cannot update it.
Any Ideas?




Replies:
Posted By: Xaltar
Date Posted: 24 May 2017 at 7:17pm
" rel="nofollow - Very curious...

Try clearing CMOS via the battery removal method. Once clear try update again via the instant flash method. If you hit enter once the file is detected on the flash drive does anything happen?


-------------


Posted By: Fitfit
Date Posted: 25 May 2017 at 3:58am
" rel="nofollow - Thank you for the reply!

I cleared the CMOS with the battery removal and also by using the onboard jumper (pins 2-3), but it does not change anything, I still have the issues. Also it is weird because in the manual it is written that there is a clear CMOS button and not jumpers.

Is it possible that the "flashing utility" has always been broken on my motherboard?
A working motherboard with a bad flashing utility that passed quality control because there are no checks for that?

I made a few computers using the extreme series motherboards and I never encountered issues previously.


Posted By: Xaltar
Date Posted: 25 May 2017 at 4:13am
Is this what your board looks like?



I have seen a few cases where people have purchased boards that are not labeled correctly, some boards have a model sticker over the screen printed sticker. If that sticker is removed often the model screen printed on the board is higher than the model on the sticker. Many boards use the same PCB which is typically designed for the highest model based on it. So my ASRock N3150M board has N3700M under it's sticker. If I were to sell it with the sticker removed many people would be none the wiser.

The easy way to check is in CPUz under the motherboard tab. If that says the correct board model then it shouldn't be an issue.

I take it pressing enter when the instant flash detects the ROM file and the system stops responding to commands does nothing?

If the issue persists try contacting Tech Support directly, they may know what is happening. 

Quote  
International

http://event.asrock.com/tsd.asp


US.

Support Phone: 1-909-590-8308 (CA so PST Time Zone)
Support Email:  mailto:support@asrockamerica.com" rel="nofollow - support@asrockamerica.com


-------------


Posted By: Fitfit
Date Posted: 25 May 2017 at 5:14am
Yes, this is indeed my motherboard.



There is a sticker at the bottom under the USB 4 and 5 sockets.
A barcode and a number BC5FF4BE8028.

I contacted the support and sent them this thread also. They are on holiday tomorrow so they will not be able to help sadly.

EDIT:

Originally posted by Xaltar Xaltar wrote:



I take it pressing enter when the instant flash detects the ROM file and the system stops responding to commands does nothing?



Yes, I cannot even exit anymore. Nothing responds.

Here is the Instant Flash screen.



It stays like that forever. From the BIOS or directly with F6 it is the same.



Posted By: Xaltar
Date Posted: 25 May 2017 at 5:46am
" rel="nofollow - Sadly even my Z97 board works a little different where it comes to flashing so I don't have any point of reference as to what it should behave like. I feel like there may be something you are missing but I may be wrong. 

I imagine to get to this point you have extracted the BIOS update onto a fat32 formatted flash disk. I don't think it would find the file if you hadn't. Have you tried different flash drives? I have seen some cases where certain flash drives cause issues. Generally most 4 - 8gb flash drives will have a better chance of working given they are older and should be supported. 

Other than that I am afraid I am at a loss. I have not encountered this issue on any of my numerous ASRock boards and sadly don't have a Z87 board to test with. 


-------------


Posted By: Fitfit
Date Posted: 25 May 2017 at 6:13am
Thanks for your replies.

Yes, I tried several BIOSes versions from ASRock website, and each time it produced the same issue.

I indeed use a 8GB FAT32 USB stick which has already been used for a lot of IT work, including BIOS updates, so I'm pretty sure it is not the problem. Especially since even the Windows Flash procedure does not work too. I can try tomorrow with another stick I guess, just in case.

Thank you for taking the time to search for solutions, I really appreciate. Thumbs Up

I always try to solve things by myself but I must admit I have no idea of what I should do next.
I guess I'll just wait the answers of the support, and as last resort swap the BIOS chip with an already updated one. 


Posted By: parsec
Date Posted: 25 May 2017 at 10:04am
" rel="nofollow - Are you using a USB 2.0 port on the board's IO panel?

Do you have any over clock of the CPU or memory configured while you are performing the UEFI update? It is possible that a semi-stable OC could cause a failure of the UEFI update.

The Windows update method is most likely to fail statically for some reason. Therefore we don't recommend it. Did you run the Windows update program on the C:/OS drive?

If you happened to list the sequence of events in order, you said you ran the 2.40 update, was that the Windows update method? I ask because the 2.40 UEFI contains an update to the Instant Flash module, and if the update failed, it might have corrupted the Instant Flash tool.

Instead of diagnostics, try this: Restore the main A BIOS from the backup B BIOS. You must move the BIOS selection switch first with the power removed from the board, but don't forget to move the switch back to the A/main BIOS position, with the board removed from power. It sounds like you may have left the switch in the B position. The backup B BIOS should be blocked from an update, which is what you may be experiencing. Apparently you are able to run the Secure Backup UEFI feature fine. From your board's manual:

This motherboard has two BIOS chips, a primary BIOS (BIOS_ A) and a backup BIOS (BIOS_B), which enhances the safety and stability of your system. Normally, the system will work on the primary BIOS. However, if the primary BIOS is corrupted or damaged, just flip the BIOS Selection Switch to ?úB?? then the backup BIOS will take over on the next system boot. Ater that, use ?úSecure Backup UEFI??in the UEFI Setup Utility to duplicate a working copy of the BIOS iles to the primary BIOS to ensure normal system operation. For safety issues, users are not able to update the backup BIOS manually. Users may refer to the BIOS LEDs (BIOS_ A_LED or BIOS_B_LED) to identify which BIOS is currently activated

Once you get the A UEFI/BIOS restored from the B backup, and move the BIOS selection switch back to the A position (after the board POSTs into the B BIOS/UEFI and you shut off the PC), start the PC and POST into the UEFI again. Now try Instant Flash again, with the unzipped UEFI file in the USB flash drive in a USB 2.0 port on the board's IO panel.

Your board's CPU support list shows at least UEFI version 2.30 for compatibility with an i7-4790K. I don't see UEFI 2.20 listed anywhere in the CPU Support List. Might be a typo in one or the other, but I'd go with at least 2.30.

http://www.asrock.com/mb/Intel/Z87%20Extreme6/?cat=CPU


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: Fitfit
Date Posted: 25 May 2017 at 9:05pm
Hello, thank you for your answer.

Yes, I tried with every combinations of USB ports possible.

I do not have any overclock on memory or CPU. I also made sure to try with the BIOS parameters set to default after clear CMOS.

I first tried with Instant Flash (DOS) and only tried the Windows Flash after.

I tried with every steps BIOS possible, A and B. Nothing works. I can "Secure Backup" the BIOS A to B and B to A successfully however. I do not know exactly how this is handled by the motherboard, but I suppose part of the process is similar to Instant Flash.

Both BIOSes are currently in P1.40 (factory BIOS) and work.

My current CPU is a i5 4670, in case that helps. It was the one I installed when the computer was built.




Posted By: Fitfit
Date Posted: 26 May 2017 at 11:45pm
Hello everybody,

The ASRock support has decided to send me a replacement BIOS chip with the 2.72 beta version.
It should arrive next week in the mail.

I would like to thank you guys for helping me. Thumbs Up
I would also like to thank the people working at the ASRock support (especially ASRock NL support), for being nice and very professional.

I will post a reply in this thread once I get the new chip, to confirm everything works properly, and after that I will install the new CPU.

EDIT 29/05

Hello, the 2.72 BIOS chip has arrived this morning from ASRock NL.
I installed it and it worked fine, so I put the new i7 4790K CPU.
It has been running without any issue for one hour with the stock CPU BIOS settings, and vt-d enabled.

Many thanks to the ASRock support team and forum members Thumbs Up






Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net