Print Page | Close Window

H97M Pro4 and TPM

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=5746
Printed Date: 29 Nov 2021 at 10:55am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: H97M Pro4 and TPM
Posted By: fillalph
Subject: H97M Pro4 and TPM
Date Posted: 30 Jul 2017 at 2:33am
Hi,

I submitted a technical support request on July 8 with the ASRock website, but have not received a response.

I bought the ASRock HA-TPM2-S Nuvoton NPCT650/TCG Compliance TPM Module from aerocooler on ebay. I installed the TPM module in my ASRock H97M Pro4 motherboard with bios v 2.10 (the latest).

In the UEFI setup, under Advanced\Trusted Computing, I have enabled:
Auto Detect Security Device
Security Device Support

but the Current Status Information is Support Turned Off remains.



When I run tpm.msc, Windows says that the Compatible Trusted Platform Module (TPM) cannot be found on this computer. Verify that this computer has a 1.2 TPM or later and it is turned on in the BIOS.

Any thoughts or suggestions would be appreciated.

Thanks,
fillalph



Replies:
Posted By: parsec
Date Posted: 30 Jul 2017 at 10:23am
" rel="nofollow - What version of Windows are you using?

Do you have BitLocker enabled?

Did you try connecting the TPM module again?

When you submitted a support request with ASRock, did you receive an automated email response that your request was received?


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: fillalph
Date Posted: 30 Jul 2017 at 9:52pm
Thanks for the reply parsec.

I am running Windows 10 Pro. 

If I go to enable BitLocker, I need to do so with a TPM. 


When I disconnect the TPM module, in the UEFI, the Trusted Computing option in Advanced disappears. It is only an available menu with the module installed. It must mean that the motherboard is seeing something.


I did receive the automated email response from ASRock after I submitted my issue.


Posted By: fillalph
Date Posted: 04 Aug 2017 at 8:54am
" rel="nofollow - Any thoughts? Has anyone successfully used a TPM with the H97M motherboard?


Posted By: parsec
Date Posted: 04 Aug 2017 at 10:26am
Sorry, but I've never used this TPM module, so just doing the best I can.

I don't see a driver listed for download on the ASRock website page for the TPM modules. A different manufacture's TPM module had a driver disk included with the TPM device. Nothing like that came with your TPM module? Or a user manual?

Do you see an entry anywhere in Device Manager for the TPM module? It may be shown under Security devices. Check if the TPM device is working normally according to Device Manager, and if a driver is installed.

Do you have the Secure Boot option in the UEFI/BIOS enabled? Microsoft requires this for BitLocker to function properly. See this page:

https://docs.microsoft.com/en-us/windows/device-security/tpm/tpm-recommendations" rel="nofollow - https://docs.microsoft.com/en-us/windows/device-security/tpm/tpm-recommendations

The Secure Boot option is in the Security screen in the UEFI.

You may find that if you enable Secure Boot, that the PC then does not boot. Secure Boot depends upon the CSM option (Boot screen) being disabled. Enabling Secure Boot has disabled CSM automatically in the past in ASRock UEFIs. But when CSM is disabled, that requires a UEFI booting Windows installation, or it has in the past. That is the cause of the failure to boot, if it occurs.

Please check the Device Manager entry for the TPM device, and if it is fine, then try to enable Secure Boot in the UEFI. If the PC no longer boots, set Secure Boot to disabled.

Let us know what happens and we can try to move on from there.


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: ASRock_TSD
Date Posted: 11 Aug 2017 at 7:03pm

Dear fillalph,

 

Thank you for choosing ASRock.

 

Regarding your case, H97M Pro4 support TMP1.2, we have released special BIOS to support TPM2.0,

Please download the BIOS from below link and update BIOS by instant flash.

https://mega.nz/#!k1IChbrS!hPs4FcRD441qG0imGsG2r8oYccktyc75yS1XwN5f4D4" rel="nofollow - https://mega.nz/#!k1IChbrS!hPs4FcRD441qG0imGsG2r8oYccktyc75yS1XwN5f4D4

 

Thank you!

Yours truly,

ASRock TSD



Posted By: fillalph
Date Posted: 12 Aug 2017 at 12:52pm
Thank you parsec for your reply. Sorry for my delay. I was on a short holiday. 

Thank you ASRock TSD. The BIOS below worked and it recognized the TPM module right away. I really appreciate your follow up.

Thank you everyone!

-fillalph


Posted By: Bonedaddy
Date Posted: 03 Sep 2017 at 8:48pm
" rel="nofollow - I got the exact same problem with the FM2A68M-DG3+. The TPM Module is version 2, from Asrock itself (funny coincidence...!). Is this a known problem and is there a fix?


Posted By: fillalph
Date Posted: 06 Sep 2017 at 12:16pm
ASRock released a new BIOS that support the v2 TPM module. Submit a ticket and reference this post. Hopefully they do the same for you :)!


Posted By: Aquatuner
Date Posted: 23 Sep 2017 at 8:28pm
" rel="nofollow - Hi,
could you please do the same to the B85M Pro4?
I have the same problem and wasn't able to fix it till now.

Thanks a lot


Posted By: fi11g00d
Date Posted: 24 Aug 2018 at 2:32am
Hello. Please send me also the link to lates UEFI update for FM2a68m-hd+. I have the same problem. SUPPORT TURNED OFF message after enabling of TPM module in UEFI.
Thank you very much in advance.


Posted By: mchammer26
Date Posted: 10 Dec 2018 at 6:11pm
Hello,

is there also a bios update available for B85M-ITX and TPM2-S support ?

-------------
---


Posted By: rdn6427
Date Posted: 19 Nov 2019 at 11:19am
ASRock TSD, do you still have that special BIOS release available for this mobo? I am in the same scenario as fillalph and your previously provided link is down.


Posted By: ASRock_TSD
Date Posted: 19 Nov 2019 at 11:34am
Dear Rdn6427,

BIOS download link:H97M Pro4 P2.10C
https://mega.nz/#!c8pDQAgZ!YumiMsiCerLSp6NsoxLgheajOEPuF0UD9Ltmcj0LMrA

Thanks!
Yours truly,
ASRock TSD


Posted By: rdn6427
Date Posted: 19 Nov 2019 at 8:29pm
ASRock TSD,

Just realized I have the H97 (not M), will this still work?

Thanks.


Posted By: rdn6427
Date Posted: 22 Nov 2019 at 7:30am
Ended up submitting a ticket. H97 Pro4 (non-M) only supports up to TPM 1.2 and no longer has anymore BIOS releases.


Posted By: iRoman
Date Posted: 10 Mar 2021 at 4:35am
Hello.
I also need TPM 2 support for asrock z97 extreme6. I get the message SUPPORT TURNED OFF". Could you send me a link to update the BIOS for TPM 2£


Posted By: lostechoes
Date Posted: 25 Jun 2021 at 2:21am
This is really sad !

Please ASRock provide us with an updated BIOS for the H97 Pro4 mainboards.
This is the only thing that prevents us from being able to update to Windows 11 !

https://www.microsoft.com/en-us/windows/windows-11-specifications" rel="nofollow - https://www.microsoft.com/en-us/windows/windows-11-specifications

Trusted Platform Module (TPM) version 2.0
is required !


Originally posted by rdn6427 rdn6427 wrote:

Ended up submitting a ticket. H97 Pro4 (non-M) only supports up to TPM 1.2 and no longer has anymore BIOS releases.


Posted By: matus
Date Posted: 25 Jun 2021 at 8:00am

Hello ASRock

Could you please post an updated BIOS (2.6 or maybe 2.7) for H87M Pro4 with TPM2.0 support?

Also, would you please consider adding TPM2.0 support by default to future BIOS releases? Today it was announced that Windows 11 will require TPM2.0, so I think everyone who has one of your boards without TPM2.0 will need to buy a module and they will also need support in BIOS.

This is actually good news for you, your company can make some money selling TPM2.0 modules to existing customers.

Thank you!

Matus


Posted By: pufaxx
Date Posted: 27 Jun 2021 at 1:41am
Originally posted by ASRock_TSD ASRock_TSD wrote:

Dear Rdn6427,

BIOS download link:H97M Pro4 P2.10C
https://mega.nz/" rel="nofollow - https://mega.nz/ #!c8pDQAgZ!YumiMsiCerLSp6NsoxLgheajOEPuF0UD9Ltmcj0LMrA

Thanks!
Yours truly,
ASRock TSD


Thanks a lot for this update. Newest BIOS on the H97M Pro4 page is 2.30 - is TPM 2.0 support included in 2.30, too?

I couldn't try myself, yet - TPM module still on its way ...


Posted By: pufaxx
Date Posted: 27 Jun 2021 at 8:04pm
Another question: I can't find "Trusted Computing" in my "Advanced" Tab. Does this only appear when a module is installed? (H97M Pro4)


Posted By: magrathsmith
Date Posted: 28 Jun 2021 at 3:39am
Originally posted by ASRock_TSD ASRock_TSD wrote:

Dear Rdn6427,

BIOS download link:H97M Pro4 P2.10C
https://mega.nz/" rel="nofollow - https://mega.nz/ #!c8pDQAgZ!YumiMsiCerLSp6NsoxLgheajOEPuF0UD9Ltmcj0LMrA

Thanks!
Yours truly,
ASRock TSD


Does the 2.10C BIOS enable support for Intel's firmware-based TPM (PTT)? My understanding is that firmware TPM exists in Haswell (4th-gen) CPUs and later. If not, it would be great if a BIOS could be released that supports it. Otherwise it may be a long wait for hardware TMP modules to become available again.


Posted By: pufaxx
Date Posted: 28 Jun 2021 at 5:14am
@magrathsmith: Not sure, but I think firmware TPM is in mobile Haswell, only.

Sadly ... hardware TPM modules were sold out quickly. And next wave of scalpers is incoming. I saw prices quadruple in just two days ...

:(


Posted By: andreluizbarbieri
Date Posted: 28 Jun 2021 at 8:46pm
Originally posted by ASRock_TSD ASRock_TSD wrote:



Dear fillalph,



Thank you for choosing ASRock.



Regarding your case, H97M Pro4 support TMP1.2, we have released special BIOS to support TPM2.0,

Please download the BIOS from below link and update BIOS by instant flash.

https://mega.nz/" rel="nofollow - https://mega.nz/ #!k1IChbrS!hPs4FcRD441qG0imGsG2r8oYccktyc75yS1XwN5f4D4



Thank you!

Yours truly,

ASRock TSD



Please, I need a BIOS for the asrock z97m pro4 with trusted computing enabled.


Posted By: pedro gaspar
Date Posted: 02 Jul 2021 at 3:07am

i have the same problem wiht a z97x killer, any chance off having a bios update for it , please?
Thanks in advance


Posted By: morgindale
Date Posted: 12 Jul 2021 at 11:45pm
Hey Guys,

i only registered here just to tell you guys my story - i think some will find this helpful :-)

I also use a H97M Pro4 Mainboard with an old XEON Processor. So far i did everything what Microsoft set as minimum system requirements for Window 11, for example i moved to GPT and Secure Boot (both went fine and without data loss). The last thing to do was enable TPM 2.0 somehow, so i bought the Asrock TPM2-S V2.0 Module with Vendor Product Number 90-CXG5H1-00UBNZ.

First, i updated my BIOS to 2.30, the most current version for the board to get, but after plugging the module in, i had the same experience like in the first post, Trusted Computing was there, but the module wasn't recognized. So i tried the 2.10C Version which was posted here and that one worked fine :-)

Now, in "WhyNotWin11" App, everything is green, beside the CPU, which isn't officially supported, but why shouldn't it work, i have all the rest, including TPM 2.0.

If the MEGA-Link goes down again, PM me, then i'll send it to you / or i'll upload it again to MEGA or so.

Greetings!


Posted By: pufaxx
Date Posted: 16 Jul 2021 at 12:14pm
@morgindale: Thank you. Still waiting for my module to arrive, because two orders were cancelled by the sellers ... these modules are hard to find since Win11 was announced.

Anyway - good to know BIOS 2.30 does not work. But I'm not sure if I want to install an older version. Maybe there will be 2.30C?


Posted By: DanielHyman
Date Posted: 31 Oct 2021 at 7:12pm
Dear folks,

It's indeed a jungle out there, trying to find a 17-pin TPM 2 module, but take heart - they're starting to reappear. Being too thrifty to recycle a perfectly fine H97M Pro4 board with 16GB equally fine RAM on it, just to support Bill Gates's bachelor lifestyle, I'm also now the proud owner of a zippy i7-4790K and a Noctua cooler that might fix global warming if they could only make them big enough. (And to be fair, where would they plug it in?) Where oh where is a working link to that P2.10C BIOS flash file, which seems to have gone the way of all flash? Please continue to disregard my inadvertent cross-posts under Fatality, and thanks truly, in advance...


Posted By: DanielHyman
Date Posted: 02 Nov 2021 at 10:05pm
Dear Tech Support,

I'm pretty sure my mobo serial number is actually D06099869D64, not D05099859D54 as initially reported. If the 5's had open loops on the left, or the 6's were as round as the 9's, or I could read bar codes, it would be easier to tell. But it's one or the other.

In other news, while the link sent to fillalph does lead to a sadly vanished BIOS patch file, the link sent to Rdn6427 (as of this writing) still works, and so does the patched BIOS, and so do the TPM 2.0 module and Win 11. Finding the DOS pnputil to banish pesky .inf files and their outdated .sys drivers that were preventing memory protection was a whole nuther fun project. But that worked too, eventually.

Interestingly, while booting under BIOS version 2.30 used to take 5-6 seconds on a slow day, with a slower CPU, now it takes at least a minute, with a perky i7-4970K. The Win 11 boot (or ensuing environment) is no slower than for Win 10. Is this because the patched BIOS is less efficient, or the TPM module is overcoming trust issues, or...? There are no sparks, smoke, or error messages emanating from the renewed machine. It just takes much longer to boot. Any ideas why, and what if anything might be done to help?

And just out of curiosity, is there a 2.40 BIOS that talks to TPM 2 modules in anyone's future? That does its thing in 5 seconds?

Cheers,

Daniel



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net