Print Page | Close Window

cannot resolve error code b7 with extreme6/ac

Printed From:
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
Printed Date: 28 May 2024 at 7:07am
Software Version: Web Wiz Forums 12.04 -

Topic: cannot resolve error code b7 with extreme6/ac
Posted By: atoro
Subject: cannot resolve error code b7 with extreme6/ac
Date Posted: 07 Aug 2015 at 2:31pm


I built the PC as specified build on pcpartpicker reference W8NDvk" rel="nofollow -

Posted By: Xaltar
Date Posted: 07 Aug 2015 at 9:58pm
I would remove the CMOS battery as a final step and failing that working try and get my hands on some approved RAM for your board to rule it out as a possibility.

Clearing CMOS by removing the battery is not as quick as it used to be with the board caps holding more power than they used to so when you remove it it is best to leave the system unplugged for at least 4 hours with the battery out. Also be sure to press and hold the power button until all LEDs go off.

Good luck

Posted By: atoro
Date Posted: 08 Aug 2015 at 3:28am
Will try this. I took out the cmos battery and left work.  Will post back later.  Since I'm blind as no video is coming from the card (no onboard video), I can't get into the bios utility.  I can tell there's power on the video connector as the screen recognizes something is connected.  Bios doesn't respond to F2 on POST.

Posted By: atoro
Date Posted: 08 Aug 2015 at 9:22am
No Joy.  I don't have a Chassis speaker to hear the bios beeps, probably should get one.  It's clearly not completing the POST.  There is no power getting to the USB ports which indicates drivers not loaded, nor the video card (it's spinning but no video).

Posted By: atoro
Date Posted: 08 Aug 2015 at 2:01pm
Update...Working now but issue not resolved....

I started dismantling the PC getting ready to RMA the board, but decided to do one last try.  I remove every single cable except power to the mother board and removed the video card. Still b7, after removing the CPU cooler and again inspecting the CPU, I removed all RAM modules.  When I plugged in one ram module I still received the b7 error, then I tried two, this time I was able to get into the bios utility.  I shutdown and added two more total now 32GB, it also booted.  As soon as went over that number I received the same error.

I downloaded and re-flashed the Bios was 1.2 now is 1.7, rebooted and everything was till ok.  I added back the RAM and it failed exactly the same way error code b7.

So this mobo is supposed to support up to 128GB, I am using identical 8x8GB 244 DDR4 2133 RAM, spec'd for the mobo and the intel chip set speed.

Is there something in the BIOS that I need to do have it recognize RAM over 64GB boundary?  The B7 error is a fail on POST so it never gets further up the stack to initialize drivers.


Posted By: parsec
Date Posted: 08 Aug 2015 at 4:16pm
One correction, while the board is said to support 128GB of DRAM, your CPU only supports 64GB of memory:" rel="nofollow -

That still does not explain your problem above 32GB. Did you try increasing the memory voltage a bit with more than 32GB installed in the PC?

Did you follow the sequence of which memory slots to use when you use four DIMMs? There are similar rules when using more than four DIMMs, check the manual for details.

With that much memory in use you may need to increase the System Agent voltage.

-------------" rel="nofollow">

Posted By: atoro
Date Posted: 09 Aug 2015 at 2:23am
Update #2.
Thanks very much for your reply.  Yes I wanted to max the RAM at 64GB.
I started adding the additional RAM in sequence one at a time and rebooting into the BIOS  I discovered that anything I put into DDR4_D2 (the last memory slot) fails with b7 error code.  Now I'm up to 7 RAM sticks 56GB.
I will try your suggestion about tweaking the voltage on the DRAM.  The Default is set to 1.2V.  When I read the RAM configuration in the BIOS it reads as follows....
DRAM Voltage              +1.20V
+12V                          +12.249v
+1.05V                       +1.056V
+5.0V                         +5.136V
+3.3V                         +3.312V
I'm not sure how much to tweak it, but will do some research on it.  I want to confirm if I have a bad DDR4_D2 slot on the Mobo.
thanks again

Posted By: atoro
Date Posted: 09 Aug 2015 at 6:06am
Update 3
Here are the other options I tried, I think it the mobo is fautlt at DDR4_D2 slot, but can't rule out the memory controller of CPU as I have not way to test that.
1) Increase system agent offset to .6V (min .3 max .6)
2) Increase DRAM voltage to 1.21v from 1.2
3) Enabled JEDEC#1 (there are not XMP profiles)
4) 1+2
5) 1+2+3
All yield B7 and does not complete POST to event get into the bios.
Looks like I may have to RMA the board, I could live w/0 the 8GB of RAM but I don't know what else might be wrong with the board.

Posted By: parsec
Date Posted: 09 Aug 2015 at 12:34pm
It sounds like any of your eight DIMMs, when used in the DDR4_D2 slot (the first blue slot to the right of the CPU socket), will cause the POST failure and the display of the post codes you mentioned, correct?

You may have a bad DIMM slot or connection to that slot if it is unusable. If you know that none of the pins in the CPU socket are damaged, then it is most like the D2 DIMM slot.

It is not dangerous increasing the memory voltage up to 1.30V. Some people that OC memory go above that with DDR4 memory. It might not be worth it testing again with a higher memory voltage, just an FYI.

-------------" rel="nofollow">

Posted By: atoro
Date Posted: 10 Aug 2015 at 1:14am
Correct, placing any of the DIMMs into the DDR4_D2 slot (first from the right of the processor) will fail POST.
I checked the CPU several times, there's nothing bent, it fact there are really no pins to bend on the CPU, the mobo slot also looks fine.
1.3V did nothing.
Thanks for your help, I just finished packing up the mobo and RMA back to newegg.  I will post back once I receive the new Mobo.

Posted By: parsec
Date Posted: 10 Aug 2015 at 3:03am
I must agree that sending back your board was the right decision. Unhappy

The X99 platform, particularly the memory, is very complex and difficult to design and build. Quad channel memory with two slots per channel and eight slots total is a lot to get perfect, as it must be.

Please let us know how the new board works out for you. Thumbs Up

-------------" rel="nofollow">

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -