Print Page | Close Window

cannot start up from the network with Wake On Lan

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=6159
Printed Date: 25 Jun 2024 at 11:19pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: cannot start up from the network with Wake On Lan
Posted By: pan883
Subject: cannot start up from the network with Wake On Lan
Date Posted: 22 Sep 2017 at 3:38pm
I want to start with Wake On Lan from the power off state on Win10, but I can not do it. 

X370 Gaming K4 BIOS set the following setting to Enabled.
1. Advanced / ACPI Configuration / PCIE Decices Power On
2. Boot / Boot from Onboard LAN
I also tried making the latest version of Intel's network driver, but it does not change.

Thanks for help in advance.




Replies:
Posted By: ASRock_TSD
Date Posted: 22 Sep 2017 at 3:45pm
Dear pan883,

Greetings, this is ASRock TSD.


Please refer to the following steps for setting up Wake On Lan function:
1. BIOS setting:
Step1: Power on the system.
Step2: When POST screen is displaying then press the keyboard "Del" key to enter to the BIOS setting.
Step3: Switch to Advanced page, select ACPI Configuration, change PCIE Devices Power On to Enabled.
Step4: Press "F10" key to save the BIOS setting and restart the system.

2. Network adapter settings:
Step1: Start Windows and open Device Manager.
Step2: Expand "Network adapter", right-click "Intel (R) I 211 Gigabit Network Connection", and click "Properties".
Step3: Select the "Power Management" tab.
Step4: Please check "Enable computer to release standby state on this device".
Step5: Next, click the "Advanced Settings" tab, select the "Wake on Magic Packet" from the "Property" column, confirm that the "Value" is "Enabled" and click the "OK" button.

3. Check the power option:
Step1: Open the Power Option item in control panel.
Step2: Click the Choose what the power buttons do link.
Step3: Click Change settings that are currently unavailable.
Step4: Clear the Turn on fast startup(recommend) check box.
Step5: Click Save changes.
After above setting, WOL function should work properly.


Thanks!

All the best,
ASRock TSD



Posted By: Kagey_bee
Date Posted: 01 Nov 2017 at 3:49pm
These instructions dont work.

I've enabled everything I need to in bios. I've followed the instructions in Windows the best I can. However they don't seem to be 100% accurate to what I see in Windows 10.



This image shows an example of what in see. Not actually taken from my pc. But it's the same. No "Enable computer to release standby state on this device" option.

Power options regarding fast startup also don't exist.


Posted By: hellsolo
Date Posted: 25 Jun 2018 at 3:05am
Hello, I was looking for a solution to the problem with WOL and found, specially registered here to share with you. I have the same motherboard. In order for everything to work, download the driver for the network adapter from the official Intel site, and in his settings put a tick opposite - "WOMP from power off state". In BIOS, turn on the PCI power. Hope i am helped you.


Posted By: ggalt
Date Posted: 04 Feb 2019 at 3:00am
Any suggestions for Linux? Loading a device driver (windows based) or using the Windows settings dialog is not an option.


Posted By: AntoMac93
Date Posted: 03 Apr 2020 at 7:20am
same problem, different motherboard (Z390 xtreme4) with bios 4.30 ... I have xigmanas (FreeBSD) as a system.

I await solutions, I have also opened a private ticket.


Posted By: xboxbml
Date Posted: 23 Aug 2020 at 10:02am
Originally posted by ASRock_TSD ASRock_TSD wrote:

Dear pan883,

Greetings, this is ASRock TSD.


Please refer to the following steps for setting up Wake On Lan function:
1. BIOS setting:
Step1: Power on the system.
Step2: When POST screen is displaying then press the keyboard "Del" key to enter to the BIOS setting.
Step3: Switch to Advanced page, select ACPI Configuration, change PCIE Devices Power On to Enabled.
Step4: Press "F10" key to save the BIOS setting and restart the system.

2. Network adapter settings:
Step1: Start Windows and open Device Manager.
Step2: Expand "Network adapter", right-click "Intel (R) I 211 Gigabit Network Connection", and click "Properties".
Step3: Select the "Power Management" tab.
Step4: Please check "Enable computer to release standby state on this device".
Step5: Next, click the "Advanced Settings" tab, select the "Wake on Magic Packet" from the "Property" column, confirm that the "Value" is "Enabled" and click the "OK" button.

3. Check the power option:
Step1: Open the Power Option item in control panel.
Step2: Click the Choose what the power buttons do link.
Step3: Click Change settings that are currently unavailable.
Step4: Clear the Turn on fast startup(recommend) check box.
Step5: Click Save changes.
After above setting, WOL function should work properly.


Thanks!

All the best,
ASRock TSD



This totally worked! Thanks!


Posted By: Tippi
Date Posted: 06 Nov 2020 at 8:58pm
For Linux you can follow this instructions:
https://wiki.ubuntuusers.de/Wake_on_LAN/ (german)
https://help.ubuntu.com/community/WakeOnLan (english)
(should be the same on other distributions)

Only one important step:
Use ethtool to set wol for the network interface to state g.
This must be done at every start, so choose for example the systemd method.


Posted By: kwakker
Date Posted: 22 Jun 2021 at 10:57pm
I found out that for the DeskMini H470 a display MUST be connected and powered on (standby is fine) before the DeskMini will boot.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net