Print Page | Close Window

970 extreme 3 ultra fast boot

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=632
Printed Date: 22 May 2022 at 9:39pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: 970 extreme 3 ultra fast boot
Posted By: panabesk
Subject: 970 extreme 3 ultra fast boot
Date Posted: 13 Aug 2015 at 12:30am
My motherboard is Asrock 970 extreme3. i am using windows 10 pro 64bit in gpt format.

When i am trying to enable ultra fast boot mode from uefi, i get an error message 'The VBIOS of your discrete VGA card does not support UEFI GOP, so it can not support "Ultra Fast Boot" and "CSM Disable" '

my graphic card is Gigabyte gtx 650 ti 2Gb. on the latest vbios and supporting uefi gop. Gigabyte support said  "After confirmed, GV-N65TOC-2GI (rev. 1.0) F11 BIOS is already UEFI BIOS. About the issue you mentioned, we suggest you to contact your motherboard manufacturer and see if there is any setting in BIOS you need to adjust."

motherboard bios version is 1.80, which is the latest available from asrock website.




Replies:
Posted By: parsec
Date Posted: 14 Aug 2015 at 11:48am
I had to update the VBIOS of an EVGA GTX 650 video card before I could use Ultra Fast boot with Windows 8. That was a while ago now, and their VBIOS update worked fine, but that was with an ASRock Z77 (Intel) board.

Given the error message you are seeing, that seems to be a Gigabyte problem, but I'm not 100% certain.

There is a Beta BIOS for your board for use with AM3 processors and secure boot, which has the same requirements as using Ultra Fast:

http://www.asrock.com/mb/AMD/970%20Extreme3/?cat=Beta" rel="nofollow - http://www.asrock.com/mb/AMD/970%20Extreme3/?cat=Beta


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: panabesk
Date Posted: 15 Aug 2015 at 2:22am
Is there any changelog for the beta bios ? i didn't find any. my CPU is amd fx 6300


Posted By: WKjun
Date Posted: 18 Aug 2015 at 9:23pm
Well, that's a mess and hard to say. At first I would have suspected the VGA BIOS. If they say UEFI is fully supported, then maybe there is a MB BIOS bug. Actually, the older the hardware, the crapier UEFI implementation gets. Especially around the AM3+ platform. A newer FM2+ board with an AMD APU boots Win7 the hell of a lot faster, even without UEFI partition!
You can see how slow or fast it boots if you start the MSCONFIG tool and enable "OS boot information" at the Boot tab. On AM3+ the lines with loaded drivers can be seen for a while with MBR partition (Legacy), it's okay but quiet slow. But with a GPT partition (UEFI) it needs at least double the time. While on FM2+ I not even see one line with a MBR partition, so no use to bother with UEFI and Win7 there. The BIOS implementation is vital for proper UEFI support and all components need to be alright.
My AM3+ boards with Radeon 7950 & 280X do not allow me to use CSM with VGA UEFI enabled. It has to be Legacy.
If there is no update or the update does not add the required feature, you have to enable CSM and set just "Launch Video OpROM Policy" to "Legacy", but keep in mind, you do not have to abandon UEFI/GPT boot compeltely because of that.
 
Do you have other VGA cards to test how the MB reacts?
You could open an official support ticket at ASRock Support. But I still think the VGA card is the problem.


Posted By: panabesk
Date Posted: 18 Aug 2015 at 9:29pm
this is NOT graphic card problem. my gpu supports uefi gop and in another pc i can use ultra fast boot mode with my graphics card


Posted By: WKjun
Date Posted: 18 Aug 2015 at 9:55pm
Maybe I overread it, but then you clearly have a MB BIOS problem. I suggest an official ASRock support ticket.
 
PS: I've edited my last post meanwhile, because I went uncertain after all and I've remembered much more about my experiences while I typed.


Posted By: panabesk
Date Posted: 19 Aug 2015 at 8:54pm
i can't find anything like  'CSM' or  "Launch Video OpROM Policy" in uefi settings ...

is there any other naming of these ?


Posted By: parsec
Date Posted: 23 Aug 2015 at 3:13pm
Does your BIOS have a Secure Boot setting?

Secure Boot will (must) disable CSM in order to work. If you don't have a Secure Boot option in your BIOS, I doubt you would have a CSM option.

BTW, if you set Fast Boot to Ultra Fast the CSM option will be removed from the BIOS/UEFI options. At least that is how it works on some other ASRock boards. A potential bug in the UEFI may not be setting CSM to Disabled before it is removed.

So set Fast Boot to Disabled, and you might even need to save and exit the UEFI and go back in again to find the CSM option. If still no CSM and you have Secure Boot, disable Fast Boot, and then enable Secure Boot. Restart into the UEFI, and then set Fast Boot.

The CSM option is normally at the very bottom of the Boot or Advanced screen. It is easy to miss.


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: panabesk
Date Posted: 23 Aug 2015 at 6:20pm
there secure boot option in my uefi. i've tried changing it to enable , but nothing happens. If i disable fast boot , the csm option appears in acpi settings , but nothing changed . i still get the same error message


Posted By: parsec
Date Posted: 24 Aug 2015 at 2:23am
Well, if you are sure that your video card is GOP compatible (as you said you verified on another board), and you have CSM Disabled and Fast Boot set to Ultra Fast, that would seem to be potentially a UEFI/BIOS issue. Unless something related to Windows 10.

I've never seen any posts about your board and problems with Ultra Fast boot, so it is difficult to know exactly what is happening.

Question, what is the other board that your video card worked fine with Ultra Fast boot?

Also, what video interface are you using on your video card? HDMI, DVI, VGA?


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: panabesk
Date Posted: 24 Aug 2015 at 4:42am
my video card is gop compatible, i've seen it in gpu-z, and in some vbios flasher log. That's what gigabyte( graphics card vendor ) , and i've tested to another motherboard too.

on the pc that i've got the problem , i use vga. Could that be a problem ?


Posted By: parsec
Date Posted: 24 Aug 2015 at 8:09am
It's certainly worth trying another output on your video card as a test.

VGA is an analog signal, DVI-D, HDMI, and Display Port are all digital signals.

I install and boot Windows on all my PCs (five) in UEFI booting configuration, with CSM disabled. The video cards I happen to use, the oldest being an EVGA GTX 650 with a GOP compatible VBIOS update, all have GOP compatible VBIOS. Even the integrated Intel graphics are all GOP compatible, at least as far back as an i7-2600K.

I never use the VGA output/input with my PCs and monitors. I do NOT know if VGA signal is not GOP compatible since I don't even have a video source with a VGA output on the PCs that are up and running currently.

You may be able to teach us if VGA is not GOP compatible, if you try a digital video output and it works. Or at least with your video card. I'd really love to know that, please try a digital output! Big smile

-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: panabesk
Date Posted: 24 Aug 2015 at 2:19pm
That was the problem !!! I can't believe that ultra fast boot wouldn't work because of vga. I used HDMI and it worked.

I've heard that in ultra fast boot mode , you can't enter uefi settings. In my motherboard i can enter uefi settings if i hit del very quickly. This is not a problem, I think of that as an advantage!! But i didn't know it is possible



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net