Print Page | Close Window

DO YOU HAVE PROBLEMS WITH IOMMU?

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=7285
Printed Date: 15 Jun 2024 at 3:01pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: DO YOU HAVE PROBLEMS WITH IOMMU?
Posted By: lifeinmono
Subject: DO YOU HAVE PROBLEMS WITH IOMMU?
Date Posted: 14 Jan 2018 at 3:27am
[URL=][/URL]see below
x370 gaming x



DO YOU HAVE PROBLEM WITH IOMMU ADDRESSING?

THIS IS NOT THE FIRST TIME.

ASROCK 970M PRO3 DID ALREADY

IT DIDN'T SEPARATE IOMMU GROUP ALSO
WHICH GIGABYTE AND ASUS BOARDS DID RIGHT.

YOU CAN'T ADDRESS IOMMU PROPERLY,CAN YOU?
IS THIS REAL IN X370 BOARD?
DONT REPLY ABOUT BIOS SETTING
I TRIED EVERY AVAILABLE OPTION IN BIOS CFG.



Replies:
Posted By: zlobster
Date Posted: 14 Jan 2018 at 3:49am
I feel your frustration!!! Angry

It's the same mess with the X370 Taichi as well!

Too bad I rushed blindly and didn't wait for reviews and user feedback.

I bought my ASRock mobo because it was among the few advertised with IOMMU & SR-IOV. I initially intended to run a bare metal hypervisor and many VMs. After all, that's one of Ryzen's strong sides. Or as a second option I had in mind running Linux as host OS and using the advertised virtualization features for guest OS. Who was I kidding?

I don't know if they can fix their mess with a UEFI update, though?

After all the FUD we were fed, after all the cash we burned, now my PCIe slots lay barren. At least Ryzen is still strong in scientific and rendering workloads. Ironically, Spectre is hammering down performance heavily even on AMD systems. So much for fast SSD hooked directly to the CPU.

Life sometimes ain't fair...


-------------
1700X ZP-B1 (stock); X370 Taichi (UEFI 3.10); 16GB F4-3200C14-8GFX XMP; 256GB 960 EVO; RX 580 NITRO+ 8GB


Posted By: gjaltemba
Date Posted: 14 Jan 2018 at 9:23am
Big problems with GPU passthru. Tried everything AMD & ASRock tech support advised. Case has been escalated. My conclusion is Ryzen is not ready for prime time and I am going to pack it in. Three weeks of wasted time is too much to take.




Posted By: lifeinmono
Date Posted: 15 Jan 2018 at 6:47am
" rel="nofollow - https://www.reddit.com/r/Amd/comments/7p5ra3/asus_prime_x370pro_bios_3402_improves_iommu/ < ="chrome-extension://hhojmcideegachlhfgfdhailpfhgknjm/web_accessible_resources/index.js">

ASUS is doing fix this problem.

ASROCK? they finally didn't fix IOMMU Grouping problem of AM3+ boards until RYZEN. 
I sold all of my 970m pro3 boards (about 20EA) last month.
I bought RYZEN 7 1700 with ASROCK FATAL1TY GAMING X last week and now I'm selling again.

On IOMMU Grouping, i WON'T BUY ASROCK IN MY LIFE AGAIN.


Posted By: zlobster
Date Posted: 15 Jan 2018 at 8:26pm
" rel="nofollow - OMFG! So, it is possible to fix with UEFI update!

Moderators, could you please bring this to ASRock's attention? ASR_TSD guys may have already seen it but we all know they reply very rarely.


-------------
1700X ZP-B1 (stock); X370 Taichi (UEFI 3.10); 16GB F4-3200C14-8GFX XMP; 256GB 960 EVO; RX 580 NITRO+ 8GB


Posted By: gjaltemba
Date Posted: 16 Jan 2018 at 6:47am
Not sure that will help my case. My GPU is in a group with an audio device.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net