Print Page | Close Window

AB350 Gaming-ITX/ac - BIOS 4.40 bricked it

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=7337
Printed Date: 21 Jun 2024 at 9:13am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: AB350 Gaming-ITX/ac - BIOS 4.40 bricked it
Posted By: matthoz
Subject: AB350 Gaming-ITX/ac - BIOS 4.40 bricked it
Date Posted: 17 Jan 2018 at 8:19pm
" rel="nofollow - Hi there,

I've got a serious problem with my new AB350 Gaming ITX/ac mainboard.

Short:
Yesterday I've flashed BIOS 3.60 because the description said it is needed before updating to 4.40. Today I've flashed 4.40 and now the system hangs when showing the ASRock bootup screen. I cannot enter bios, instant flash or boot menu anymore. CMOS Reset did not help. This occurred immediately after the first boot when BIOS was flashed.

I am using the A12-9800E APU with ballistix sport 8GB Kit DDR4 2400.

Why did I flash the bios?

As I said I've just received the board yesterday and I installed Ubuntu Mate on it. No matter which linux distro, linux boot screens were not working, because the board seems not to be able to run my ASUS monitor on 75hz. It worked with any 60hz monitor. So I've tried the bios updated to fix this issue...

I can't even flash back. Should I send the mainboard back to amazon, or does anybody have any tipps on how to solve this problem?



Replies:
Posted By: matthoz
Date Posted: 17 Jan 2018 at 8:34pm
" rel="nofollow - Switching the screen by pressing TAB is working, but when I press DEL or F2 nothing happens. system freezes. same for F6 (Instant flash). When I press F11 for boot menu after I've pressed TAB there is an output "Enteroing boot menu" but nothing happens.

CTRL-ALT + DEL will work all time...

Any ideas?


Posted By: matthoz
Date Posted: 17 Jan 2018 at 8:36pm
I've now tried to run it with only one ram and without SSD. Still cannot enter bios. Did another cmos reset after removing the ram...


Posted By: kerberos_20
Date Posted: 17 Jan 2018 at 8:38pm
hard to say if u dont have dr debug led
try to unplug everything from your mobo, clear cmos, start mobo (empty mobo)
then plug cpu, ram gpu and keyboard...see what that will do
if u pass this step keep pluging devices until u find culprit


Posted By: matthoz
Date Posted: 17 Jan 2018 at 8:44pm
" rel="nofollow - Thanks for your reply. The only thing left, I can remove is the CPU. I've also started it without ram a few minutes ago. Anyone else has tried BIOS 4.40?

I really don't want to remove the cooler and cpu, but I will give it a try. If it doesn't work, I will have to send it back... No time for such crap.


Posted By: zlobster
Date Posted: 17 Jan 2018 at 8:46pm
" rel="nofollow - OP, did you update to P3.60 before updating to P4.40?


-------------
1700X ZP-B1 (stock); X370 Taichi (UEFI 3.10); 16GB F4-3200C14-8GFX XMP; 256GB 960 EVO; RX 580 NITRO+ 8GB


Posted By: matthoz
Date Posted: 17 Jan 2018 at 8:50pm
Yes I've updated to 3.60 before 4.40, as mentioned in my first post. I had both updates on same stick and when updating the first time, it only let me choose 3.60 anyways..


Posted By: matthoz
Date Posted: 17 Jan 2018 at 8:54pm
Ok, even removed the CPU and "started" (It won't start anything without cpu... cooler didn't move) - Plugged in everything again. Same result. ASRock screen shows. can be changed to oldschool boot screen by pressing TAB, but no other actions will work, except CTRL + ALT + DEL for reboot... :(


Posted By: zlobster
Date Posted: 17 Jan 2018 at 8:54pm
" rel="nofollow - May I suggest RMA then?


-------------
1700X ZP-B1 (stock); X370 Taichi (UEFI 3.10); 16GB F4-3200C14-8GFX XMP; 256GB 960 EVO; RX 580 NITRO+ 8GB


Posted By: matthoz
Date Posted: 17 Jan 2018 at 8:57pm
" rel="nofollow - I'll return it to amazon. They will send me a new board as soon as I request return. But the question is, what just happened here. Will it happen again when I flash 3.60 and 4.40 to the next board as well?


Posted By: kerberos_20
Date Posted: 17 Jan 2018 at 9:02pm
" rel="nofollow - if kepp pressing f6, does instant flash pops up?


Posted By: matthoz
Date Posted: 17 Jan 2018 at 10:42pm
" rel="nofollow - I did not try to hold the button, if you mean that by keep pressing. But it was the same reaction for all options. Usually the fancy high-res UIs would show up, but since 4.40 nothing happened anymore. I already disassembled everything and ordered another mainboard, as I already lost so much time. :/

Thanks for your help. Do you think I should reassemble it and try it again? I doubt it will work if I just keep pressing the button.


Posted By: Dibdidu
Date Posted: 17 Jan 2018 at 10:45pm
Hello, my 350B iTx is broken to!
Iam using same Apu like you.
I ordered an Chip with 3.40 from ebay.
I will receive it next week, I hope it will work :/
I allready opened an ticket.
3.60 was working.


Posted By: matthoz
Date Posted: 17 Jan 2018 at 11:35pm
" rel="nofollow - Hey Dibdidu,

did you also flash 4.40 on your board?


Posted By: Dibdidu
Date Posted: 17 Jan 2018 at 11:40pm
Hi!
yes, with 3.60 system was working fine but after flashing to 4.40 the pc stucks on the asrock logo/flash screen.
Keys dont working.
Even with mainboard Apu and 1 ram without any connected other devices the damn board isnt enterin the uefi...
Nice to see iam not alone with this^^
Even disconnecting the battery and or clear cmos didnt work :/


Posted By: matthoz
Date Posted: 18 Jan 2018 at 2:37am
I guess they really screwed up the firmware... at least when using A12 - 9800E APU :S
Already sent my mainboard back an hour ago.


Posted By: Dibdidu
Date Posted: 18 Jan 2018 at 3:16am
Yeah :/
I will report back when i get that bios chip.
It would be nice when you open a ticket for this.
Maybe we get an working bios^^


Posted By: wardog
Date Posted: 18 Jan 2018 at 9:17pm
" rel="nofollow - Was 3.60 performed via Windows Flash?


Posted By: Dibdidu
Date Posted: 18 Jan 2018 at 9:32pm
No, just with Instant flash.


Posted By: matthoz
Date Posted: 18 Jan 2018 at 11:27pm
Same here. Instant flash in UEFI BIOS with good USB Stick. (Checked for bad blocks)


Posted By: Dibdidu
Date Posted: 19 Jan 2018 at 5:15pm
Heyho, i got my new 3.40 bios chip.
It isn't working...
Screen is black, no led for keyboard and system is restarting all the time.

-> RMA.


Posted By: wussery
Date Posted: 24 Jan 2018 at 3:19am
" rel="nofollow - What was Bios 4.40 supposed to fix?


-------------
MOBO: ASRock AB350 Gaming-ITX/ac
CPU: Ryzen 5 1600
RAM: G.SKILL TridentZ Series 16GB DDR4 3200
GPU: EVGA GeForce GTX 1060 SC
PSU: EVGA 750 B3
Cooler: Cryorig C7
Boot Disk: SAMSUNG 850 PRO 256GB SSD


Posted By: Dibdidu
Date Posted: 24 Jan 2018 at 4:09am
Nothing, but it adds support for new cpu/apu.
I will get an Ryzen 5 2400G soon.
But it seems it stops supporting 9800E^^


Posted By: Matush
Date Posted: 23 Feb 2018 at 6:27am
The same issue here. Got hte AB350 ITX board, put in mine old 1600 to get the board SW up to 4.4 (Raven Ridge supported BIOS), after the middle FW 3.6 upgrade all good, after going from 3.6 to 4.4  system is booting to the first BIOS window (F2 DEL to BIOS F6 INSTAN FLASH) but only for about a second then restarts and over and over forever. Tried everything mentioned here, clear CMOS, etc, but the same .... Going to return the board back to asrock as this is nonsense.


Posted By: thiagohpb
Date Posted: 18 Mar 2018 at 1:26pm
" rel="nofollow - I just bought a AB350 ITX/ac MB, on my first day using it, I've tried to update BIOS because the CPU temperature was 127ÂșC constantly... even just after starting up.

The original BIOS version was 4.40, I've found on the MB website a version 4.50, saying: Before updating this BIOS, please update BIOS to P3.60 firstly.

So I downloaded the 3.60 and 4.50 versions, put on the pendrive just formated in FAT32, I did the first update to 3.60 version, It was completed 100%, ask to press enter to restart the system, after that my screen keeps off and the MB stays restarting... I have no screen.

I tried to reset the CMOS but no way... It keeps the same.

My CPU is a Ryzen 5 2400G.

Does anybody have an idea to fix that?


Posted By: stree
Date Posted: 18 Mar 2018 at 2:21pm
" rel="nofollow - Because now you need a pre raven ridge APU, such as the AMD boot kit.
Why? because you backdated your BIOS to 3.6 bridge BIOS when there was absolutely no need to.
You ( usually)work your way through the BIOS updates in a linear fashion, and there may be what is called a Bridge BIOS...on this MB version 3.6 is such a Bridge BIOS....once you have it it allows you to then download a Raven Ridge compatible BIOS.  Such as 4.40 (yes, it is very buggy)
You were already at that stage......and because you were at that stage you had no further need to use a Bridge BIOS from earlier in the series. You could and shold have gone straight to 4.50.
You are not the first to fall for this, perhaps it could be stressed more in the literature.
But you do not have Bricked MB, just one with a BIOS not ready for Raven Ridge, so beg borrow or steal an APU that will allow you to boot, install 4.50 and put it down to experience.


-------------
ASRock X370-ITX BIOS 4.50
R5 2600    Cryorig C7
EVGA GTX 950 75w
2x8GB Ballistix Sport LT 2933
960Evo M.2 256GB, Firecuda 1TB
Win 10 Pro 64 1803
G-Unique Archdaemon 300 Watt
Lian-li Q21B



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net