Print Page | Close Window

Bios Boot Order reseted

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=7368
Printed Date: 30 May 2024 at 5:37am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Bios Boot Order reseted
Posted By: alex_ro_bv
Subject: Bios Boot Order reseted
Date Posted: 19 Jan 2018 at 8:57pm
Hi guys, even though I am a technical guy, I got this problem which simply I see no way of resolving it by myself.

I have an ASRock X370 Killer motherboard and Samsung PICE 960 EVo drive. It worked fine since I bought it, September or so. I had installed Windows 10 and Ubuntu, it booted with grub.

I installed Manjaro linux removing completely the ubuntu. A new grub was installed replacing the old one, I believe on a new partition.

Windows was not detected anymore at all. I tried to install windows, I could not since I booted with EFI and the drive was MBR. 
I removed one partition. Now grub is all messed up, no way of booting back because the partition index is somehow not in sync.

I am trying to reinstall any OS but I cannot boot it from USB while the drive is connected. I have no other drive and nobody with a M.2 slot to format my drive.

The problem is that regardless what I choose to boot from, in bios, the order is reseted to my drive being the first option, all the time. If I disconect the drive, it boots into USB stick and windows installation starts. If I connect back the drive, USB doesn't boot anymore, boots from drive into faulty grub.



Replies:
Posted By: alex_ro_bv
Date Posted: 19 Jan 2018 at 9:02pm
By the way, I updated bios to latest, cleared CMOS, load defaults, disabled booting from hard drive, etc... Nothing worked. Save and override from bios doesn't save the boot order for me, it is always hard drive which is messed up now.


Posted By: kerberos_20
Date Posted: 19 Jan 2018 at 9:18pm
check if u have csm in leagacy mode
boot options should be able to see mbr and gpt partitions for either boot


Posted By: alex_ro_bv
Date Posted: 19 Jan 2018 at 9:23pm
Thanks for the quick answer, I already checked that and I have legacy mode enabled.  I tried with it disabled as well, still no luck.


Posted By: zlobster
Date Posted: 19 Jan 2018 at 10:04pm
I think you'd have more luck in dedicated penguin forums.

I was rarely able to fix bad GRUB configs myself, often getting all up from scratch. That's why to keep data storage on entirely different disks.


-------------
1700X ZP-B1 (stock); X370 Taichi (UEFI 3.10); 16GB F4-3200C14-8GFX XMP; 256GB 960 EVO; RX 580 NITRO+ 8GB


Posted By: alex_ro_bv
Date Posted: 19 Jan 2018 at 10:09pm
thanks for your reply zlobster.
The grub I believe is not fixable. 
The ASRock bug however is that I cannot boot from USB while my drive is plugged in. So I cannot format my drive thus.

Regardless of my options in bios boot order, it always picks the hard drive to boot, and never the USB.


Posted By: kerberos_20
Date Posted: 19 Jan 2018 at 10:45pm
" rel="nofollow - can you post here picture of what your boot order looks like?


Posted By: alex_ro_bv
Date Posted: 19 Jan 2018 at 11:49pm
" rel="nofollow - yes sure so:

Whenever I enter into bios, is the same: https://drive.google.com/file/d/0B6KclfMiVjEDWkdnN1VuT3gzYWlFRnV2dlFwQ1p0OWZ5eTZJ/view?usp=sharing

Then I change it to : https://drive.google.com/file/d/0B6KclfMiVjEDVndTY0NXQ3hLTHdLUGJyRC1tbHd4NERRU1Rv/view?usp=sharing

And I save the bios changes from here:

https://drive.google.com/file/d/0B6KclfMiVjEDcHFJU3pDYUNVMVk4cG01NEhKSzRuLTJ5OS13/view?usp=sharing

After I save and reboots, I enter again into bios only to find same as picture 1.



Posted By: alex_ro_bv
Date Posted: 21 Jan 2018 at 6:40pm
" rel="nofollow - So I managed to boot from the exit menu of the bios, directly into one of my usb sticks and then removed the faulty grub partition.
This doesn't change the fact that somehow boot order is reseted at every reboot. I even altered the boot order with refind-efi or efibootmgr, and upon restart I see it again reseted.

I believe it is a bios problem since even the bios order is completely reseted and not some kind of ssd uefi order (don't know how can ssd uefi order override bios order).

My question is : how come I haven't seen this on google/asrock forums? I tried with 3 different bios versions and this is not fixed.


Posted By: kerberos_20
Date Posted: 21 Jan 2018 at 7:12pm
i just tryied it with few drives/usb and what i set keeps there, no matter how many restarts.
maybe your cmos is at fault.
try to reset cmos, then reflash your bios either from efi shell or from dos



Posted By: Pelelademadera
Date Posted: 04 Aug 2018 at 10:27pm
I have the same problem in an asrock z68 extreme3, so its a really old bug... And not fixed yet



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net