Print Page | Close Window

AB350 ITX Pstates does not work properly(voltages)

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=7412
Printed Date: 04 Mar 2024 at 7:01am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: AB350 ITX Pstates does not work properly(voltages)
Posted By: nnyymm
Subject: AB350 ITX Pstates does not work properly(voltages)
Date Posted: 24 Jan 2018 at 3:59am
Hi guys, I'm currently using the AB350 itx P3.10

I've a issue with the voltages not dropping when my p state overclock falls to p1 and/or p2 state. I've ensured that amd cool n quiet is enabled and running ryzen balance plan with processor set to 0% minimum. I have also tried turning off some of the settings like performance core boost etc. The voltage is still stuck at the p0 state, according to hwinfo64. 

I'm curious if anyone has any issues with this? Any settings have I left out? Overall this is still a great motherboard!







Replies:
Posted By: nnyymm
Date Posted: 24 Jan 2018 at 1:08pm
" rel="nofollow - Update: 
I can confirm that pstates does not work properly for this board, despite only changing the frequency (r5 1600 3.7ghz) under AMD CBS/zen option (everything else stock under oc tweaker). The voltages should fallback to p1 or p2 voltages during idle, but it doesn't.

I tried manually input the SAME frequency(r5 1600 3.7ghz) under oc tweaker, it produces the SAME result as I when I changed the p0 setting under AMD CBS.

Any AB350 itx users experiencing the same as me?


Posted By: kerberos_20
Date Posted: 24 Jan 2018 at 4:33pm
hwinfo shows only 1 voltage type (die)
use aida 64, it shows all cpu voltages


Posted By: nnyymm
Date Posted: 24 Jan 2018 at 6:45pm
I think you misunderstood me. It doesn't actually matter which voltage monitoring software I use. P state simply is broken. If I leave everything default no overclocking whatsoever, the default "pstate" works. 

Once I fiddle with custom p0 state profile, it is broken. 


Posted By: kerberos_20
Date Posted: 24 Jan 2018 at 7:41pm
try to change power supply idle control in cbs


Posted By: arsn
Date Posted: 24 Jan 2018 at 11:18pm
I'm in the same boat. I've seen other people with the same issue and the only apparent fix is offset overclocking, which isn't a feature of my motherboard.. I don't know about yours. Here's a discussion about it:

https://www.reddit.com/r/Amd/comments/69t5ts/problems_with_pstate_overclocking/" rel="nofollow - https://www.reddit.com/r/Amd/comments/69t5ts/problems_with_pstate_overclocking/


Posted By: nnyymm
Date Posted: 25 Jan 2018 at 1:26am
I do have vcore offset, but it is not exactly a solution. vcore is still stuck at p0 state as you can see...


From what I'm seeing right now, there is absolutely NO reason to do p0 overclocking because it is broken. I can still oc using oc tweaker and have my clocks downclock via amd coolnquiet, there is little to no reason to fiddle with the AMD CBS settings... Ermm


Posted By: skwa
Date Posted: 29 Jan 2018 at 5:26am
nnyymm,

Using BIOS 3.0, I have had some success using custom P-states. I haven't tried BIOS 3.10.

I currently run:

P0: 3.6 GHz, Vcore 1.07
P1: 3.0 GHz,  Vcore 0.87
P2: 2.4 GHz, Vcore 0.78

cpufreq and lmsensors ( in linux ) shows the states behaving as they should.

To get the undervolt that I wanted I had to use voltage offset (in OC tweaker) and adjust the VID ( in custom P-states).  I can't remember the details now, but all three variables ( FID, VID, and the other one i can't remember the name of ) had to be adjusted for this to work. It all seemed a little buggy and random at the time.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net