Print Page | Close Window

Trying to install Windows 7 on N3000

Printed From: ASRock.com
Category: Technical Support
Forum Name: HTPC&Gaming Barebone&Others
Forum Description: Question about HTPC&Gaming Barebone&Others
URL: http://forum.asrock.com/forum_posts.asp?TID=778
Printed Date: 09 Dec 2023 at 11:59pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Trying to install Windows 7 on N3000
Posted By: FoulFoot
Subject: Trying to install Windows 7 on N3000
Date Posted: 06 Sep 2015 at 7:14am
Pulling my hair out trying to install Windows 7 on an Beebox N3000 barebones.

-- The USB3 Patcher (1.0.6) along with the newest USB3 drivers from this site is completely nonfunctional.  It appears to create a patched ISO, but the USB3 drivers are not installed.

-- I next downloaded the newest USB3 Braswell drivers from Intel directly, and installed them in boot.wim using these manual instructions: http://codeabitwiser.com/2014/03/how-to-install-windows-7-with-only-usb-3-0-ports/ .  That worked to a point; I was able to get past the language selection screen.  However, when Windows reboots to complete the installation process, the USB3 drivers are forgotten.  The comments in this article reflect other users who encountered the same issue.

-- Getting serious, I next tried to inject the USB3 drivers into the DriverStore folder.  This required:
1.  pulling the N3000 drive out and hooking it to my main PC
2.  staging the USB3 drivers into my main PC's DriverStore folder
3.  taking ownership of the N3000 drive (otherwise, you can't copy anything into the system32 folder)
4.  copying the three relevant driver folders from the FileRepository folder
5.  copying the driver cache files from the DriverStore folder
 This didn't work, either.  And I didn't really expect it to. 

I'm at wits end; I've tried everything I can think of.  Please, some help, before I end up returning all of this.

Scott



Replies:
Posted By: FoulFoot
Date Posted: 06 Sep 2015 at 12:53pm
OK, I managed to solve the USB3 driver problem.  Follow the guide here:

http://nucblog.net/2015/07/installing-windows-7-on-the-nuc5cpyh-or-nuc5ppyh/

A couple of things that didn't work as described:

1) When modifying the install.wim file, you may only have one index (I did).  To check, type this at command line:  dism /get-wiminfo /wimfile:"path to the wim file\wim file name" .  In which case, your "index" parameter will be 1, and not based on the Windows version as described in the article.

2) I was unable to get it to work until I created the "mount" directory on a separate hard drive from where I was running dism.

The problem that this article fixed was to A) integrate the drivers into install.wim, which is used when Windows is setting up, and B) installing the drivers on both indexes of boot.wim.  

As a final note, do not get clever and try and disable legacy USB support from within the BIOS (before installing Windows).  If you do, you will need to reset the BIOS.

Hope this helps someone.

Scott


Posted By: parsec
Date Posted: 06 Sep 2015 at 1:52pm
Thanks for posting these instructions, although I cannot verify that the ASRock Windows 7 USB Patcher ver:1.0.6 program does not work. I'll need to try that myself, since it seems strange that a tool that does not work would be made available for such an important task.

I will say given your description of what you tried and finally did to insert the drivers into the Windows 7 installation files, that it's hard for me to believe you could not complete the simple procedure of the USB Patcher program successfully. That implies the program may not work, as you said.

I should also say that we have not seen many complaints about the USB Patcher program not working. I recall one other thread on that topic, but that is all.

Sorry, but until I see this program fail when I use it, I cannot agree that it does not work. I do take your post seriously, and will try using it myself. Regardless of the result, I will post it here.


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: nostromo
Date Posted: 06 Sep 2015 at 10:46pm
the Windows 7 USB Patcher 1.0.6 was working properly (for me at least) only after i modified the first entry in the PatcherConfig.ini (same folder as Win7UsbPatcher.exe)

You have to change

[Setting]
DriverOptionHidden=1

to

DriverOptionHidden=0

before modifying the PatcherConfig.ini the USBPatcher couldnt find the USB3 Drivers under ...\UsbPatcher(v1.0.6)\Resource\Usb3Drv

after editing you get a new Option to select the USB3 driver folder (see path above).

maybe this helps?



Posted By: FoulFoot
Date Posted: 06 Sep 2015 at 11:00pm
I should point out that several posters I found online (various sites) stated that by just injecting the USB3 drivers into boot.wim (which is what I believe the USB3 Patcher is attempting to do) worked just fine for them.  They had no need, obviously, to also inject them into install.wim, which was the key to getting it to work for me.

I forgot to mention that the first thing I tried after the USB3 Patcher was to inject the USB3 drivers from the ASRock site into boot.wim.  This didn't work.  It was only the updated drivers from Intel that worked (https://downloadcenter.intel.com/download/22824/USB-3-0-Driver-Intel-USB-3-0-eXtensible-Host-Controller-Driver-for-Intel-8-9-100-Series-and-C220-C610-Chipset-Family), dated a few days ago.

Scott


Posted By: luke123
Date Posted: 10 Sep 2015 at 11:59am
Hi

Is it possible to disable USB 3.0 in UEFI/BIOS like the following procedure?

http://dellwindowsreinstallationguide.com/ensure-you-have-the-correct-sata-configuration-in-the-bios-setup-for-your-configuration/disable-usb-3-0-functionality/

If not, would it be possible to provide a future UEFI/BIOS update to include this feature? This would make life a lot easier for Windows 7 users.

Thanks!



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net