Print Page | Close Window

Fatal1ty x370 Gaming X Power issues

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=7867
Printed Date: 18 Jul 2024 at 10:12pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Fatal1ty x370 Gaming X Power issues
Posted By: zZTriHawk8Zz
Subject: Fatal1ty x370 Gaming X Power issues
Date Posted: 28 Feb 2018 at 12:50pm
So just today I got my parts in for my PC, after getting everything hooked up and put in I press the power button on the case and the LED panel on the motherboard is blinking Red. It blinks White for about 3 seconds then switches over??? Anyone have any leads as to why this is happening?Confused

-------------
Asrock Fatal1ty X370 Gaming x, AMD Ryzen 5 1500x, G.Skill FlareX F4-2400C15D-16GFX, No OS yet, Stock AMD Wrath Cooler,1x Crucial SSD, EVGA 600B 100-B1-0600-KR



Replies:
Posted By: MisterJ
Date Posted: 01 Mar 2018 at 2:35am
" rel="nofollow - zZTriHawk8Zz, is that a 600 Watt power supply?  Might be a bit weak, but maybe not.  Do you have both the 4-pin and 8-pin CPU power connectors in place?  Make sure the 4-pin is not rotated 90 degrees.  Make sure you are using CPU power cables, not PCIe.  What is your GPU?  The 1500X has no integrated GPU?  You may need to get a small speaker to hear beep codes (no Hex display, right?).  Enjoy, John.


-------------
Fat1 X399 Pro Gaming, TR 1950X, RAID0 3xSamsung SSD 960 EVO, G.SKILL FlareX F4-3200C14Q-32GFX, Win 10 x64 Pro, Enermx Platimax 850, Enermx Liqtech TR4 CPU Cooler, Radeon RX580, BIOS 2.00, 2xHDDs WD



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net