Print Page | Close Window

LSI 2308 SAS RAID

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=81
Printed Date: 14 Apr 2024 at 9:39pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: LSI 2308 SAS RAID
Posted By: Gattopardo
Subject: LSI 2308 SAS RAID
Date Posted: 04 May 2015 at 12:23pm
Dear All,

Could anyone tell how I can install LSI 2308 SAS (not SATA) RAID, please? 
I have a Z77 Extreme 11 board.  I installed Windows 8.1 on an SSD connected to SATA 0 or 1.  I have two SAS disks, and would like to connect it as RAID (either 0 or 1) to keep multimedia data.
I viewed manuals, but I was unable to find how I can make a SAS RAID system.  I can access to the disks as ordinary SAS disks.
Thank you in advance.

Best.
Gattopardo





Replies:
Posted By: parsec
Date Posted: 04 May 2015 at 1:07pm
So you have the SAS disks connected and running, and have the LSI SAS Driver ver:2.00.68.00 installed, correct?

You then need to download and install the LSI MegaRAID Utility ver:13.08.04.01, from your board's Windows 8.1 download page:

http://www.asrock.com/mb/Intel/Z77%20Extreme11/?cat=Download&os=Win8a64" rel="nofollow - http://www.asrock.com/mb/Intel/Z77%20Extreme11/?cat=Download&os=Win8a64

You then run the LSI MegaRAID utility in Windows, where you can create a RAID 0, 1, or 10 array.

I found this description of using the LSI MegaRAID utility to create a RAID 0 array. The ASRock mother board is different, but it uses the same LSI 2308 SAS controller and the same version of the LSI MegaRAID utility:

http://www.anandtech.com/show/6228/asrock-x79-extreme11-review-pcie-30-x16x16x16x16-and-lsi-8way-sassata/10" rel="nofollow - http://www.anandtech.com/show/6228/asrock-x79-extreme11-review-pcie-30-x16x16x16x16-and-lsi-8way-sassata/10

Please let us know how this works for you.


Posted By: Gattopardo
Date Posted: 04 May 2015 at 2:03pm
Dear parsec,

Thank you for your prompt reply.

the SAS driver is not the one but a new version by Microsoft.  I do not know if it matters.  Now I am getting the LSI driver from the ASRock site.  Also other *new* drivers.

I did download the LSI MegaRAID Utility and run it from Windows, but I was unable to find where the RAID configuration was.

Best,
Gattopardo



Posted By: Gattopardo
Date Posted: 04 May 2015 at 2:53pm
I finished downloading all *new* drivers.  However, the "device manager" says the newest driver has already been installed when I try to update the driver.

I have not yet found where the RAID menu is in the LSI MegaRAID storage manager.

Best,
Gattopardo




Posted By: Gattopardo
Date Posted: 04 May 2015 at 3:49pm
The window views (Advanced Software Option and Actions) shown in help menus and mine appears different, e.g., Create virtual drive in the help is blue whereas mine is black.

Gattopardo




Posted By: Gattopardo
Date Posted: 04 May 2015 at 4:21pm
I was completely wrong:  The RAID configuration is inside LSI BIOS.  I have to enable boot from LSI although I do not want boot from the SAS disk.  Then I find the RAID menu in LSI BIOS.

I recommend to write "Enable LSI BIOS (boot / RAID configuration)" in the menu.

Best,
Gattopardo




Posted By: parsec
Date Posted: 04 May 2015 at 10:15pm
Sorry about that, I was wondering if you needed to enable that option in the BIOS. As you said, that BIOS option is not clear about needing to enable it for the RAID option to be available.

Did you try to use the LSI MegaRAID utility in Windows with that option enabled?


Posted By: Gattopardo
Date Posted: 05 May 2015 at 6:31am
Hi parsec,

I tried to use the LSI MegaRAID utility as you recommended, but it did not work.  There was a create virtual volume menu, but it did not work; it was colored in black and I was unable to select it.  I was unable to reach the RAID option at all even after I set the LSI bootable enabled.

Anyway I appreciate your help, which lead me to the solution; it was the starting point that I tried several possible options.

Best,
Gattopardo



Posted By: parsec
Date Posted: 05 May 2015 at 11:23am
Sorry the MegaRAID utility didn't work for you, but I'm glad you were able to use the LSI BIOS utility.

I doubt that the MegaRAID utility has any more features than the LSI BIOS utility does.

I'm surprised the MegaRAID utility did not work for you, it worked for the reviewers of the X79 Extreme11 board in the link in my earlier post. But the boards have very different chipsets, so that may be related to your problems. The version of the MegaRAID utility is the same for both boards. Were none of the Help options that are listed on the screen of any help?

There are different versions of the LSI MegaRAID utility listed in the Windows 8 and Windows 7 download pages, in case you wanted to try one of those. I see that the review used version 12.01.03.00, which is for Windows 7, used in the review.

I don't see any BIOS/UEFI updates related to the LSI 2308 chipset.

Just trying to offer you some options in case you wanted to try the MegaRAID utility again.

So is your RAID array on the LSI 2308 SAS chipset working fine?


Posted By: Gattopardo
Date Posted: 05 May 2015 at 5:27pm
Yes, it is.  I tried RAID 1 first, and now switched to RAID 0.  I have not yet copied data, but it seems to be working.  The version of the MegaRAID utility I downloaded was 13.08.04.01.

I was unable to find any actual trial on SAS RAID; all articles I found were on SATA RAID.  Before I use Z77 Extreme11, I used ASUS P6T WS, which had a Marvell SAS RAID.  It was not difficult to find SAS RAID configuration in BIOS because I used the SAS RAID not only for data but also for Windows and boot.

Anyway thank you again.





Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net