Print Page | Close Window

Issues Installing Microsoft OS

Printed From: ASRock.com
Category: Media&User's Review
Forum Name: AMD Motherboards
Forum Description: ASRock AMD Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=8276
Printed Date: 25 Jan 2022 at 12:38pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Issues Installing Microsoft OS
Posted By: Alik21
Subject: Issues Installing Microsoft OS
Date Posted: 03 Apr 2018 at 10:55pm
" rel="nofollow - I've just bought a new computer with asrock x399 motheboard, AMD Ryzen Threadripper 1950X 3.4GHz and 64GB  DDR4 3000MHz (G. Skill). I've tried to install windows 10 from a USB, and from a DVD and I have the same result: It seems as if the computer is blocked when the Windows logo appear before beginning the installation.
I've installed Ubuntu successfully and everything is running normally.
Anyone knows how to install the win 10?

Thanks in advance


-------------
Loïc Guérin - CEO Alik21.com
lguerin@alik21.com



Replies:
Posted By: Xaltar
Date Posted: 03 Apr 2018 at 11:05pm
Make sure you make a fresh install medium using the very latest OS download from Microsoft. This alone eliminates a LOT of issues with AM4 and TR2 systems. 

In addition, always make sure to disconnect all drives from your system except the one you plan to install to. Multiple hard disks/SSDs can cause major installation issues with new hardware. I don't know if this is something Microsoft is working to improve/fix but that has been the case for many users here.


-------------


Posted By: Xaltar
Date Posted: 03 Apr 2018 at 11:07pm
It is especially important to disconnect optical drives. New motherboards and Windows 10 do not play nice with quite a few older optical drives for some reason, often causing major issues with stability and freezing.

-------------


Posted By: Alik21
Date Posted: 11 Apr 2018 at 1:09am
" rel="nofollow - I still have issues with the Win10 OS installation. I've read that it seems as if there is a compatibility bug between Asrock wifi module and win10 installation. Anyone knows if that is correct? If it is correct, how can I disable this module for the installation?



-------------
Loïc Guérin - CEO Alik21.com
lguerin@alik21.com


Posted By: scythefwd
Date Posted: 14 Apr 2018 at 1:53am
OK, use the media creation tool on another windows machine, make sure the version you are installing is 1709 or later (that is the latest for now btw).

If that doesnt work, go into the bios and disable iommu and get it installed, then do an update and let the system update to 1709, then you can turn on iommu if need be (or dont if you're not doing virtualization).

I just installed windows 10 my x399 taichi and 1950x about a week ago...

I never disabled the wifi.. matter of fact I have to enable it in the bios (not set to auto) after the fact...

She runs a bit choppy until all the drivers are up to date as well... Then nothing seems to be able to stop her.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net