Print Page | Close Window

Unable to boot from RAID 0 array on Z370 Taichi

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=8502
Printed Date: 23 Jul 2024 at 7:41pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Unable to boot from RAID 0 array on Z370 Taichi
Posted By: zzz
Subject: Unable to boot from RAID 0 array on Z370 Taichi
Date Posted: 25 Apr 2018 at 10:56am
" rel="nofollow - The subject line says it all.  I am coming from an ASRock Z87 OC Formula, where I had my two SSDs linked in RAID 0, and I had no problems at all booting from them.  I just put together a new system with the Z370 Taichi, using the same SSDs.  On the Taichi, under the "Advanced" tab in UEFI, the Intel RST selection shows my existing RAID configuration properly.  I also have the SATA type set to RAID in the Storage Configuration section.  However, the Boot section does not see my RAID array, and so I cannot boot off it.  If I try to type Control-I when the system is POSTing, nothing happens (and I am never prompted to type Control-I), and I'm just left with a message that no boot device can be found.  What do I need to do to make the UEFI boot section see my RAID disks?

If I boot off my CD, which is a Macrium Reflect restore disk, I can see the RAIDed disks just fine.

I am also using an IOCrest SATA expansion card, which is where my DVD drives are located.  It works fine.



Replies:
Posted By: badbri
Date Posted: 25 Apr 2018 at 11:06am
" rel="nofollow - Welcome to the forums.
You moved from a Z87 to a Z370 and expected it to boot from a RAID array, it is Rare you can change hardware that way and get a single HD to boot proper let alone a raid array. Under Advanced Storage is it set to raid or still at AHCI ? Have you tried rebuilding the array ?
Sorry that is all I can think of...you should email Tech support, they may have an answer.


-------------
https://www.passmark.com/baselines/V9/display.php?id=99573335296


Posted By: zzz
Date Posted: 25 Apr 2018 at 2:30pm
" rel="nofollow -
Originally posted by badbri badbri wrote:

Under Advanced Storage is it set to raid or still at AHCI ?

It is set to RAID.

Quote Have you tried rebuilding the array ?

No, as I would like to use it as is if possible.  I do have a backup I made right before taking my old system down, so I can rebuild the array if necessary.

What is strange is that on the UEFI Advanced tab, in the Intel RST section, this RAID array is listed and displayed in a way that seems to indicate that everything is OK.  The proper drives are indicated for the array, with the proper total array size, and the array status is Normal.  Looking at the drive details, the drives are marked bootable.  Yet on the Boot tab, the array is not even listed as an option.  Only my non-RAIDed HDDs and optical drives are listed.  The Intel RST section is in clear disagreement with the Boot tab.

And as I mentioned, if I boot the Macrium Reflect Windows PE CD, the included File Explorer has no trouble not only seeing the RAID array, but also looking through its whole file system as it would any ordinary disk.

I have sent a message about this to Technical Support, but so far I have not heard anything back.




Posted By: zzz
Date Posted: 25 Apr 2018 at 3:20pm
Problem solved.

I booted up my Macrium Reflect Restore CD.  It has an option to redeploy the installed OS to new hardware, which I selected.  It then got the new drivers off the ASRock CD and injected them into the current OS.  Rebooting still didn't work, though.  So I booted up the Macrium Reflect Restore CD again, and this time I chose the option to fix boot problems.  After playing around with the options a bit, I got my computer to boot up into Windows 10 just fine.

Interestingly, my RAID array still doesn't show up in the UEFI Boot tab.  Instead there's an entry for "Windows Boot Manager", which does the trick.

As you may gather, Macrium Reflect is a fantastic program.  I've been using it for a dozen years.

Now I just need to install all the current ASRock drivers, and I'll be all set.

@badbri - Thanks for the reply - it helped.


Posted By: badbri
Date Posted: 26 Apr 2018 at 9:46am
" rel="nofollow - Good to know you figured it out. Which version of Macrium Reflect Restore did you use ?


-------------
https://www.passmark.com/baselines/V9/display.php?id=99573335296


Posted By: zzz
Date Posted: 26 Apr 2018 at 9:55am
Originally posted by badbri badbri wrote:

" rel="nofollow - Good to know you figured it out. Which version of Macrium Reflect Restore did you use ?


I have the Home (paid) edition of the current Macrium Reflect version 7.  One key feature distinguishing the Home version from the free version is the Redeploy feature, which is present only in the paid versions.  At $70, it's not cheap, but I have found it to be worth every penny - it's saved my bacon more times than I can count.  And once a year on Black Friday, you can get it for half price on Macrium's Facebook page.


Posted By: wildcatdave
Date Posted: 10 Mar 2019 at 4:14am
Here is likely what you could have done to avoid so much work...

I was having the exact same issue migrating from a failing old genuine Intel motherboard to the B365M Pro4. I was taking a RAID-1 array over and the BIOS saw the array (once Intel RST was enabled) and showed it as normal & bootable. However it did not show up in the list of bootable devices no matter what I tried. Since the old motherboard was not UEFI, I had to switch this BIOS setting: Advanced/Storage Configuration/Use Legacy RST OROM - SET THIS TO ENABLE. This switches the Intel RAID Configuration so that it uses the old style where you can hit Ctrl+I right after POST and configure the RAID. It also removes the ability to manage the array in the BIOS at this point. But, you will now have the ability to set your transferred array as the boot device in the BIOS. This should work for anyone swapping from an older (non-UEFI) motherboard with a RAID array.

Luckily I saw this right before I got creative and started over.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net