Print Page | Close Window

Asrock Fatal1ty z170 Gaming itx/ac BSODs

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=851
Printed Date: 15 Apr 2024 at 11:24am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Asrock Fatal1ty z170 Gaming itx/ac BSODs
Posted By: Eltreum
Subject: Asrock Fatal1ty z170 Gaming itx/ac BSODs
Date Posted: 19 Sep 2015 at 1:30pm
I've built this system two days ago and I've been getting a lot of BSODs, all of them related to memory problems it seems (MEMORY_MANAGEMENT)

I've tried a lot of things and ran memtest86+ extensively but memtest returned no errors after the bios update (it gave some on one of the sticks, but the other stick tested without errors even without the bios update)

So now I face the options of: Motherboard being bad, RAM being bad OR incompatibility issues.

I never had RAM incompatibility issues before on any board, so this is a first for me, the memory I am using is this

http://www.newegg.com/Product/Product.aspx?Item=N82E16820233752&nm_mc=AFC-C8Junction&cm_mmc=AFC-C8Junction-PCPartPicker,%20LLC-_-na-_-na-_-na&cm_sp=&AID=10446076&PID=3938566&SID=

I know its not on the list, but to be honest I didn't see the list before I bought (i am not even sure it existed before the bios update). I can return the memory and buy a new one that is compatible, but the other thing that I find weird is that on the features list the motherboard supports 32GB of ram, yet on the memory supported list there is no single 16gb stick or combo supported, all of the sticks on the list are combos of 8gb x2 or 4gb x2.

Is there something missing? Is there going to be another bios update? I really would like to know (or find a solution that doesn't require me sending stuff back) because for now this motherboard feels pretty limited to me which this holw compatibility list.



Replies:
Posted By: Xaltar
Date Posted: 19 Sep 2015 at 1:58pm
Could we get a full list of specs for your PC as well as what OS you are using? It would also be helpful know the exact BSODs you are getting, you should be able to find the info in "Event Viewer" under windows logs -> system. 

In the interim you can also try clearing CMOS and seeing if that corrects the issue.  


Posted By: Eltreum
Date Posted: 19 Sep 2015 at 2:03pm
This is my computer http://pcpartpicker.com/p/qfDJ3C

I am lacking the hitachi 2.5" driver as it hasn't arrived.

I am using Windows 10 Pro, and pretty much all the BSODs have been MEMORY_MANAGEMENT errors with ntoskrnl.exe being the one that crashed.

Sometimes it crashes at the start, sometimes I can use the computer for 15min before it crashes, its somewhat random which again coupled with the error code and the program at fault (windows kernel) does suggest that it's the memory, even if memtest86+ doesn't show errors.

I already did a cmos reset, didn't work since nothing changed. I did try underclocking the ram (and then went back to default because it didn't help).

Voltages look good, both in the bios and when I can enter Windows i check on HWmonitor, but the bios is more reliable.

Only windows crashes, I pretty much never get a problem while in the BIOS, although it did lock up twice while switching from easy mode to advanced, but I have done that many many times so I assume that it's a bug in the bios mode due to easy mode being new. 


Posted By: Xaltar
Date Posted: 19 Sep 2015 at 4:49pm
Thanks for the extra info. I would start by removing your GTX 980 and seeing if you still get BSODs on the iGPU. Ntoskrnl errors can be caused by a wide variety of things, the GPU or GPU drivers among them. Remove everything from the system that isn't essential to boot into the OS and check for stability. If you are stable then add things back one at a time checking for stability again between each addition.


Posted By: Eltreum
Date Posted: 20 Sep 2015 at 12:49am
That didn't help, I am still getting BSODs after removing the GPU.


Posted By: Xaltar
Date Posted: 20 Sep 2015 at 1:02am
Ntoskrnel problems can be tricky to diagnose. When you ran Memtest I assume you ran it in safe mode or with a bootable flash drive from command prompt? If the RAM is passing memtest for at least 4 hours then the odds are that the problem is driver/OS related or it has something to do with another piece of hardware that accesses the system's caching facilities. Did you try a minimal boot? Only 1 stick of RAM, CPU and boot drive connected to the system. If at all possible you could try a fresh installation in this minimal configuration, that should ensure that all drivers and system files are fresh and uncorrupted.  If after this you still get BSODs then it is time to dig further into your hardware for the fault. At this point you should remove the CPU and check for bent or damaged pins on the CPU socket and check all connections to the board.

Good luck


Posted By: Eltreum
Date Posted: 20 Sep 2015 at 1:11am
You don't think that the lack of my ram being on the compatibility list is an issue at all? I was getting problems with it before the bios update.


Posted By: Xaltar
Date Posted: 20 Sep 2015 at 1:57am
Generally speaking RAM is compatible if it passes memtest but I suppose it isn't out of the question, there could be some kind of intermittent load failure or dual channel hiccup happening. If getting replacement RAM isn't a problem for you then by all means give it a try. If it does not help then you can try the steps I outlined previously. 

You can also check what voltage your RAM is designed to run at and see if it is getting the right voltage from your board. Some high performance RAM needs a little more voltage than other RAM modules. If your board is setting the voltage too low or high it could cause problems, high with overheating and low with instability.


Posted By: Eltreum
Date Posted: 20 Sep 2015 at 7:30am
I'll leave memtest86+ running for a few hours and report back later, prob going to do minimal boot.

I didn't do it because its such a pain to get everything out in the sg08. 


Posted By: Eltreum
Date Posted: 20 Sep 2015 at 11:01am
I ran memtest86+ for 4 hours and got no errors.

I am going to try messing with windows on another HD to see if there's a faulty driver installed. I did run some tests to check if the ssd was damaged but they all turned out to be fine so i don't think its the ssd's fault but it could be a faulty driver. My top candidates:

LAN
Bluetooth+Wireless
External Sound card (soundblaster creative omni)
Keyboard/gamepad/mouse (integraded or their own drivers)

Could be something else too, the NAS turned fine but maybe it's a problem since it has 4TB.


Posted By: Eltreum
Date Posted: 20 Sep 2015 at 11:32am
Ran prime95 on blend test for 30min, no BSODs, errors or overheating of any kind.

Gotta leave the pc runnning dota2 on spectator mode (i have it installed on the ssd) that way I don't need to install anything and can also test the GPU for a bit (it if doesnt crash).

Gonna try endless 3dmark, furmark or something else to stresstest it later if I dont BSOD.


Posted By: Xaltar
Date Posted: 20 Sep 2015 at 11:44am
Good luck Thumbs Up


Posted By: Eltreum
Date Posted: 20 Sep 2015 at 11:48am
I just finished watching a 40min match of dota 2 and no BSOD.

At this point I am actually starting to believe that it might truly be a driver. 

I didnt update windows either, I think the driver could have come with a windows update so having a completely fresh windows does help.

I now need to take some time and figure out which driver is causing problems, i suspect it's one that came with the motherboard so if I figure out which one I do hope Asrock either takes it out or reports it to manufacturer.


Posted By: Eltreum
Date Posted: 20 Sep 2015 at 2:31pm
I just played 2h of MGS5 and I didnt get BSODs on the fresh win10 install. Going to try to pinpoint the faulty driver now



Posted By: Xaltar
Date Posted: 20 Sep 2015 at 2:38pm
That is good to hear. As I said before, more often than not ntoskrnl problems are driver related, especially when you can rule out RAM.

Good luck and enjoy your new build Thumbs Up


Posted By: Eltreum
Date Posted: 21 Sep 2015 at 9:16am
After quite a lot of troubleshooting I actually found out that the problem seems to be related to the Legacy USB support for keyboards/mice.

I have all the drivers installed and I am not getting bluescreens, but if I disable the Legacy support they seem to return. I should do further testing with the RAM speeds in combination with the legacy option since it might be a BIOS bug, but right now as it is I am no longer getting BSODs and it's been quite a long time since the pc has been on.

I have no idea how to report this, but it should definitely be looked upon.


Posted By: Xaltar
Date Posted: 21 Sep 2015 at 3:22pm
You can send a support ticket to ASRock http://asrock.com/support/index.us.asp?cat=RMA" rel="nofollow - here . Just outline the problem as simply as possible and I am sure they will get back to you.

I am glad your system is at least running well now with legacy mode enabled.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net