Print Page | Close Window

Graphics issues with Ryzen APU on AB350 ITX

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=8770
Printed Date: 16 Apr 2024 at 3:57am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Graphics issues with Ryzen APU on AB350 ITX
Posted By: a13antichrist
Subject: Graphics issues with Ryzen APU on AB350 ITX
Date Posted: 24 May 2018 at 9:07pm
" rel="nofollow - Hi, my equipment is listed in my signature. 

I've recently built a new machine but am having constant crashes anytime I try to do anything graphics-related. I get a number of different blue-screen reports: 

DRIVER_IRQL_NOT_LESS_OR_EQUAL
SYSTEM_SERVICE_EXCEPTION
KERNEL_something-something-I-forget-exactly
and there was another one which I forget also.

And depending on the case I have had two registers called out also: 

atikmdag.sys
dxgmm2.sys

So it -seems- to point to something Radeon-driver-related. However I haven't seen similar issues from AMD discussions so I wondered if it couldn't be board-related..

I am currently using BIOS L4.51D; I had the 4.60 on before but changed it as I thought I was getting system shutdowns randomly; appears it's just the OS shutting off the CPU fan when sleeping - seemed odd to me but ok. 

I was using a 17.x Radeon driver, upgraded to the 18.5.1 but that hasn't helped. 

Playing Youtube in 4K it will sometimes last a fair while, an hour or so or sometimes only a few minutes; then the Chrome tab may crash or the video might start going blocky or distorted, sometimes one then the other. 

Playing HEVC 265 video in VLC crashes the computer within a few minutes. Playing on MPC-HC lasted a bit longer, got up to 30mins or so. 

I have tried with multiple memory sticks (have some 2666 modules here, also tried running the 3200 at only 2133) and multiple PSUs. No tangible differences in behaviour there. 

I don't have anything happening on this machine at present; it's to be the HTPC so only a couple of media players installed, and nothing heavy yet. 

Another thing - if I enable the HDR + WCG setting in windows, the CPU grinds to almost a halt when playing a 4K HDR video in Youtube. Weird.. 

Any ideas? Bad CPU/board/driver install?



-------------
R9 5950x | Asrock B550M Steel Legend | 64Gb 3600Mhz | RTX 3090 FE
R3 2200G | ASRock Fatal1ty AB350 ITX

Dell Latitude 7470 | QNAP @58Tb | Mikrotik routers/wifi



Replies:
Posted By: robmcc83
Date Posted: 25 May 2018 at 1:05am
I'm getting similar issues on a a320 board.
I can't even get my cpu to 100% with high performance windows power plan.
Anything graphics related seems to make the system unstable, mine doesn't even load Kodi it just freezes system. My lightroom lags dramatically with GPU acceleration enabled. Even putting in my old 1gb gtx 650 solves all these problem so it's clearly GPU related. I've tried all different drivers but all is the same so either the mobo bios are causing this or the cpu itself. Either way I'm having a horrible experience with the new Ryzen Apus and everyone seems to ignore every message I post on forums.


Posted By: TooQik
Date Posted: 25 May 2018 at 11:20am
" rel="nofollow -
Do you have any monitoring tool installed that can check the CPU and GPU temperatures?

If so, I'd suggest taking a look to see how high the temperatures are going and see if it correlates to the crashes you're having.


Posted By: a13antichrist
Date Posted: 25 May 2018 at 7:03pm
Yes, the Ryzen Master software and temps never go above 40°C. 

An update though, I removed all AMD drivers using the AMD CLeanup Utility. Then I re-installed the graphics drivers -only- and manually using Device Manager and not the packaged installation. Full disclosure, the driver package I used for this was the amd-chipset-drivers18.10.0418 which I guess I downloaded in April; Radeon driver version actually lists the same as when installed by the new Adrenaline package release yesterday (24.20.11016.4) so that's a bit odd. Well it also says 'Driver date 16/05/2018 so I'm not entirely sure how that happened :p But in any case the install was done manually through DM and not the package installer. 

With this driver installed and none of the other AMD bits (other than Ryzen Master) I am able to watch any 4K Youtube or HEVC media without suffering the crashes - EXCEPT when I turn the HDR + WCG mode on. With that mode enabled I see the same crashes as before.

-------------
R9 5950x | Asrock B550M Steel Legend | 64Gb 3600Mhz | RTX 3090 FE
R3 2200G | ASRock Fatal1ty AB350 ITX

Dell Latitude 7470 | QNAP @58Tb | Mikrotik routers/wifi


Posted By: TooQik
Date Posted: 25 May 2018 at 7:24pm
Well that definitely points to the issue being driver related then.

Sorry I can't offer anything else at this point to try. Maybe reach out to AMD support if you haven't already done so.


Posted By: a13antichrist
Date Posted: 26 May 2018 at 4:11am
Yeah I created the same topic at AMD Support, will see how it goes I guess. 

In the meantime I've been experimenting a little.. After first running AMD Clean util, I rebooted into Safe Mode. Before running the Guru3D DD cleaining process, when switching user from dummy to admin, system crashed & rebooted again. OK :/ This in Safe Mode still. 
Ok finally after booting back to safe mode, ran the Guru cleaner and back to Windows. 

installed "Chipset Drivers" labelled 18.10.0418. I noted that the items being installed were: 
AMD PSP
AMD SMBus
AMD GPIO
AMD Graphics Driver 24.x 
Balanced Power Plan 2.0.0

A note on these 'chipset drivers' - when installing, it says I'm using 18.10, but that there's a newer recommended version 18.5 (the adrenaline). Bit curious.. 

Allowed to install. Rebooted - Windows failed to start after two atttempts. So I stripped off all the drivers again. This time I skipped the "chipset drivers" and went straight to the new Adrenaline 18.5.1. After install I checked that all the previous components were there & with the same or better driver versions - they were. So either the driver removal didn't touch them or the Adrenaline 18.5 installs them also. 

Eventually I got the system back into its correct state. I like to tempt fate, so I went straight for HDR mode. Both Chrome & Edge crash on any YouTube video within seconds. Chrome just kills the tab; Edge actually crashes the system (although to be fair, I only tried Edge once). 
Playing videos while in HDR has given me a number of different BSODs (all in the last 2 hours): 
- SYSTEM_SERVICE_EXCEPTION
- SYSTEM_EXCEPTION_NOT_HANDLED: atikmdag.sys
- DRIVER_IRQL_etc_etc: dxgmm2.sys
- VIDEO_TDR_FAILURE: atikmdag.sys


Now I will try raw 4K with no HDR before diving into any memory & voltage changes.


-------------
R9 5950x | Asrock B550M Steel Legend | 64Gb 3600Mhz | RTX 3090 FE
R3 2200G | ASRock Fatal1ty AB350 ITX

Dell Latitude 7470 | QNAP @58Tb | Mikrotik routers/wifi


Posted By: a13antichrist
Date Posted: 05 Jun 2018 at 12:28am
" rel="nofollow - Sooooo

I guess I'm pretty dumb then. 

After all the drama.. I try a 2666 RAM kit I have sitting here.. running at only 2133 but at least at that point (and no XMP profile) I have no issues. So I checked it up and it turns out my 3200 I've been using actually ---isn't-- on the supported list (CMK8GX4M2B3200C16R ). This isn't to say that it's the RAM's fault, per se, but.. sure doesn't help the case. I could have sworn it was listed as compatible before. :/ 

Anyone know how to check if there really is a bad match between this board (Fatal1ty AB350 ITX) and/or CPU and this Mem? Or is it just "unknown" so far? 


-------------
R9 5950x | Asrock B550M Steel Legend | 64Gb 3600Mhz | RTX 3090 FE
R3 2200G | ASRock Fatal1ty AB350 ITX

Dell Latitude 7470 | QNAP @58Tb | Mikrotik routers/wifi


Posted By: datonyb
Date Posted: 05 Jun 2018 at 1:27am
try using the ryzen dram calculator to suggest the sub timings to manually set for the 3200 ram

allthough im guessing your'll need to run them at 2666 or 2933 though


-------------
[url=https://valid.x86.fr/jpg250][/url]

3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net