Print Page | Close Window

z97 Extreme9 Raid issue

Printed From:
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
Printed Date: 19 Jul 2024 at 3:38am
Software Version: Web Wiz Forums 12.04 -

Topic: z97 Extreme9 Raid issue
Posted By: thymeless
Subject: z97 Extreme9 Raid issue
Date Posted: 05 May 2015 at 10:33pm
I'm dual booting Win 8.1 and Linux Mint 17.1, each off their own ssd.

I want to run a RAID 1 array visible to both OS using two 2.7 TB Western Digital Black drives. According to the RAID guide table for disks of that size and win 8.1 at least, I need to use the UEFI Setup Utility. However, the utility shown in the manual: Intel (R) Rapid Storage Technology is not present in my UEFI on the Advanced Tab or anywhere else.  I've tried setting it up with the Intel utility via CTL I at boot. That doesn't work in Win or Linux. 

Yesterday I flashed the 1.6 Bios hoping for a fix. But that didn't offer any help either. 

Thanks for any help on this.

Posted By: parsec
Date Posted: 05 May 2015 at 11:54pm
There is nothing wrong with your board or the UEFI version you are using. You just need to configure one thing in the UEFI correctly.

I assume you installed Win 8.1 with the SATA mode for the Intel Z97 chipset set to RAID, is that right?

If so, do this: In the UEFI/BIOS, go to the Boot screen. At the bottom of that screen is the CSM option. Click on that, which will bring you to the CSM configuration screen.

You'll see that CSM is set to Enabled, which it is by default. I don't know if your Win 8.1 installation was done in UEFI booting mode, and if your video source supports GOP, so keep CSM Enabled.

Below CSM, find the Launch Storage OpROM Policy which will be set to Legacy Only, the default.

Click on the Launch Storage OpROM Policy option, and select UEFI Only.

You're done at that point, save and exit the UEFI. You can then go directly back into the UEFI and you should see the Intel Rapid Storage Technology option displayed at the bottom of the Advanced screen.

If you did not install Win 8.1 in RAID mode, or this does not work for you, let us know and we'll take it from there.

Posted By: thymeless
Date Posted: 06 May 2015 at 3:10am
From the supplied documentation I'd have never figured that out. Let me play with that and see how it goes.   Thanks.

Posted By: thymeless
Date Posted: 06 May 2015 at 11:04pm
Still no joy within Win8.1 or Linux. The Windows installer saw the raid drive, at least it showed a 2.7 TB drive, but once I install Windows, the raid isn't visible.  Neither the linux installer nor the OS itself could see the raid. 

I've deleted the raid, rebooted, rebuilt the raid, rebooted, run win install. 

I'm really at a loss with this as it shouldn't be this opaque.  Nothing is installed on the system yet and re-installs of the OS aren't a problem so complete change-arounds aren't an issue if that's what it takes.

Complete system details:

ASRock z97 Extreme9 motherboard
Intel i7 4790K I'm currently using the onboard video of the CPU but will get dedicated gpu later
Corsair h100i water cooler
16 gb G-Skill 1600 RAM

Samsung evo 840 Pro (Windows ssd)  Sata3_0 connection as recommended for fastest boot
Crucial  MX 100 (linux ssd) Sata3_A4 port--turned off m.2 in UEFI
WD Black 3 TB 2x for the RAID Sata3_2 and Sata3_5 ports for RAID support
LG blu Ray wh16ns40 Sata3_3 port

Thermaltake t81 Urban case
XFX xtr 750 watt PSU

Kinesis contour keyboard
Rat 7 mouse

Posted By: thymeless
Date Posted: 06 May 2015 at 11:16pm
And yes, I'm in RAID mode, not AHCI.

Posted By: parsec
Date Posted: 07 May 2015 at 1:33am
Yes, the method of getting the UEFI IRST setup utility available is not intuitive. It takes some explanation about why it's like that, but that will not help you with your problem, so I'll skip that for now.

You didn't mention this, but after you create a new RAID array of any type, you must initialize and format it in Windows Disk Management. A new RAID array will not be recognized by Windows until it is initialized and formatted, that is not done during the array creation process.

When you start Disk Management (DM), it should prompt you to initialize the RAID array. You'll then see it listed among your drives in the DM list. Then you'll need to format it by right clicking on its entry, and following the prompts. After that, you will see the RAID 1 array in the list of drives in Windows Explorer.

Sorry, I did not know your level of experience with RAID arrays, and it looks like I could have saved you a lot of work and grief. Embarrassed

Did you install the IRST driver and software package, the Intel Rapid Storage Technology driver and utility ver: software in your board's download page, or on the driver disk? You don't need it to format the RAID 1 array in DM, but the IRST Windows application in this package allows you to check the status and administer your RAID arrays. There will be an entry in Control Panel for the IRST Windows application.

This software will also monitor your RAID arrays for any problems and display warnings if there are any problems. You can delete and create RAID arrays with this application. At the top of its display is a Help button. Clicking that will open a new window with all the IRST documentation that describes the capabilities and requirements for using IRST.

One more thing. When creating the array, did you choose a RAID 1 array, or did you select Flexible Data Protection (recovery)? There is a size limitation for the Recovery option, and your drives may be exceeding that limit. There is no limit for a non-OS RAID 1 array.

Let us know if all this solves your issues.

Posted By: thymeless
Date Posted: 07 May 2015 at 1:59am
I went with raid 1. Yes I forgot about Windows Disk Management. I've been used to seeing unformatted drives show up in explorer and format them from there. I was on XP for so long....

This is my first time with Raid.   I susepct if I format it in Windows, Linux will see it and save me the hassle. 

I do see the array in Disk management. 

You've been very helpful, thank you. 

Posted By: parsec
Date Posted: 07 May 2015 at 12:38pm
Great, glad it was something simple in the end.

First time with IRST RAID? You're doing fine.

I'm not a Linux person (have worked with Unix), so I can't tell you how your RAID 1 will work with Linux. The Windows IRST software won't work with Linux. I'm not sure the IRST RAID format (it uses the standard developed by SNIA) is compatible with Linux.

If you feel like it, I'd like to know how well it works with Linux.

FYI: Any UEFI/BIOS update or CMOS clear will reset the Intel SATA mode to AHCI. You must reset the Intel SATA mode to RAID in those circumstances before you boot an OS.

Booting (or failing to boot) in AHCI mode won't ruin the RAID array, just set the SATA mode to RAID and reboot.

The drives are not tied or related to any particular Intel SATA port, you can move the SATA data cables to different Intel SATA ports and the array will work fine. You could move the drives in a RAID array (non-OS volumes) from one Intel system to another, as long as the Intel chipsets are compatible.

When you decide to remove/delete a RAID array, save the data first, and then delete the RAID array with the IRST utility. Either the UEFI utility or the Windows IRST utility.

If you just remove the drives physically, the RAID metadata (data about the RAID configuration) will still exist on the drive, and Windows DM sometimes sees that as a system partition and won't let you format the drive. You can use the Windows Cmd prompt program Diskpart to run a clean command on the drive (in Admin mode) to remove that data. You'll have a drive that needs initialization and formatting after that. The IRST utility deletion of a RAID array is the simplest way to start from scratch with the drives.

Posted By: thymeless
Date Posted: 07 May 2015 at 10:47pm
Linux is  aware of the raid. It's not mounting it. I'm still pursuing a few avenues for why that is. It looks like it has to do with the NTFS signature but I've not found a fix for that yet. 

Posted By: thymeless
Date Posted: 07 May 2015 at 10:51pm
Maximum PC has been running a series of articles on RAID for Windows and Linux. It's not particularly deep, mostly discussing the sotfware RAID features of the OS for each RAID type.  And giving a FAKERAID solution as well for dual booters like me.  You might find the series interesting.

Posted By: thymeless
Date Posted: 07 May 2015 at 11:26pm
The NTFS signature problem seems to be caused by the Windows Hibernation file. 

The Windows ssd couldn't be mounted either because of that file.  I'm not a huge fan of hibernation for my PC uses anyway so deleting the file and turning off hibernation aren't an issue for me.  Just turning off hibernation in the Control panel doesn't remove the file.  gives instructions on how to do this.  In linux, I no longer have the NTFS signature error, but my mounting of the raid is still problematic.  still more to do. 

Posted By: thymeless
Date Posted: 08 May 2015 at 12:09am  casts some doubt on my being successful.   A dedicated hardware RAID card might be a better solution at this time. 

Posted By: thymeless
Date Posted: 08 May 2015 at 2:24am
Linux is aware of the raid, dmraid sees it. It is listed in /dev/mapper/.  But mounting  can't see it to mount it. There are various sites discussing similar issues and I've tried a number of suggestions without success. Some distributions are alleged to be better at this than others but those tend to be the more minimalist distros like Knoppix which  is not well suited to my purposes. 

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -