Print Page | Close Window

FM2A88X Pro3+ / soundblaster problems

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=96
Printed Date: 17 Apr 2024 at 11:15pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: FM2A88X Pro3+ / soundblaster problems
Posted By: clahman
Subject: FM2A88X Pro3+ / soundblaster problems
Date Posted: 05 May 2015 at 10:20pm
hi.  because with my asus crosshair v mobo having sound issues i bought the above mobo and amd A10 7850K  cpu. i also bought a new pci-e souncard audigy soundblasterFX. it was crashing then and it is crashing now. i don't know if the mobo is at fault or the sb is at fault. i also bought a new r7 graphics card and i can't get it to work either.  in the bios the creative souncard is not shown and i am sure there are other items missing in the bios. the sound issue is the most important at present. is there a bios update for this board ? thankyou,,,gordon // running windows 8 at present / have tried windows 8.1 and also windows 7


-------------
asrock fm2a88x pro3+ amd fx7850 cpu creative audigy soundblasterfx (pci express) ocz obsidian 1600 mhz running at 1066 corsair 850 modular psu



Replies:
Posted By: clahman
Date Posted: 06 May 2015 at 2:34pm
bios is updated to P1.40

my ocz obsidian memory is not on the vendors list; though that hasn't stopped me before. i haven't got any money to upgrade anyway. i have 2 x 2 gb in dual channel, slots 2 and 4.


-------------
asrock fm2a88x pro3+ amd fx7850 cpu creative audigy soundblasterfx (pci express) ocz obsidian 1600 mhz running at 1066 corsair 850 modular psu


Posted By: Xaltar
Date Posted: 17 May 2015 at 1:41pm
Try install the sound card in a different PCI/E slot, on some boards there are conflicts between the PCIE 16 slot and one of the PCIE x1 slots, this is usually documented in the user manual for the board. Given that neither the sound card or the R7 GPU are working I would suspect this may be the case. The sound card likely would not show up in the bios unless your bios displays populated expansion slots so that is nothing to be concerned about. 

The memory should not be an issue, so long as it is posting and you are able to boot into windows you should be fine. Generally manufacturers test a spectrum of popular and budget RAM with their products, this list is not often updated after the release of the product.


Posted By: clahman
Date Posted: 17 May 2015 at 2:14pm
for just now i have it working okay. i'm scared to install other programs like nero 10 / bitlord etcetra as they might be part of the problem. i also did a clean install of windows 8 and upgraded to 8.1 before installing any drivers. and a big mistake i think was installing from the mobo disc amd drivers and then on board graphics drivers. i just installed the amd drivers and not a lot else. worst 3 years of my life. creative drivers taken from the website too.  thanks


-------------
asrock fm2a88x pro3+ amd fx7850 cpu creative audigy soundblasterfx (pci express) ocz obsidian 1600 mhz running at 1066 corsair 850 modular psu



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net