Print Page | Close Window

Fatal1ty B450 Gaming K4 - Fan Control doesn't work

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=9701
Printed Date: 24 Jun 2021 at 11:41pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Fatal1ty B450 Gaming K4 - Fan Control doesn't work
Posted By: Dr@gonXP
Subject: Fatal1ty B450 Gaming K4 - Fan Control doesn't work
Date Posted: 16 Sep 2018 at 5:17pm
[URL=][/URL]
Hi All,

Experienced an issue with my Fatal1ty B450 Gaming K4, the Fan Control is not working.
I have adjusted the temperatures & fan speeds in the UEFI, saved and restarted.
Used a stress test tool (aida64) and temperatures increased, but the fan speeds stayed constant.

Any ideas?

Thanks
Dr@gonXP




Replies:
Posted By: datonyb
Date Posted: 16 Sep 2018 at 8:06pm
set fan monitoring to tctl


-------------
[url=https://valid.x86.fr/jpg250][/url]

3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold


Posted By: Dr@gonXP
Date Posted: 16 Sep 2018 at 8:29pm
It works, thank you!


Posted By: fnordie
Date Posted: 17 Sep 2018 at 3:04pm
this should be made sticky! ;)


Posted By: kschendel
Date Posted: 18 Sep 2018 at 12:14am
It definitely should be a sticky.  It would be even better if Asrock would either fix the bogus "CPU temp" sensor output, or get rid of it, because it doesn't work -- across numerous boards, not just the B450's.  My X470 Taichi has the same issue, and someone here with a Threadripper board sees it too.




Posted By: Xaltar
Date Posted: 18 Sep 2018 at 12:16am
Stuck Wink

This is indeed a common issue and this post should help others find the rather quick and easy workaround/fix. 


-------------


Posted By: fnordie
Date Posted: 19 Sep 2018 at 2:31pm
" rel="nofollow - lets do a list af affected boards!

x470 fatality gaming k4
x470 taichi
b450 (all?)


Posted By: Kami
Date Posted: 20 Sep 2018 at 11:26am
X399 Taichi
X399M Taichi




Posted By: kschendel
Date Posted: 20 Sep 2018 at 11:47pm
Maybe we should put out a call for someone with an AM4 board where the CPU thermistor temperature actually works!



Posted By: adrian0380
Date Posted: 11 Oct 2018 at 5:11pm
My X470 TAICHI have a same issue. CPU fan - only tctl monitoring. CPU sensor doesn't work.


Posted By: fnordie
Date Posted: 28 Oct 2018 at 5:50pm
" rel="nofollow - how much longer will it take to fix this simple bug? also why are XFR and PBO fine tuning like MSI has? 

i hope people stop buying asrock stuff


Posted By: shindig
Date Posted: 12 Nov 2018 at 4:37am
" rel="nofollow - Hey all. 

Quick question about fan control on the B450 boards. When using Tctl as temperature source, won't the fans annoyingly keep ramping up/down rapidly to match spiking Tctl temperatures? Or is there a hysteresis or step up/down feature I'm just not seeing?


Posted By: fnordie
Date Posted: 12 Nov 2018 at 5:16pm
" rel="nofollow -
i think all asrock boards (am4) use the same fan controlls?

the ramp up is very noticeable, i try to set the temps beyond the spikes. but this is still a compromise. and still very noticeable with the quick fan speed changes.

i think we only can set the curve. no step up hor hysteresis.

i wonder whats up with the sensor in the socket. why is it disabled on almost all asrock boards? is it broken fom the factory? or maybe its just the core temp +  smoothing?


Posted By: Miepel
Date Posted: 13 Nov 2018 at 2:54am
My B450M Pro4 has many issues:
- Fan control does not work with MB sensor.
- Fan speed changes rapidly when using CPU sensor.
- Strange counts of the other sensors (VRM Mos and VSoC very high and do not vary).
- Coil whine of the MB while heavy load on GPU.
I read the sensors with HW-Info (latest version).
This is very annoying. I replaced a Gigabyte GA-AB350, because I wanted to control 5 fans separately. The Gigabyte MB had only 3 fan headers, but the fan control worked very nice.
Again, very annoying.
Miepel
PS: Please excuse my poor English.



Posted By: fnordie
Date Posted: 15 Nov 2018 at 4:14pm
i see a new 1.5 bios update for the Fatal1ty B450 Gaming K4. someone try this allready? thanks


Posted By: fnordie
Date Posted: 15 Nov 2018 at 4:45pm
sorry i meant the x470 fatality k4 got the update.

i just installed it. but the fan problem is still there


Posted By: Miepel
Date Posted: 16 Nov 2018 at 12:48am
I have updated to 1.50 and then to 1.60 (latest ASRock Bios). Still no difference.


Posted By: basedmeezus
Date Posted: 17 Nov 2018 at 7:15am
so for my pc case fans, should i set that to tctl as well? or keep it at mobo or cpu?

Thanks


Posted By: Miepel
Date Posted: 18 Nov 2018 at 6:11pm
TCtl seems to be the only value, that works with the fan control. So I've connected all fans to TCtl.
There is an option for temperature hysteresis (AMD CBS/MBIO/Fan control). It is possible to set it between 0 and 255, but I didn't recognized any difference.


Posted By: globsch
Date Posted: 18 Nov 2018 at 10:13pm
ASRock B450 Pro 4 here.

Same Problem. Very glad to find this thread. Was ready to send the Board to RMA and buy anoter one.

I think there are many users who regognize these problems and than try another Manufacturer.

Asrock should fix it. Monitor CPU has no effect. tried Bios 1.4 and 1.5.
till today I cant confirm that monitor MB works.


Posted By: Miepel
Date Posted: 19 Nov 2018 at 12:24am
ASRock does not seem to work on a solution. The problem about the fan control is reported in the Internet since 2015.
I can't believe that ASRock Boards have so many bells and whistles for the money, but fail in such substantial things.


Posted By: fnordie
Date Posted: 19 Nov 2018 at 5:34pm
really? this problem is 3 years old already?

why no reviews mention this? IMHO fan controller is one of the more important features. but i guess LEDs are better selling.


Posted By: fnordie
Date Posted: 19 Nov 2018 at 5:36pm
yesterday i try to set my case fans to motherboard temp. its also not working correctly. so tcl is the only value that works for the fan controll. can confirm


Posted By: Miepel
Date Posted: 20 Nov 2018 at 2:49am
I must correct myself. ASRock fan control issues are reported since 2015, but this special failure is reported since 2017.


Posted By: Miepel
Date Posted: 30 Nov 2018 at 2:47am
Finally, I found out a solution for me.
At first I have tried Speenfan (freeware), but this tool didn't read out the sensors correctly. The latest version of Speedfan was released in 2016.
Then I have Tried Argus Monitor - a very nice tool. You can adjust fan curves, hysteresis (in Celsius) an a mean value for the sensor readout (e.g. 10 seconds). That was exactly what I was looking for.
You can test the software 30 days. After that, you can buy a license for one or three years (not very expensive).
This is not an advertising, but I want do replay my solution.
URL: https://www.argotronic.com/en/index.php
I am so happy in the end.
Kind regards and best wishes from Germany!
Miepel


Posted By: xavierif
Date Posted: 02 Dec 2018 at 8:12pm
Having a x470 fatal1ty gaming k4 mobo for 3 days, first the leds problem and then the fan problem. Have to say that with bios 1.0 fan problem was not there. All these problems have "easy" solution, I mean all this is about drivers and controllers, but sh*t... they do not seem to work on a solution.


Posted By: fnordie
Date Posted: 03 Dec 2018 at 2:06am
thanks miepel, will have to try it too.

@xavierif good to know it was working on 1.0. i also think this things would be quick and easy to fix.. and asrock is not doing anything about it


Posted By: Henn91
Date Posted: 14 Dec 2018 at 5:13pm
Okki i have same board, i opened aida64 to see if temperature is ok, VRM was allmost 100C, i freaked out and did try to put more fan-s but it wont drop, i touched all heatsinks, they normal. In games or when i put gpu under load, VRM tems starts to drop to about 70C.

So i ask is VRM temp not right in aida64?


Posted By: fnordie
Date Posted: 14 Dec 2018 at 8:16pm
hi henn91! i would try Hwinfo64 for ryzen temperatures. its often recomendet for ryzen systems and gets updated all the time.
or the official ryzen master OC tool, but i think ryzen master only gives you cpu temp.

i did some more resarch on wich cpu temp sensor is best for fan control. i now think tctl is the way to go because it speeds fans up faster than a sensor in the socket would.
only problem is the temp spikes every ryzen seems to have, because the fan spikes to for a second.. other users think hysteresis setting would be the solution.


Posted By: Miepel
Date Posted: 30 Dec 2018 at 12:30am
Just installed Bios 2.00. Fan control did not change.


Posted By: asp
Date Posted: 23 Jan 2019 at 10:30am
I'm confused about this discussion. I just finished building my new system with this fantastic motherboard, I did randomly discovered the automatic fan tuning feature in the BIOS and tried it, and now when in Windows I see that my 2 case fans and CPU fan are adjusting their speed based on how hard I am working the computer. What am I missing here?


Posted By: paologab
Date Posted: 23 Jan 2019 at 5:52pm
it's simple: only Tctl sensor works

-------------
AMD Ryzen 7 2700X w/Wraith prism
x470 Taichi bios 3.50
16gb HX432C16PB3K2/16 (hynix H5AN8G8NCJR-UHC)
M.2 970 EVO, SATA SSD, 2 SATA HDD
AMD Radeon RX 580 8G OC
Linux Kernel 5.4
Manjaro Stable XFCE


Posted By: Andy_NTG
Date Posted: 21 Feb 2019 at 7:12pm
Originally posted by datonyb datonyb wrote:

set fan monitoring to tctl


Where is this item in BIOS?


Posted By: paologab
Date Posted: 21 Feb 2019 at 7:15pm
HI
dig into fan settings.
I cannot be more clear because I've the x470 where they're there.

-------------
AMD Ryzen 7 2700X w/Wraith prism
x470 Taichi bios 3.50
16gb HX432C16PB3K2/16 (hynix H5AN8G8NCJR-UHC)
M.2 970 EVO, SATA SSD, 2 SATA HDD
AMD Radeon RX 580 8G OC
Linux Kernel 5.4
Manjaro Stable XFCE


Posted By: paim0n
Date Posted: 28 Mar 2019 at 1:31pm
hey, i have AMD B450 Gaming K4, yesterday i have uploaded bios version to 3.10 and tctl option have gone ??


Posted By: asp
Date Posted: 28 Mar 2019 at 4:39pm
I did notice this as well, but I think they simply force tctl now as the only option. If you notice the fan tuning page, you will see on the CPU there is nothing selected for the options that are available, implying that it is locked to the invisible tctl. :-)

HWiNFO shows temps are reported the same with the mystery new setting, as they were set to tctl on mine.


Posted By: paologab
Date Posted: 29 Mar 2019 at 1:40am
Hi, are still tctrl 10 degree more than tdie?

-------------
AMD Ryzen 7 2700X w/Wraith prism
x470 Taichi bios 3.50
16gb HX432C16PB3K2/16 (hynix H5AN8G8NCJR-UHC)
M.2 970 EVO, SATA SSD, 2 SATA HDD
AMD Radeon RX 580 8G OC
Linux Kernel 5.4
Manjaro Stable XFCE


Posted By: kschendel
Date Posted: 29 Mar 2019 at 3:47am
Yes, I think the Tctrl vs Tdie offset is defined by AMD.


Posted By: paologab
Date Posted: 29 Mar 2019 at 4:41am
Yes I know that, I meant now, after they give up others sensors with this new bios version.

-------------
AMD Ryzen 7 2700X w/Wraith prism
x470 Taichi bios 3.50
16gb HX432C16PB3K2/16 (hynix H5AN8G8NCJR-UHC)
M.2 970 EVO, SATA SSD, 2 SATA HDD
AMD Radeon RX 580 8G OC
Linux Kernel 5.4
Manjaro Stable XFCE


Posted By: Katana_Ryzen
Date Posted: 05 Apr 2019 at 5:11pm
I test many B450 Boards and test OC too, and yes with Bios update 3.10 the Version Tctrl is deleted from bios, you can only Monitor MB or CPU. And the Standarts like Custom Silent and ??I ask Asrock a lot and the german support test for me too on a B450 Pro 4 and it works, but i say Asrock miss a Code in the System for check the Fan Control. Only good Fans atm work on the Board is Be Quiet or Noctua Fans, is horrible Design from Asrock. Tctrl can only to be activated via windows, and that over the Asrock program for the Fan Control.

I wish Asrock would work better with the Community on the Problem and would solve it because everyone eventually also paid money to get a reasonably clean system.


Posted By: paologab
Date Posted: 05 Apr 2019 at 7:04pm
Horrible!
thank you very much for the clou.

-------------
AMD Ryzen 7 2700X w/Wraith prism
x470 Taichi bios 3.50
16gb HX432C16PB3K2/16 (hynix H5AN8G8NCJR-UHC)
M.2 970 EVO, SATA SSD, 2 SATA HDD
AMD Radeon RX 580 8G OC
Linux Kernel 5.4
Manjaro Stable XFCE


Posted By: Katana_Ryzen
Date Posted: 09 Apr 2019 at 1:18am
With the newest BIOS, there will only be monitoring Tctrl and monitor MB provided..
Monitoring thermistor has been removed.
Also with Tctrl, we have tuned fan curves for it, so the fan should not be changing rapidly when choosing Tctrl as before.


Comes from Asrock Support))))



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net