Print Page | Close Window

Fatal1ty Z170 Gaming K4 can't update BIOS

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=998
Printed Date: 15 Apr 2024 at 1:12am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Fatal1ty Z170 Gaming K4 can't update BIOS
Posted By: scajjr2
Subject: Fatal1ty Z170 Gaming K4 can't update BIOS
Date Posted: 11 Oct 2015 at 2:49am
I have now tried all 3 ways to update the BIOS from 1.40 to 1.90 (DOS, Windows and Instant via the BIOS) and none install. Every one restarts after and just stays on the ASRock spalsh screen, does not respond to any keys (F2,DEL, F11), never shows any screen showing flash progress and I have to use the clear CMOS jumper to get it to boot to BIOS a/o windows 8.1 again. Something I need to do that's not in the instructions listed on their site? Didn't have any of these issues flashing my ASRock Z77 Pro 4 BIOS.

Sam





Replies:
Posted By: parsec
Date Posted: 11 Oct 2015 at 2:34pm
It sounds like your board has the UEFI/BIOS selection switch set to 'B', the backup UEFI/BIOS, which cannot be updated.

Each UEFI/BIOS chip has an LED that is on when it is selected. The selection switch is at the very bottom of the board, almost exactly in the middle, just to the right of a Chassis Fan header. It is possible that the switch was moved when you were installing the board, or any time you were doing something inside the PC case.

Just set it back to 'A', with the PC disconnected from power of course. I suggest checking the settings before letting the PC boot, and be sure is does boot and restart once or twice, before trying to update the UEFI/BIOS again.

I've never tried to update the backup UEFI/BIOS chip, so I don't know how the board reacts to that situation.

If that is not the issue, let us know.


-------------
http://valid.x86.fr/48rujh" rel="nofollow">


Posted By: ASRock Expert
Date Posted: 11 Oct 2015 at 4:18pm
It's a bit silly that a backup EEPROM could not be updated.

When You update your primary EEPROM, test it, and if everything is fine,
just replace the chips on the boards, switch their places,
and then You can update Your backup EEPROM too.

A bit pain to do, because You can always brake some pins, if not careful enough,
but for right now, it's the only way.




-------------
990FX Extreme 9 MOD P1.70
AMD FX 8120 4GHz 1.25V
Thermalright HR-02
Patriot Viper 2x4GB 2133MHz
Samsung 850 EVO 250GB
MSI R7970 TFIII 3GB
CORSAIR VX550W
LanCool K62 Dragonlord
ASUS Xonar D2X


Posted By: parsec
Date Posted: 12 Oct 2015 at 10:39am
The switch the chips method would work of course, that's where a chip removal tool would come in handy.

Otherwise two philosophies on allowing the backup UEFI/BIOS to be updated. Allow it or not at all.

Allowing the backup UEFI/BIOS to be updated is dangerous in the sense that it assumes updating it is a good thing. I have seen cases with another mother board manufacture's products that allow updating the backup UEFI/BIOS, where users updated it only to find it was a mistake to do so. That manufacture is infamous for their terrible UEFI/BIOS updates, with endless Beta versions that fix one thing (if they were lucky) but break two or more other things. They updated the backup chip with a version that changed the CPU microcode that removed the non-K OC capability, which they can never get back again without an update that changes the microcode back to the non-K OC version. There are other examples of updates that later were worse to have than the original backup UEFI/BIOS.

Not allowing any updates to the backup chip protects the user from themselves. I actually prefer this choice and know of situations where it would have been better for the user. Even for myself being very careful, I want a known, stable version that I can start from again. I would not update it even if I could.

I don't disagree with your ideas, but I prefer the no update to the backup BIOS, mainly for other users.


-------------
http://valid.x86.fr/48rujh" rel="nofollow">



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net