Print Page | Close Window

Never buying another ASRock product.

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=9998
Printed Date: 21 May 2024 at 5:45am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Never buying another ASRock product.
Posted By: AHamsterPig
Subject: Never buying another ASRock product.
Date Posted: 24 Oct 2018 at 2:07pm
So I have been dealing with asrock's terrible audio drivers ever since I bought this damn z370. Today marks the fourth time the Realtek Audio Control Panel has disappeared for seemingly no reason. Since day 1 the audio drivers on the asrock website have done nothing to resolve this issue. The only solution I've found is manually uninstalling the drivers and searching through Window's Driver Catalog in hopes of finding what seems to be the singular version of Realtek that actually works. Last time this happened I was fiddling around with drivers for nearly 3 hours before I fixed the issue. I specifically bought this mobo because of the competitive price and the onboard soundcard; now the latter has been rendered practically useless. At this point I'm so fed up dealing with this that I'd rather drop an extra $200 for an Asus board. As soon as I can, I'm getting Ryzen 2 and ANY other mobo besides an ASRock.Angry



Replies:
Posted By: Globespy
Date Posted: 25 Oct 2018 at 5:32am
Originally posted by AHamsterPig AHamsterPig wrote:

So I have been dealing with asrock's terrible audio drivers ever since I bought this damn z370. Today marks the fourth time the Realtek Audio Control Panel has disappeared for seemingly no reason. Since day 1 the audio drivers on the asrock website have done nothing to resolve this issue. The only solution I've found is manually uninstalling the drivers and searching through Window's Driver Catalog in hopes of finding what seems to be the singular version of Realtek that actually works. Last time this happened I was fiddling around with drivers for nearly 3 hours before I fixed the issue. I specifically bought this mobo because of the competitive price and the onboard soundcard; now the latter has been rendered practically useless. At this point I'm so fed up dealing with this that I'd rather drop an extra $200 for an Asus board. As soon as I can, I'm getting Ryzen 2 and ANY other mobo besides an ASRock.Angry

Not to put a damper on your day, but this audio issue is across literally every Z370 board that has the Realtek ALC1220 chipset. If you can find much older drivers (the original ones), they seem to work ok, however may still have issues with the front panel (headphones for most users) not working properly.

Don't wast your money on another board like this as your problems will still be there - go check the Asus, Gigabyte, MSI forums and you will find the same issues. The only board that might be the exception right now is the MSI Z370-a Carbon as it uses a slightly different variant of the Realtek chipset we have in this board.

I eventually gave up and just use the generic Microsoft HD Audio drivers that for the most part work well.
The Realtek HD Audio Manager doesn't really offer you much functionality to be honest. And the Realtek drivers can't differentiate between headphones and desktop speakers so it's a pretty useless combination.
The Microsoft drivers on the other hand have no issues showing you both headphones and desktop speakers simultaneously and the sound quality is every bit as good as the Realtek drivers, if not better.
All the motherboard manufacturers are just ignoring the issue, blaming Realtek and Nvidia and Microsoft, and Realtek and Nvidia blame everyone else.
Personally I can't fault Microsoft in this matter - surely each peripheral manufacturer has the responsibility to their customer to make sure that the boards they build and sell are compatible with the hardware and drivers required? 
Reality is they don't care.

If you really want great sound you should invest in a dedicated sound card - not what the marketing garbage would want you to believe, but I think you have experienced just how bad onboard sound solutions can be.

Good luck with whatever you do.


Posted By: Edropian
Date Posted: 26 Feb 2019 at 6:19am
Originally posted by Globespy Globespy wrote:

Originally posted by AHamsterPig AHamsterPig wrote:

So I have been dealing with asrock's terrible audio drivers ever since I bought this damn z370. Today marks the fourth time the Realtek Audio Control Panel has disappeared for seemingly no reason. Since day 1 the audio drivers on the asrock website have done nothing to resolve this issue. The only solution I've found is manually uninstalling the drivers and searching through Window's Driver Catalog in hopes of finding what seems to be the singular version of Realtek that actually works. Last time this happened I was fiddling around with drivers for nearly 3 hours before I fixed the issue. I specifically bought this mobo because of the competitive price and the onboard soundcard; now the latter has been rendered practically useless. At this point I'm so fed up dealing with this that I'd rather drop an extra $200 for an Asus board. As soon as I can, I'm getting Ryzen 2 and ANY other mobo besides an ASRock.Angry


Not to put a damper on your day, but this audio issue is across literally every Z370 board that has the Realtek ALC1220 chipset. If you can find much older drivers (the original ones), they seem to work ok, however may still have issues with the front panel (headphones for most users) not working properly.

Don't wast your money on another board like this as your problems will still be there - go check the Asus, Gigabyte, MSI forums and you will find the same issues. The only board that might be the exception right now is the MSI Z370-a Carbon as it uses a slightly different variant of the Realtek chipset we have in this board.

I eventually gave up and just use the generic Microsoft HD Audio drivers that for the most part work well.
The Realtek HD Audio Manager doesn't really offer you much functionality to be honest. And the Realtek drivers can't differentiate between headphones and desktop speakers so it's a pretty useless combination.
The Microsoft drivers on the other hand have no issues showing you both headphones and desktop speakers simultaneously and the sound quality is every bit as good as the Realtek drivers, if not better.
All the motherboard manufacturers are just ignoring the issue, blaming Realtek and Nvidia and Microsoft, and Realtek and Nvidia blame everyone else.
Personally I can't fault Microsoft in this matter - surely each peripheral manufacturer has the responsibility to their customer to make sure that the boards they build and sell are compatible with the hardware and drivers required??
Reality is they don't care.

If you really want great sound you should invest in a dedicated sound card - not what the marketing garbage would want you to believe, but I think you have experienced just how bad onboard sound solutions can be.

Good luck with whatever you do.


Well ... I was also myself one who bought this board for the ability for the onboard card to drive high impedance (600hm) headphones and everything was fine until I decided to update the damn drivers ....

Front panel audio started to have upside downs and distortion unless you crank the volume up completely which is impossible to deal with :S

I was and still am troubleshooting the issue and the only out I found was to use the Windows Drivers and a Universal Driver Pack (realteck) I managed to find from Digging the web.

Unfortunately, the windows Drivers won't drive high impedance headphones properly from the front panel audio which forced me to try and use the audio jacks from other USB devices which are attached to my system to get done with it ... which practically means that my front panel onboard audio is "SCRAP"!

To add another issue to your pile here ... front panel mic will also "record" whatever sound the pc will generate (even if a mic is not attached) and broadcast it to others like if I was doing it (note that I am saying that there is no mic attached ;) ) ... this happens especially with discord and it forces me to mute myself or use push to talk ...

-------------
Fatal1ty Z370 Professional Gaming i7 / i7 8700K / HX1000i / H100i / F4-3200C14D-16GTZ



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net