ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Fail to install WIN10
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Fail to install WIN10

 Post Reply Post Reply
Author
Message
Dungeonkeeper View Drop Down
Newbie
Newbie


Joined: 11 Nov 2017
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dungeonkeeper Quote  Post ReplyReply Direct Link To This Post Topic: Fail to install WIN10
    Posted: 23 Apr 2019 at 11:23am
I have a problem installing WIN10 OS on my M.2 on ab350M pro4
Not sure system detect M.2 or not and no idea where to check it.
So please someone can teach me how to do it?
I am a rookie.
Thanks.
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 8592
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 23 Apr 2019 at 12:09pm
Dear Dungeonkeeper,

Greetings, this is ASRock TSD.


If you'd like to install Windows 10 OS on your M.2 drive, please refer to the steps below:

1. Remove the entire storage device from motherboard; only install M.2 SSD to M.2_1 slot.

2. Boot system into BIOS setup and make sure the SSD is detected under BIOS>Advanced tab>Storage device. If so, please press [F9] to load BIOS default and press [F10] to save the setting and exit.

3. Install the Windows 10 installation media (USB or CD/DVD) and power on the system; press [F11] when seeing the post screen to enter Boot Menu; select your Windows 10 installation media (USB or CD/DVD) to boot.

* If your M.2 is NVMe type SSD, be sure to install OS in UEFI mode (GPT partition). To do this, please select your Windows 10 media with "UEFI" in front to post in Boot Menu.

4. If successful, following the Windows 10 installation process to install OS.


Thanks!

All the best,
ASRock TSD
Back to Top
JustGalaxy View Drop Down
Newbie
Newbie
Avatar

Joined: 22 Apr 2021
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote JustGalaxy Quote  Post ReplyReply Direct Link To This Post Posted: 22 Apr 2021 at 4:36am
I Dont Know Why But My Thing Keeps Black Screening After I Try. Any Reason Why?
Back to Top
ket View Drop Down
Senior Member
Senior Member


Joined: 13 Jul 2017
Location: UK
Status: Offline
Points: 1676
Post Options Post Options   Thanks (0) Thanks(0)   Quote ket Quote  Post ReplyReply Direct Link To This Post Posted: 22 Apr 2021 at 10:30pm

Describe what you mean by "black screening". Also what make and model is your M.2 SSD?

Here are some simple steps you can try;

1. If you haven't already make a bootable USB stick with Win10 on (easy to do, google and use Media Creation Tool)
2. Remove the battery from your mainboard and pull out the power cord, press the power button 3-4 times to discharge the capacitors.
3. Disconnect all other optical and storage drives you might have
4. Put the power cord and battery back, power on
5. Try installing Win10

With the UEFI reset and the M.2 drive being the only storage device attached to the system you shouldn't have any problems with incorrectly set boot priorities.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.176 seconds.