ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - No OS Boot without a graphics card
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

No OS Boot without a graphics card

 Post Reply Post Reply Page  12>
Author
Message Reverse Sort Order
hats0id View Drop Down
Newbie
Newbie
Avatar

Joined: 15 Apr 2021
Status: Offline
Points: 30
Post Options Post Options   Thanks (0) Thanks(0)   Quote hats0id Quote  Post ReplyReply Direct Link To This Post Topic: No OS Boot without a graphics card
    Posted: 16 Apr 2021 at 12:47am
Update - centos 7 boots well without graphics. Proxmox VE 6.3 does not boot.
Back to Top
hats0id View Drop Down
Newbie
Newbie
Avatar

Joined: 15 Apr 2021
Status: Offline
Points: 30
Post Options Post Options   Thanks (0) Thanks(0)   Quote hats0id Quote  Post ReplyReply Direct Link To This Post Posted: 15 Apr 2021 at 11:19pm
I have some hosts on Asrock mainboards where i have inetl F without graphics and i can boot OS without any problems.

Asrock B460M Pro4 with i7-10700F   = OK
Asrock H370 Pro4 with i3-9100F     = OK
Asrock B460M-ITX/ac with i5-10400F = OK

Recently i purchased Gigabyte B460M DS3H with refused to boot with i5-10400F. I was thinking that it Gigabyte MB issue and last time i purchased again Asrock H470M-HVS and you know what? I can't boot OS without graphics. I have tried almost every option in BIOS and no luck.

BTW - i have checked OS logs and system try to BOOT, but something in the end goes wrong. Neworking is not starting, so i can't access it using ssh. We need a specialist to solve this.

/var/log/kern.log without graphics:

Apr 15 17:50:02 43oz-pve1 kernel: [    3.859298] softdog: initialized. soft_noboot=0 soft_margin=60 sec soft_panic=0 (nowayout=0)
Apr 15 17:50:02 43oz-pve1 kernel: [    3.860507] new mount options do not match the existing superblock, will be ignored
Apr 15 17:50:02 43oz-pve1 kernel: [    4.022705] bpfilter: Loaded bpfilter_umh pid 1173

/var/log/kern.log with graphics installed:

Apr 15 18:03:53 43oz-pve1 kernel: [    4.557232] softdog: initialized. soft_noboot=0 soft_margin=60 sec soft_panic=0 (nowayout=0)
Apr 15 18:03:53 43oz-pve1 kernel: [    4.561911] new mount options do not match the existing superblock, will be ignored
Apr 15 18:03:53 43oz-pve1 kernel: [    4.596775] vmbr0: port 1(enp2s0) entered blocking state
Apr 15 18:03:53 43oz-pve1 kernel: [    4.597609] vmbr0: port 1(enp2s0) entered disabled state

Without grahics networking is not starting. Any ideas?
Back to Top
TemporaryPerson View Drop Down
Newbie
Newbie
Avatar

Joined: 15 Sep 2020
Location: London
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote TemporaryPerson Quote  Post ReplyReply Direct Link To This Post Posted: 15 Sep 2020 at 6:57pm
Late to the party, but: I've been able to boot without an attached monitor on an asrock b460m-itx/ac after enabling CSM in the BIOS. Otherwise, I got 5 beeps from the chassis speaker, and no boot.
Back to Top
kschendel View Drop Down
Newbie
Newbie


Joined: 21 Aug 2018
Status: Offline
Points: 86
Post Options Post Options   Thanks (0) Thanks(0)   Quote kschendel Quote  Post ReplyReply Direct Link To This Post Posted: 02 May 2019 at 6:10am
I had to reboot just now so wandered through the BIOS, didn't see anything that sounded like allow headless boot except possibly for the boot splash screen option under Boot - I didn't experiment but you could try it.

I found a reddit posting where someone claimed to be able to boot headless with one of the Gigabyte B450 boards. The interesting bit is that Gigabyte told him no, that doesn't work, you have to have a GPU!
Back to Top
alinthda View Drop Down
Newbie
Newbie


Joined: 30 Apr 2019
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote alinthda Quote  Post ReplyReply Direct Link To This Post Posted: 02 May 2019 at 5:17am
yes apparently I have no choice. I am disappointed with Asrock. Thanks for your help
Back to Top
xhue View Drop Down
Groupie
Groupie


Joined: 17 Aug 2018
Status: Offline
Points: 634
Post Options Post Options   Thanks (0) Thanks(0)   Quote xhue Quote  Post ReplyReply Direct Link To This Post Posted: 01 May 2019 at 7:44pm
Most discrete GPU have a really low power draw in idle, while not feeding a monitor, e.g. 12-25W. Some have even lower power sip.

For 24/7 usage it really adds up, but what are your other options?
Back to Top
alinthda View Drop Down
Newbie
Newbie


Joined: 30 Apr 2019
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote alinthda Quote  Post ReplyReply Direct Link To This Post Posted: 01 May 2019 at 7:21am
I have gpu, that's not the problem. Only for power consumption I do not want a gpu. ASRock allows it with Intel and not with AMD? weird
Back to Top
xhue View Drop Down
Groupie
Groupie


Joined: 17 Aug 2018
Status: Offline
Points: 634
Post Options Post Options   Thanks (0) Thanks(0)   Quote xhue Quote  Post ReplyReply Direct Link To This Post Posted: 01 May 2019 at 5:17am
There might be one. I am just not aware of it.

You can also try emailing tech support for more info.

Or you could get a $100 server/VM AMD GPU.
Back to Top
alinthda View Drop Down
Newbie
Newbie


Joined: 30 Apr 2019
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote alinthda Quote  Post ReplyReply Direct Link To This Post Posted: 01 May 2019 at 5:08am
There is no solution? No adjustment possible in the bios?
Back to Top
xhue View Drop Down
Groupie
Groupie


Joined: 17 Aug 2018
Status: Offline
Points: 634
Post Options Post Options   Thanks (0) Thanks(0)   Quote xhue Quote  Post ReplyReply Direct Link To This Post Posted: 01 May 2019 at 3:09am
It is an ASRock thing. Ryzens and TRs can run headless servers without any issue.

It's the mobo that actually checks for a GPU during POST and refuses to boot without one.
Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.125 seconds.