ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Won?t recognize my M2 drive
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Won?t recognize my M2 drive

 Post Reply Post Reply
Author
Message
Toukon View Drop Down
Newbie
Newbie


Joined: 11 Nov 2017
Status: Offline
Points: 19
Post Options Post Options   Thanks (0) Thanks(0)   Quote Toukon Quote  Post ReplyReply Direct Link To This Post Topic: Won?t recognize my M2 drive
    Posted: 08 Jul 2019 at 11:32am
ASROCK B450M PRO4 won?t recognize my M2.
The manual is worst and no help.
Can anyone give me a hand, please?
I change another 2400G CPU but same result.
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 8277
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 08 Jul 2019 at 12:28pm
Dear Toukon,

Greetings, this is ASRock TSD.


B450M Pro4 supports 2 M.2 slot, M2_1 slot supports PCIe type SSD, M.2_2 slot supports SATA type SSD. Be sure connecting to the correct M.2 slot.
https://www.asrock.com/MB/AMD/B450M%20Pro4/index.asp#Specification

If the SSD still cannot be detected, we provide some suggestions for verifying:

1. Please refer to user manual page.26 to clear CMOS.
http://asrock.pc.cdn.bitgravity.com/Manual/B450M%20Pro4.pdf

2. Cut off the AC power and reinstall the M.2 module to M.2 slot.
Then power on system to BIOS and check the detection.

3. Only install bare bone devices, CPU, one stick memory, M.2 SSD and using onboard graphics to verify.

4. If possible, please install another M.2 SSD to verify.

5. If possible, please install your M.2 SSD to another system to verify.


Thanks!

All the best,
ASRock TSD
Back to Top
Toukon View Drop Down
Newbie
Newbie


Joined: 11 Nov 2017
Status: Offline
Points: 19
Post Options Post Options   Thanks (0) Thanks(0)   Quote Toukon Quote  Post ReplyReply Direct Link To This Post Posted: 12 Jul 2019 at 3:57pm
the reason is broken N.2 device
replace a new everything is okay!
Thanks guys.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.125 seconds.