Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Asrock x570 Pro4 not posting - CPU and DRAM PSC
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Asrock x570 Pro4 not posting - CPU and DRAM PSC

 Post Reply Post Reply
dooky710 View Drop Down

Joined: 13 Nov 2019
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote dooky710 Quote  Post ReplyReply Direct Link To This Post Topic: Asrock x570 Pro4 not posting - CPU and DRAM PSC
    Posted: 13 Nov 2019 at 4:19am
PCPartPicker Part List:

CPU: AMD Ryzen 5 3600X 3.8 GHz 6-Core Processor ($234.37 @ Amazon)
Motherboard: MSI MPG X570 GAMING PLUS ATX AM4 Motherboard ($162.99 @ B&H)
Memory: G.Skill Trident Z 16 GB (2 x 8 GB) DDR4-3600 Memory ($109.99 @ Newegg)
Storage: Intel 660p Series 1.02 TB M.2-2280 NVME Solid State Drive ($97.99 @ Newegg)
Video Card: MSI Radeon RX 5700 8 GB MECH OC Video Card ($359.99 @ B&H)
Case: Cooler Master HAF XB EVO ATX Desktop Case ($109.99 @ Amazon)
Power Supply: Corsair CSM 750 W 80+ Gold Certified Semi-modular ATX Power Supply
Operating System: Microsoft Windows 10 Home OEM 64-bit ($98.99 @ Amazon)

Hey all,

My Asrock x570 Pro4 isn't posting and has the CPU and DRAM PSC lights are lit for ~10 seconds then the computer will reboot.

I legit can't find any info about the PSC (Post Status Checker) lights for the Asrock mobos from the Asrock site. I've used their search features and several posts show up regarding the same problem as me. With this issue, most people have a power issue, CPU issue, or mobo is dead. Heres the catch, I have booted on an MSI x570 gaming plus with this CPU and power supply (TLDR; MSI x570 was defective and got RMA'd and there wasnt a replacement so I was refunded and got an Asrock. RAM I have now is QVL checked against the Asrock mobo and is good by them). So my thoughts are that the mobo is bad. However, what would be the chances of getting 2 mobos that are both defective back to back? My power supply is from an old build (like 8 years ago old). I figured that it would be good to still use.

My current plan is to reseat the CPU tonight and try again. If that doesnt work, I'm thinking about getting a new PS since mines old. I've already tried reseating the RAM, using 1 sitck at a time in all port while clearing CMOS between tests. I've triple checked my PSU connections are plugged in and proper (IE PCIe wasnt going to mobo 8 pin). I let the boot -> 10s CPU/DRAM lit -> reboot cycle happen for ~ 5 minutes and still no dice - I read somewhere that Ryzen can take upto 3 reboot cycles to post. I'm running out of ideas for troubleshooting stuff and I'm coming to you guys to see if theres something I'm missing.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.164 seconds.