ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Mobo B450M Pro4-f doesn't boot screen off
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Mobo B450M Pro4-f doesn't boot screen off

 Post Reply Post Reply
Author
Message
Aleonardi View Drop Down
Newbie
Newbie


Joined: 04 Jan 2020
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Aleonardi Quote  Post ReplyReply Direct Link To This Post Topic: Mobo B450M Pro4-f doesn't boot screen off
    Posted: 04 Jan 2020 at 4:39am
I finished assembling a new PC. I'm not new in such matter. I followed the ASrock manual procedures and when I switched on the pc the mouse, keyboard, ssd, DVD, start working but the screen remained dark and "no signal" appeared. It was impossible to enter in the BIOS. After few second 5 beeps came out. The viedeo was switched on and setteted to HDMI input and tested on other computer it works pretty well.
I tried to unplug all the peripherial but the results were always the same.

The PC configuration is the following.
MOBO ASrock B450M Pro4-f
CPU Ryzen 2700
RAM 4 Corsair Vengeance LPX DDR4 CMK16GX4M2B3200C16R
SSD SATA III 960 GB
GPU Integrated (no esternal GPU installed)

Could you help me to understand wath's wrong?
Back to Top
jdillipl View Drop Down
Newbie
Newbie


Joined: 03 Aug 2017
Location: USA
Status: Offline
Points: 159
Post Options Post Options   Thanks (0) Thanks(0)   Quote jdillipl Quote  Post ReplyReply Direct Link To This Post Posted: 05 Jan 2020 at 5:57am
There is no GPU integrated on the motherboard. There is integrated graphics in a Ryzen series APU. The Ryzen 7 2700 is not an APU. Looking at page 6 of the Quick Installation Guide:

Integrated AMD RadeonTM Vega Series Graphics in Ryzen
Series APU*

Do you happen to have a spare video card for testing?

Jake
Asrock X370 Killer SLI/ac, Amd Ryzen 7 1700, GSkill FlareX F4-2400C16D-32GFX, RaidMax Thunder V2 735W PS
Back to Top
Aleonardi View Drop Down
Newbie
Newbie


Joined: 04 Jan 2020
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Aleonardi Quote  Post ReplyReply Direct Link To This Post Posted: 07 Jan 2020 at 12:33am
Manu thanks, I tried with a graphic card and the PC is working perfectly
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.375 seconds.