ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - (Solved)cd/dvd driver no show in Device Manager
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Topic Closed(Solved)cd/dvd driver no show in Device Manager

 Post Reply Post Reply
Author
Message
Kerry View Drop Down
Newbie
Newbie


Joined: 22 Aug 2017
Status: Offline
Points: 213
Direct Link To This Post Topic: (Solved)cd/dvd driver no show in Device Manager
    Posted: 23 Feb 2020 at 9:56am

I upgraded the BIOS on my Z97Pro4 to v2.60 and added an M.2 SSD and did a clean install of Windows 10 Pro on to it. It appears to be working correctly. I now have the option of booting to the old C: or the new M.2 C: Once everything is working I'll delete the old C:

Is there a setting in the BIOS that allows the MOBO to see my onboard cd/dvd optical player? It worked before. The Device Manager doesn't show cd/dvd.

Thanks, Kerry
Windows 10Pro
Z97Pro4

Edited by ASRock_TSD - 02 Mar 2020 at 11:29am
Back to Top
RLGL View Drop Down
Senior Member
Senior Member
Avatar

Joined: 29 Jul 2018
Location: MN
Status: Offline
Points: 1995
Direct Link To This Post Posted: 23 Feb 2020 at 10:47pm
Are you sure it is properly connected?
Asrock Z370 Gaming K6,Intel i7 8700K,
Asrock x570 Taichi

Back to Top
Kerry View Drop Down
Newbie
Newbie


Joined: 22 Aug 2017
Status: Offline
Points: 213
Direct Link To This Post Posted: 24 Feb 2020 at 4:41am
Thanks RLGL,
It's a possibility. I'll open it up and check. I'll post the results.
Kerry
Back to Top
Kerry View Drop Down
Newbie
Newbie


Joined: 22 Aug 2017
Status: Offline
Points: 213
Direct Link To This Post Posted: 24 Feb 2020 at 11:15am
I checked and it appears to still be connected.

It has been working for years and stopped working after I updated the BIOS, added an M.2 SSD and and did a clean install of Windows 10 Pro on the M.2.
I get "no driver" whether I boot to the old C: or the new M.2 drive.

I'll try another clean install of W10 on the M.2.
Thanks, Kerry
Back to Top
Kerry View Drop Down
Newbie
Newbie


Joined: 22 Aug 2017
Status: Offline
Points: 213
Direct Link To This Post Posted: 28 Feb 2020 at 5:42am
Update:

I disconnected the CD/DVD player and booted up. I then shut down and reconnected the CD/DVD player and booted up and W10 apparently recognized the player; it now works. Whew!!
Thanks all,
Kerry
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.109 seconds.